OpenVZ Forum


Home » General » Support » issues with ulogd2
issues with ulogd2 [message #52702] Thu, 29 December 2016 11:55
nestor is currently offline  nestor
Messages: 1
Registered: December 2016
Junior Member
From: 152.206.137*
Hi,

I am using an OpenVZ-based VPS service (running Debian 8 x86_64) and I have been trying to load the ulogd2 service, but it keeps giving problems. See this:

# service ulogd2 status
[FAIL] ulogd is not running ... failed!

# service ulogd2 start
[ ok ] Starting netfilter userspace log daemon: ulogd.

# service ulogd2 status
[FAIL] ulogd is not running ... failed!


See the relevant content of daemon.log:

Dec 29 11:40:06 myserver ulogd[5604]: building new pluginstance stack: 'log1:NFLOG,base1:BASE,ifi1:IFINDEX,ip2str1:IP2STR,print1:PRINTPKT,emu1:LOGEMU'
Dec 29 11:40:06 myserver ulogd[5604]: forcing unbind of existing log handler for protocol 2
Dec 29 11:40:06 myserver ulogd[5604]: forcing unbind of existing log handler for protocol 10
Dec 29 11:40:06 myserver ulogd[5604]: forcing unbind of existing log handler for protocol 7
Dec 29 11:40:06 myserver ulogd[5604]: unable to bind to log group 0
Dec 29 11:40:06 myserver ulogd[5604]: error starting `log1'
Dec 29 11:40:06 myserver ulogd[5604]: not even a single working plugin stack


I thought this might be caused because group 0 could be in use by someone else, but I changed it in ulogd.conf to 1 (and then to 2) and when I tried to try to start the service again, the same thing happened.

A few months back I had used another OpenVZ-based VPS service (from another provider) and there ulogd started just fine.

You see, I like redirecting netfilter logs to a file so I can monitor in real time what is happening (using something like tail -f or multitail) and making security adjusments as needed.

Any ideas on how to solve this problem? Thanks in advance.
Previous Topic: CentOS 7.x and OpenVZ
Next Topic: OpenVZ 7 Startup problems
Goto Forum:
  


Current Time: Mon Apr 24 03:32:54 GMT 2017