OpenVZ Forum


Home » General » Support » Strange memory issue in openvz CT
Strange memory issue in openvz CT [message #52689] Fri, 09 December 2016 09:32
jazzl0ver is currently offline  jazzl0ver
Messages: 1
Registered: December 2016
Junior Member
From: *abisoft.spb.ru
Hello.

I've got very strange issue with openvz container memory. In short, the OS in the container eats all available memory, so it shows 0k free. I can't say that the system feels bad, the only issue at the moment is that our nagios alarms about no free memory. The longer story is here: https://forum.proxmox.com/threads/strange-memory-issue-in-op envz-ct.30844/

top - 12:31:00 up 6 days, 10:30,  1 user,  load average: 0.00, 0.00, 0.00
Tasks:  53 total,   1 running,  52 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.2%us,  0.1%sy,  0.0%ni, 99.6%id,  0.1%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   2097152k total,  2097152k used,        0k free,        0k buffers
Swap:        0k total,        0k used,        0k free,   407592k cached


# free -m
             total       used       free     shared    buffers     cached
Mem:          2048       2048          0        802          0        397
-/+ buffers/cache:       1650        397
Swap:            0          0          0

# uname -a
Linux vm-box-4 2.6.32-48-pve #1 SMP Fri Nov 25 06:28:35 CET 2016 x86_64 GNU/Linux

# vzcalc -v 112
Resource     Current(%)  Promised(%)  Max(%)
Low Mem          0.91 549375301828.06 549375301828.06
Total RAM        9.65        n/a        n/a
Mem + Swap       6.82 219750120705.05        n/a
Alloc. Mem       8.00 219750120705.05 225243873716124.31
Num. Proc        0.04        n/a 7210434920186352.00
--------------------------------------------
Memory           9.65 549375301828.06 7210434920186352.00


Can anyone help me with that, please?
Previous Topic: Ploop compact not working - Call FITRIM loop
Next Topic: VZ7 Win 2008 , 2012 VM paused
Goto Forum:
  


Current Time: Fri Jun 23 19:01:34 GMT 2017