OpenVZ Forum


Home » General » Support » util-linux-ng with dependency for rhel kernel (util-linux-ng with dependency for rhel kernel no update of openvz centos/rhel 6.8 VEs)
util-linux-ng with dependency for rhel kernel [message #52687] Thu, 08 December 2016 09:35 Go to next message
sabine77 is currently offline  sabine77
Messages: 2
Registered: May 2016
Location: Frankfurt
Junior Member
From: 89.106.185*
Hello everybody,

the latest version of util-linux-ng has a dependency for rhel kernel, which prevents us from updating all our Centos 6.8 and RHEL 6.8 VEs.

https://rhn.redhat.com/errata/RHBA-2016-2748.html

* Previously, after updating the util-linux-ng packages to version 2.17.2 on Red
Hat Enterprise Linux 6.8, a corresponding kernel update was not pulled due to a
missing RPM dependency in the util-linux-ng spec file. As a consequence, a
telnet corruption occurred, and a kernel update with a subsequent reboot was
required.

Redhat offers a workaround (exclude=kernel* util-linux-ng*), but never updating util-linux-ng again, would not be my prefered solution.
https://access.redhat.com/solutions/2796421

I would also not prefer to rebuild util-linux-ng for each release.

Right now, this seems only to be the case for COS/RHEL 6 and not for COS/RHEL7.

Maybe there is a chance to complain, as I am pretty sure that we are not the only ones who are affected.

Or maybe somebody has other ideas/solutions?

Greetings, Sabine
Re: util-linux-ng with dependency for rhel kernel [message #52708 is a reply to message #52687] Thu, 05 January 2017 16:59 Go to previous message
faris is currently offline  faris
Messages: 2
Registered: July 2012
Location: UK
Junior Member
From: *cymru1.org
I just went ahead and upgraded, allowing the kernel to be installed. It did no harm, other than take up some unnecessary space.

I'm sure there may be better options, but this is what I did.

Note that this was commercial VZ not OpenVZ, but there should be no difference in this situation.
Previous Topic: Converting OpenVZ to `KVM not working anymore
Next Topic: vzquotamod is needed by vzquota-3.1-1.x86_64
Goto Forum:
  


Current Time: Wed May 24 11:49:49 GMT 2017