OpenVZ Forum


Home » General » Support » USB devices don't show in prlsrvctl info listing
USB devices don't show in prlsrvctl info listing [message #52582] Fri, 07 October 2016 08:54 Go to next message
constb is currently offline  constb
Messages: 5
Registered: August 2016
Location: Tomsk, Russia
Junior Member
From: *tomtelnet.ru
hello. I have a problem.

I'm trying to attach a USB device to a VM as described at https://docs.openvz.org/openvz_users_guide.webhelp/_assignin g_usb_devices_to_virtual_machines.html

Unfortunately it ends for me on the very first step - I issue "prlsrvctl info" command and its output contains no USB devices at all. Nevertheless when I connect and disconnect it, I see /dev/usb/hiddev1 appear and disappear on host, so kernel sees them. Also /dev/usb/hiddev0 (apparently keyboard) is also always present.

"prlsrvctl info" says:

[root@vz01 dev]# prls info -f
ID: {b9899efb-db86-4aae-8dbc-b0c2e131fb8c}
Hostname: 127.0.0.1
Version: Server 7.0.451
VM home: /vz/vmprivate
Memory limit: auto
Minimal security level: low
Manage settings for new users: deny
CEP mechanism: on
Backup path: /vz/vmprivate/backups
Backup temporary directory:
Backup timeout: 3600
Traffic shaping: off
CPU model: Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
CPU features: physical_address_bits=0 virtual_address_bits=0
VM guest CPU limit type: full
CPU unmaskable features:
CPU masked features:
Verbose log: off
License: state='not installed'
Hardware Id: ''
Hardware info:
     hdd  WDC WD10EZEX-00Z ATA (/dev/sdc)          '/dev/disk/by-id/ata-WDC_WD10EZEX-00ZF5A0_WD-WMC1S2379421'
     hdd  WDC WD10EZEX-00Z ATA (/dev/sdd)          '/dev/disk/by-id/ata-WDC_WD10EZEX-00ZF5A0_WD-WMC1S2385425'
     hdd  WDC WD5003AZEX-0 ATA (/dev/sda)          '/dev/disk/by-id/ata-WDC_WD5003AZEX-00K1GA0_WD-WMC1S6119275'
     hdd  WDC WD5003AZEX-0 ATA (/dev/sdb)          '/dev/disk/by-id/ata-WDC_WD5003AZEX-00K1GA0_WD-WMC1S6119588'
     hdd  /dev/md126                               '/dev/disk/by-id/md-name-localhost.localdomain:root'
     hdd  /dev/md127                               '/dev/disk/by-id/md-name-localhost.localdomain:swap'
     hdd  /dev/md124                               '/dev/disk/by-id/md-name-localhost.localdomain:vz'
     hdd  /dev/md125                               '/dev/disk/by-id/md-name-openvz_boot'
     hdd  /dev/md127                               '/dev/disk/by-id/md-uuid-2d53a0f1:341bfe28:9e807dcc:1d0b1644'
     hdd  /dev/md124                               '/dev/disk/by-id/md-uuid-7d111837:23058702:ed0ea531:30052a04'
     hdd  /dev/md126                               '/dev/disk/by-id/md-uuid-df8a1578:fedd91d9:e44bc84a:9077bfdb'
     hdd  /dev/md125                               '/dev/disk/by-id/md-uuid-e5d6a0b3:355e7134:156cabfe:f185f2cb'
     hdd  WDC WD10EZEX-00Z ATA (/dev/sdc)          '/dev/disk/by-id/wwn-0x50014ee058da6d2f'
     hdd  WDC WD5003AZEX-0 ATA (/dev/sda)          '/dev/disk/by-id/wwn-0x50014ee058f5a8be'
     hdd  WDC WD10EZEX-00Z ATA (/dev/sdd)          '/dev/disk/by-id/wwn-0x50014ee0ae301111'
     hdd  WDC WD5003AZEX-0 ATA (/dev/sdb)          '/dev/disk/by-id/wwn-0x50014ee0ae4b3e39'
   cdrom  Default CD/DVD-ROM                       'Default CD/DVD-ROM'
     net  vme42328909                              'vme42328909'
     net  veth42695b06                             'veth42695b06'
     net  veth422bbe1d                             'veth422bbe1d'
     net  enp3s0                                   'enp3s0'


What do I do?
Re: USB devices don't show in prlsrvctl info listing [message #52585 is a reply to message #52582] Fri, 07 October 2016 09:26 Go to previous message
constb is currently offline  constb
Messages: 5
Registered: August 2016
Location: Tomsk, Russia
Junior Member
From: *tomtelnet.ru
Additionally I discovered lines in "/var/log/messages" lines that describe what happened when I was attaching device:

Oct  7 15:41:22 vz01 kernel: usb 1-13: new low-speed USB device number 4 using xhci_hcd
Oct  7 15:41:22 vz01 kernel: usb 1-13: New USB device found, idVendor=0fde, idProduct=ca01
Oct  7 15:41:22 vz01 kernel: usb 1-13: New USB device strings: Mfr=0, Product=1, SerialNumber=0
Oct  7 15:41:22 vz01 kernel: usb 1-13: Product: Universal Bridge
Oct  7 15:41:22 vz01 kernel: hid-generic 0003:0FDE:CA01.0003: hiddev0,hidraw2: USB HID v1.10 Device [Universal Bridge] on usb-0000:00:14.0-13/input0


And when I disconnected it:

Oct  7 15:48:33 vz01 kernel: usb 1-13: USB disconnect, device number 4
Oct  7 15:48:33 vz01 systemd-udevd: error opening USB device 'descriptors' file
Previous Topic: Regression IPv6 Source address, compilation error
Next Topic: How to update?
Goto Forum:
  


Current Time: Thu Dec 12 11:53:05 GMT 2019