OpenVZ Forum


Home » General » Support » Traffic shaping not working for VMs? (Is traffic shaping works for you?)
Traffic shaping not working for VMs? [message #52541] Thu, 01 September 2016 06:28
JimmFrem is currently offline  JimmFrem
Messages: 10
Registered: September 2016
Location: Europe
Junior Member
From: *iv.lt
Hi,

I've been trying to set up traffic shaping for virtual machines for about a week, but without success.

My /etc/vz/vz.conf:

traffic_shaping=yes
ratebound=yes
rate="*:3:1024"


My /etc/vz/conf/network_classes:

# Example of networks_classes file
# To get full power of traffic management system
# please define HW node IP networks and your traffic
# classification as described below.

# HW node VPS's networks
0 My_local_IP/24 
#0 10.10.15.0/24

# all IP("local" traffic)
1 0.0.0.0/0

# class 2 - "foreign" traffic
#2 31.14.177.0/16
3 My_destination_testing_IP/32


# inside "foreign" network there
# is a hole with "local" traffic
#1 10.10.16.0/24

# all IPv6("local" traffic)
#1 ::0/0


I also set --rate 3:1024 and --ratebound yes/on for my testing VM

I log in my VM, and try to upload file to my destination testing IP, but the limitation does not work.

From the host, I see that it is using 3rd network class:

	net.classful.traffic.ipv4  0                    0          0                44695        234
	net.classful.traffic.ipv4  1             15017036      46423             39807657      37287
	net.classful.traffic.ipv4  2                    0          0                    0          0
	net.classful.traffic.ipv4  3              3179416      47720            227702032      28707


Have anyone tried this feature? Is it working for you? Maybe I am doing something wrong?

Thanks for your replies.
Previous Topic: openvz 7.0 networking docs are outdated
Next Topic: How to change boot order on VM
Goto Forum:
  


Current Time: Mon Dec 09 00:30:46 GMT 2019