OpenVZ Forum


Home » General » Support » CentOS 5: upgrade vzctl from 3.3 to 4.9.4
CentOS 5: upgrade vzctl from 3.3 to 4.9.4 [message #52291] Tue, 12 January 2016 11:25
droner is currently offline  droner
Messages: 1
Registered: January 2016
Junior Member
From: *domeny.com
Hello,

HW node: CentOS 5, kernel 2.6.18-406.el5.028stab119.6

I currently have vzctl 3.3-1

yum list installed | grep -i vzctl

vzctl.x86_64                             3.3-1                         installed
vzctl-lib.x86_64                         3.3-1                         installed


I see newer version is available in yum:

There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package ploop-lib.x86_64 0:1.14.1-1 set to be updated
--> Processing Dependency: e2fsprogs-resize2fs-static for package: ploop-lib
---> Package vzctl.x86_64 0:4.9.4-1 set to be updated
--> Processing Dependency: vzstats for package: vzctl
--> Processing Dependency: bridge-utils for package: vzctl
--> Processing Dependency: attr for package: vzctl
--> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl
---> Package vzctl-core.x86_64 0:4.9.4-1 set to be updated
--> Running transaction check
---> Package attr.x86_64 0:2.4.32-1.1 set to be updated
---> Package bridge-utils.x86_64 0:1.1-3.el5 set to be updated
---> Package e2fsprogs-resize2fs-static.x86_64 0:1.42.11-1.ovz set to be updated
---> Package libcgroup.x86_64 0:0.37-4 set to be updated
---> Package vzstats.noarch 0:0.5.3-1 set to be updated
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Finished Dependency Resolution
ploop-lib-1.14.1-1.x86_64 from openvz-utils has depsolving problems
  --> ploop-lib conflicts with ovzkernel
Error: ploop-lib conflicts with ovzkernel
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


I must remove 3.3 before upgrade to 4.9.4 - it is safe? Containers data will be lost?
Previous Topic: backup rsync /vz/root
Next Topic: MAC address
Goto Forum:
  


Current Time: Tue Oct 23 20:26:45 GMT 2018