OpenVZ Forum


Home » General » Support » CentOS 7 telnet-server issue
CentOS 7 telnet-server issue [message #52257] Fri, 13 November 2015 14:59
seneca214 is currently offline  seneca214
Messages: 1
Registered: November 2015
Junior Member
From: *hfc.comcastbusiness.net
Hello,

We're seeing the following issues with the telnet-server package in CentOS 7 running in a openvz container (in proxmox 3.4). We only see this when running in a openvz container, i.e. not with CentOS 7 install on a physical server, or a LXC container. When logging into the server via telnet, characters are missing from the login prompt, text is not echoed back, and new lines on the screen are 'stair-stepping'. Has anyone run across this before? Any suggestions for making this work correctly? We see this happen when using a telnet client from the localhost, putty on windows and from telnet on other devices on the network.

In addition:

* In CentOS 7. If you edit the /usr/lib/systemd/system/telnet@.service file changing ExecStart to be 'ExecStart=-/usr/sbin/in.telnetd -D options', telnets to the server work, however you're left with initial debugging information on the screen. Not ideal. e.g.

$ telnet localhost
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
td: send do TERMINAL TYPE
td: send do TSPEED
td: send do XDISPLOC
td: send do NEW-ENVIRON
td: recv do SUPPRESS GO AHEAD
td: send will SUPPRESS GO AHEAD
td: recv will TERMINAL TYPE
td: recv will NAWS
td: send do NAWS
td: recv will TSPEED
td: recv will LFLOW
td: send do LFLOW
td: recv will LINEMODE
td: send dont LINEMODE
td: recv will NEW-ENVIRON
td: recv do STATUS
td: send will STATUS
td: recv wont XDISPLOC
td: recv suboption NAWS 0 80 (80) 0 44 (44)
td: recv suboption TERMINAL-SPEED IS 38400,38400
td: recv suboption ENVIRON IS
td: recv suboption TERMINAL-TYPE IS "XTERM"
td: send do ECHO
td: recv wont ECHO
td: send will ECHO

Kernel 2.6.32-41-pve on an x86_64
server login: td: recv do ECHO

and the login session works and you get a normal shell. Without this you get (this is exactly how it appears on the screen with missing characters, no echo and 'stair stepping' lines:

$ telnet localhost
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.

Kernel 2.6.32-41-pve on an x86_64
erver login:
Password:
ast login: Thu Nov 12 13:15:58 from test
]0;guest1@server:~[guest1@server ~]$

Thanks
Previous Topic: Precreated templates cannot be downloaded
Next Topic: Centos installed, now want install Openvz, what should i do with the additional IPs?
Goto Forum:
  


Current Time: Wed Dec 12 11:40:03 GMT 2018