OpenVZ Forum

Home » General » Support » CentOS 6.7/OpenVZ container missing "Committed_AS" line in /proc/meminfo
CentOS 6.7/OpenVZ container missing "Committed_AS" line in /proc/meminfo [message #52178] Tue, 01 September 2015 06:56 Go to next message
xerobank is currently offline  xerobank
Messages: 1
Registered: September 2015
Junior Member
From: *
When I run cat /proc/meminfo on my CentOS 6.7/OpenVZ container, it is missing the "Committed_AS" line which causes the some application processes to fail.

[root@node1 ~]# more /etc/centos-release
CentOS release 6.7 (Final)

[root@node1 ~]# uname -a
Linux node1 2.6.32-042stab103.6 #1 SMP Wed Jan 21 13:07:39 MSK 2015 x86_64 x86_64 x86_64 GNU/Linux

[root@node1 ~]# cat /proc/meminfo
MemTotal: 25165824 kB
MemFree: 10861036 kB
Cached: 10156852 kB
Buffers: 0 kB
Active: 5535212 kB
Inactive: 7991088 kB
Active(anon): 2839436 kB
Inactive(anon): 660788 kB
Active(file): 2695776 kB
Inactive(file): 7330300 kB
Unevictable: 0 kB
Mlocked: 31880 kB
SwapTotal: 0 kB
SwapFree: 0 kB
Dirty: 216 kB
Writeback: 0 kB
AnonPages: 3500224 kB
Shmem: 130776 kB
Slab: 778460 kB
SReclaimable: 738684 kB
SUnreclaim: 39776 kB

Can any one help me how to get the "Committed_AS" value from /proc/meminfo please? Also, clarify why the output has so few lines.

Thank you.
Re: CentOS 6.7/OpenVZ container missing "Committed_AS" line in /proc/meminfo [message #52180 is a reply to message #52178] Tue, 01 September 2015 10:02 Go to previous messageGo to next message
bkbbkb is currently offline  bkbbkb
Messages: 4
Registered: August 2015
Junior Member
From: *
Please provide a list of applications sensitive to a presence of "Committed_AS" in /proc/meminfo.

Generally we have only that entries that have a sense in CT and are required by most programs.
Re: CentOS 6.7/OpenVZ container missing "Committed_AS" line in /proc/meminfo [message #52185 is a reply to message #52178] Fri, 04 September 2015 08:27 Go to previous message
khorenko is currently offline  khorenko
Messages: 523
Registered: January 2006
Location: Moscow, Russia
Senior Member
From: *
Fully ack the comment from bkb, if some apps are not working inside Containers, we wish to know about them.

BTW, xerobank, you are welcome to send patches as well, if you believe the enhancement is really needed. Smile

If you problem is solved - please, report it!
It's even more important than reporting the problem itself...
Previous Topic: VPN install on OpenVZ container inside KVM host
Next Topic: LAMP Server Installation
Goto Forum:

Current Time: Fri Aug 14 01:31:02 GMT 2020