OpenVZ Forum


Home » General » Support » Can't set fs.mqueue.msg_max
Can't set fs.mqueue.msg_max [message #51938] Tue, 24 March 2015 13:33 Go to next message
jakm is currently offline  jakm
Messages: 1
Registered: March 2015
Junior Member
Hello,
I need to increase POSIX MessageQueue length to 100 inside the container, but every attempt fails with 'permission denied'. Host system has length set to 100 and container to 10 (after start). We tried this commands:

[prod]root@virt2:/root# vzctl enter 32013
entered into CT 32013
root@broker:/# sysctl -w fs.mqueue.msg_max=100
sysctl: permission denied on key 'fs.mqueue.msg_max'

root@broker:/# echo 100 > /proc/sys/fs/mqueue/msg_max
-bash: /proc/sys/fs/mqueue/msg_max: Permission denied


Container has set this capabilities:
CAPABILITY="CHOWN:on DAC_OVERRIDE:on DAC_READ_SEARCH:on FOWNER:on FSETID:on KILL:on SETGID:on SETUID:on SETPCAP:on LINUX_IMMUTABLE:on NET_BIND_SERVICE:on NET_BROADCAST:on NET_ADMIN:on NET_RAW:on IPC_LOCK:on IPC_OWNER:on SYS_MODULE:on SYS_RAWIO:on SYS_CHROOT:on SYS_PTRACE:on SYS_PACCT:on SYS_ADMIN:on SYS_BOOT:on SYS_NICE:on SYS_RESOURCE:on SYS_TIME:on SYS_TTY_CONFIG:on MKNOD:on LEASE:on VE_ADMIN:on FS_MASK:on" 


Kernel and vzclt versions:
* 2.6.32-openvz-042stab104.1-amd64
* vzctl version 4.8

Any idea what is wrong? Thanks.

Jakub
Re: Can't set fs.mqueue.msg_max [message #52410 is a reply to message #51938] Fri, 20 May 2016 08:13 Go to previous messageGo to next message
sabine77 is currently offline  sabine77
Messages: 2
Registered: May 2016
Location: Frankfurt
Junior Member
Hello,

I was just wondering if somebody has found a solution to that problem?

We also need to change some fs.mqueue.* kernel parameters for POSIX Message Queues

fs.mqueue.msgsize_max=65536
fs.mqueue.msg_max=200
fs.mqueue.queues_max=512

We've set it on our OpenVZ Node but however inside of our container we've still got only default values

On HW-Node...

# uname -r
2.6.32-042stab113.17

# sysctl -a |grep mqueue
fs.mqueue.queues_max = 512
fs.mqueue.msg_max = 200
fs.mqueue.msgsize_max = 65536
fs.mqueue.msg_default = 10
fs.mqueue.msgsize_default = 65365


Inside container:

# vzctl enter 666667
entered into CT 666667
# sysctl -a |grep mqueue
fs.mqueue.queues_max = 256
fs.mqueue.msg_max = 10
fs.mqueue.msgsize_max = 8192
fs.mqueue.msg_default = 10
fs.mqueue.msgsize_default = 8192

So for unpriviliged user/processes it is still not possible to open mqueues with messagesize greater and even other than 8192.... Same applies for the other fs.mqueue parameters as well...

Any idea how to solve that problem?

Thank you in advance.

Greetings, Sabine

Re: Can't set fs.mqueue.msg_max [message #52424 is a reply to message #52410] Wed, 08 June 2016 09:38 Go to previous message
curx
Messages: 739
Registered: February 2006
Location: N├╝rnberg, Germany
Senior Member

Please add a new bugreport at https://bugs.openvz.org/
Previous Topic: Restore snapshot
Next Topic: enable openvz quota on main node
Goto Forum:
  


Current Time: Thu Mar 23 14:02:06 GMT 2023

Total time taken to generate the page: 0.00845 seconds