OpenVZ Forum


Home » International » Russian » Контейнер не видится с хоста по сети
Контейнер не видится с хоста по сети [message #51932] Wed, 18 March 2015 21:36 Go to next message
mkrentovskiy is currently offline  mkrentovskiy
Messages: 4
Registered: August 2012
Junior Member
From: *gprs.mts.ru
Здравствуйте, коллеги.

Суть проблемы такова. Есть пачка хост-машин, одним интерфейсом смотрящих наружу, другим - в локалку 10.2.0.0/16.
Контейнеры так же имеют адреса 10.2.0.0/16. ОС Debian Wheezy, 2.6.32-openvz-042stab104.1-amd64

После установки (строго по руководству в wiki) все было хорошо - контейнеры видятся с хоста и через локальную сеть, все счастливы, все танцуют.
Однако, начиная с некоторого момента начинает происходить непонятное - с хоста прекращается доступ к контейнерам, на нем размещенным.
При этом соседние контейнеры с этого же хоста доступны и пингуются и эти контейнеры с других хостов тоже доступны и пингуются.

Если сделать tcpdump -i venet0 icmp, то можно увидеть совершенно потрясную картину, как пинги уходят, ответ возвращается, но при этом до приложения, он, видимо, не долетает.
iptables занулен.

В чем может быть причина такого поведения?
Re: Контейнер не видится с хоста по сети [message #51933 is a reply to message #51932] Wed, 18 March 2015 22:43 Go to previous message
mkrentovskiy is currently offline  mkrentovskiy
Messages: 4
Registered: August 2012
Junior Member
From: *gprs.mts.ru
Сам спросил, сам отвечу. При старте на внешнем интерфейсе поднимался альяс со своей таблицей маршрутизации, оно всему и вредило. Если сделать операцию подергивания этому интерфейсу - доступ магическим образом возобновлялся.
Previous Topic: Интерпритация вывода vzmemcheck.
Next Topic: iptables в контейнере
Goto Forum:
  


Current Time: Thu Oct 19 20:02:22 GMT 2017