OpenVZ Forum


Home » General » Support » OVZ does not delete root and private directores in some cases
OVZ does not delete root and private directores in some cases [message #51497] Fri, 27 June 2014 15:43 Go to next message
o1o1o11o1 is currently offline  o1o1o11o1
Messages: 10
Registered: March 2014
Location: United States
Junior Member
Hey guys,

OS:
Distributor ID: Debian
Description: Debian GNU/Linux 7.5 (wheezy)
Release: 7.5
Codename: wheezy

Kernel:
2.6.32-openvz-042stab084.17-amd64

VZ:
vzctl 4.7.2-1

In some cases the /var/lib/vz/root/$CTID and the /var/lib/vz/private/$CTID directories are not being removed after an instance has been destroyed, No errors in the vzctl.log to indicate any reason for this. It does not happen always but probably about 40% of the time.

Not sure if anyone else has seen this behavior and if this is a bug or not.
Re: OVZ does not delete root and private directores in some cases [message #51499 is a reply to message #51497] Sun, 29 June 2014 21:08 Go to previous messageGo to next message
devonblzx is currently offline  devonblzx
Messages: 127
Registered: December 2006
Senior Member
Post the strace of the 'vzctl destroy' command on a server that does this.

http://static.openvz.org/userbars/openvz-user-2.png
ByteOnSite President
Re: OVZ does not delete root and private directores in some cases [message #51504 is a reply to message #51499] Tue, 01 July 2014 20:28 Go to previous messageGo to next message
o1o1o11o1 is currently offline  o1o1o11o1
Messages: 10
Registered: March 2014
Location: United States
Junior Member
This is hard to duplicate, however inspecting the logs show the following:

2014-07-01T20:18:33+0000 vzctl : CT 105 : Stopping container ...
2014-07-01T20:18:38+0000 vzctl : CT 105 : Container was stopped
2014-07-01T20:18:38+0000 vzctl : CT 105 : Container is unmounted
2014-07-01T20:18:38+0000 vzctl : CT 105 : Destroying container private area: /var/lib/vz/private/105
2014-07-01T20:18:39+0000 vzctl : CT 105 : Container private area was destroyed

The above is how it should work. The bellow is what happens when the private and root are not cleaned up:

2014-07-01T16:23:47+0000 vzctl : CT 105 : Stopping container ...
2014-07-01T16:23:54+0000 vzctl : CT 105 : Container was stopped
2014-07-01T16:23:54+0000 vzctl : CT 105 : Container is unmounted

Then when a new instance is created (about 2 hours later) it reuses the 105 id and errors out with:

2014-07-01T19:11:31+0000 vzctl : CT 105 : Private area already exists in /var/lib/vz/private/105

I'll try and create/destroy in a loop while stracing to see if I can get this to happen again.

[Updated on: Tue, 01 July 2014 20:40]

Report message to a moderator

Re: OVZ does not delete root and private directores in some cases [message #51509 is a reply to message #51504] Wed, 02 July 2014 18:39 Go to previous message
o1o1o11o1 is currently offline  o1o1o11o1
Messages: 10
Registered: March 2014
Location: United States
Junior Member
I was not able to duplicate this after crating 2K containers. I am closing this issue as the problem most likely is in our code. Sorry to have wasted your time.
Previous Topic: After upgrade, host reboots when trying to start container
Next Topic: Possible to put a container on a "ramdisk"? (Ploop)
Goto Forum:
  


Current Time: Sat Feb 04 13:21:15 GMT 2023

Total time taken to generate the page: 0.00774 seconds