OpenVZ Forum


Home » General » Support » [SOLVED]Updating templates on ploop system
[SOLVED]Updating templates on ploop system [message #51400] Wed, 07 May 2014 10:02
multik is currently offline  multik
Messages: 6
Registered: February 2007
Junior Member
From: 87.236.11*
I want to update some template on system with ploop.

1 create new VPS, configure , update, etc.
2. stop VPS and remove ips
3. mount -t ploop path_to_disk_desc.xml /mnt
4. cd /mnt && tar zcf /vz/template/cache/new.tar.gz .
5. umount /mnt

all ok.
but when i try to create ...

# vzctl create 1014 --ostemplate new
Creating image: /vz/private/1014.tmp/root.hdd/root.hdd size=2306867K
Creating delta /vz/private/1014.tmp/root.hdd/root.hdd bs=2048 size=4614144 sectors v2
Storing /vz/private/1014.tmp/root.hdd/DiskDescriptor.xml
Opening delta /vz/private/1014.tmp/root.hdd/root.hdd
Adding delta dev=/dev/ploop60879 img=/vz/private/1014.tmp/root.hdd/root.hdd (rw)
mke2fs 1.41.12 (17-May-2010)
Discarding device blocks: done
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
144288 inodes, 576256 blocks
28812 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=4294967296
18 block groups
32768 blocks per group, 32768 fragments per group
8016 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912

Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 34 mounts or
180 days, whichever comes first. Use tune2fs -c or -i to override.
tune2fs 1.41.12 (17-May-2010)
Setting maximal mount count to -1
Setting interval between checks to 0 seconds
Creating balloon file .balloon-c3a5ae3d-ce7f-43c4-a1ea-c61e2b4504e8
Mounting /dev/ploop60879p1 at /vz/private/1014.tmp/root.hdd/root.hdd.mnt fstype=ext4 data=''
Unmounting device /dev/ploop60879
Opening delta /vz/private/1014.tmp/root.hdd/root.hdd
Adding delta dev=/dev/ploop60879 img=/vz/private/1014.tmp/root.hdd/root.hdd (rw)
Mounting /dev/ploop60879p1 at /vz/root/1014 fstype=ext4 data='balloon_ino=12,'
Creating container private area (centos-cloud)
tar: ./.balloon-c3a5ae3d-ce7f-43c4-a1ea-c61e2b4504e8: Cannot open: Operation not permitted
tar: Exiting with failure status due to previous errors
vps-create ERROR: Unpack /vz/template/cache/new.tar.gz failed
Unmounting file system at /vz/root/1014
Unmounting device /dev/ploop60879
Destroying container private area: /vz/private/1014
Creation of container private area failed

Where i am was wrong?

if i add --layout simfs to vzctl, all fine ..

UPDATE: after mounting at step 3 REMOVE /mnt/.balloon*

[Updated on: Wed, 07 May 2014 10:05]

Report message to a moderator

Previous Topic: RHEL 6 Container does not properly start on CentOS 5 host
Next Topic: Snapshotscript Ploop/Backup
Goto Forum:
  


Current Time: Wed Nov 22 12:36:40 GMT 2017