OpenVZ Forum


Home » General » Support » RHEL 6 Container does not properly start on CentOS 5 host
RHEL 6 Container does not properly start on CentOS 5 host [message #51398] Tue, 06 May 2014 15:59 Go to next message
blahugo@yahoo.de is currently offline  blahugo@yahoo.de
Messages: 4
Registered: May 2013
Junior Member
From: 89.106.184*
Hi,

I need to set up containers running RHEL 6.5 to be running on CentOS 5 hosts.

I did manage to set up a Template which works if I run it on a CentOS 6 host.

If I migrate that container to the CentOS 5 destination host I can start the container, but it does not bring up the system services like network etc.

working:

[root@cos6host ~]# vzlist 140016
CTID NPROC STATUS IP_ADDR
140016 16 running 172.24.7.198
[root@cos6host ~]# uname -rm
2.6.32-042stab084.26 x86_64
[root@cos6host ~]# cat /etc/redhat-release
CentOS release 6.5 (Final)

fails:

only 1 process shows up

[root@cos5host ~]# vzlist 140016
CTID NPROC STATUS IP_ADDR
140016 1 running 172.24.7.198
[root@cos5host ~]# uname -rm
2.6.18-308.8.2.el5.028stab101.1 x86_64
[root@cos5host ~]# cat /etc/redhat-release
CentOS release 5.9 (Final)

I think I have a problem with /dev/pts.
If I enter the VE on the CentOS 6 host vzctl enter looks right:
root 477 1 0 17:52 ? Ss 0:00 vzctl: pts/0
root 478 477 0 17:52 pts/0 Ss 0:00 \_ -bash

Doing the same on the CentOS 5 host:
root 1069 1 0 17:51 ? Ss 0:00 vzctl: ttyp0
root 1070 1069 0 17:51 ttyp0 Ss 0:00 \_ -bash


What am I missing?

regards,
blahugo
Re: RHEL 6 Container does not properly start on CentOS 5 host [message #51399 is a reply to message #51398] Wed, 07 May 2014 08:05 Go to previous message
blahugo@yahoo.de is currently offline  blahugo@yahoo.de
Messages: 4
Registered: May 2013
Junior Member
From: 89.106.184*
Ok, I found it.

I needed to move some scripts from /etc/init to a new directory /etc/init.removed and modify a few scripts in /etc/init.

Just look at the precreated CentOS 6 Templates. Wink

regards,
blahugo
Previous Topic: OPENVZ / MYSQL CRASH RADOMLY ON CONTAINER
Next Topic: [SOLVED]Updating templates on ploop system
Goto Forum:
  


Current Time: Mon Nov 20 07:49:52 GMT 2017