OpenVZ Forum


Home » General » Support » Repo Error: All mirror URLs are not using ftp, http[s] or file (Repo Error: All mirror URLs are not using ftp, http[s] or file : yum)
Repo Error: All mirror URLs are not using ftp, http[s] or file [message #51298] Sat, 05 April 2014 21:12 Go to next message
sreeninair
Messages: 3
Registered: December 2013
Location: India
Junior Member

From: 208.116.10*
Hello,

I am getting the following error while updating or listing yum. Please let me know how to fix this.

================

root@server [/etc/yum.repos.d]# yum list all
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. $releasever is not a valid release or hasnt been released yet/
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. $releasever is not a valid release or hasnt been released yet/
removing mirrorlist with no valid mirrors: /var/cache/yum/extras/mirrorlist.txt
Error: Cannot find a valid baseurl for repo: extras
===============

network seems fine, the server is using centos 5.10 32 bit os. I have copied yum.conf, yum.repos.d from another working server. Still getting same error.

=========
===========

oot@server [/etc/yum.repos.d]# uname -a
Linux server.server.com 2.6.32-042stab076.8 #1 SMP Tue May 14 20:38:14 MSK 2013 i686 i686 i386 GNU/Linux
root@server [/etc/yum.repos.d]#
===============
oot@server [/etc/yum.repos.d]# cat /etc/redhat-release
CentOS release 5.10 (Final)
root@server [/etc/yum.repos.d]#
===============
[/etc/yum.repos.d]# ping google.com
PING google.com (74.125.21.100) 56(84) bytes of data.
64 bytes from yv-in-f100.1e100.net (74.125.21.100): icmp_seq=1 ttl=46 time=16.9 ms
64 bytes from yv-in-f100.1e100.net (74.125.21.100): icmp_seq=2 ttl=46 time=26.3 ms
^C
--- google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 16.924/21.642/26.361/4.720 ms
==================

Please note that this is a openvz vps

======================




Thanks




Thanks
Sreenivas
Re: Repo Error: All mirror URLs are not using ftp, http[s] or file [message #51299 is a reply to message #51298] Mon, 07 April 2014 07:07 Go to previous message
Paparaciz
Messages: 302
Registered: August 2009
Senior Member
From: *gaumina.lt
This is not openvz problem
Previous Topic: Problem with connectivity between containers.
Next Topic: All conteiner stoped
Goto Forum:
  


Current Time: Fri Oct 18 23:47:30 GMT 2019