OpenVZ Forum


Home » International » German » IPtables und der internverkehr ausgehend geht nicht.
IPtables und der internverkehr ausgehend geht nicht. [message #51155] Wed, 26 February 2014 22:26
unclesamwk is currently offline  unclesamwk
Messages: 1
Registered: February 2014
Junior Member
From: *dip0.t-ipconnect.de
Hey Leute,

ich habe eine Proxmox Virtualisierung am laufen und bin auch zufrieden damit.

Habe ein Problem welches ich kurz beschreiben möchte.

Promox ist mit einer IP erreichbar 1.2.3.4
Soweit alles okay. Die IP nehme ich nur für die Verwaltung von Proxmox.

Zusätzlich habe ich eine OVZ Maschine, quasi als gateway für weitere Clients im Lan.

Die Maschine hat eth0 und eth1.
eth0 = vmbr0 auf der Proxmox. Zusätzliche IP drauf. Alles gut
eth1 = vmbr2 für ein Internes Lan

Auf der Maschine habe ich ein Firewallscript welches u.a. Internet ausgehend für die Clients erlaubt. Von dem Gateway kann ich ohne weiteres ins Netz. Auch portweiterleitungen auf clients funzen ohne einschränkungen.

Das einzige Problem ist. Ausgehender IE Verkehr funzt net von den Clients:

...
# Internet im LAN
/sbin/iptables -A FORWARD -i $IFACE_WAN -o $IFACE_LAN -m state --state ESTABLISHED,RELATED -j ACCEPT
/sbin/iptables -A FORWARD -i $IFACE_LAN -o $IFACE_WAN -j ACCEPT
/sbin/iptables -t nat -A POSTROUTING -o $IFACE_WAN -j MASQUERADE
...

Diese Regeln funzen auf einer KVM Maschine ohne Probleme.

Habe eine tcpdump aufgezeichnet. Die Anfragen löst zum Beispiel ping nach google.de ohne weitere auf und kommen am gateway, jedoch nicht durch.

Jemand ne Idee?

Gruß
Sam
Previous Topic: Netzwerkprobleme mit Debian 6x64 Host und Guest (ISPConfig 3)
Next Topic: Openvz Template > OpenSuse - Yast Bug?
Goto Forum:
  


Current Time: Mon Nov 20 01:55:16 GMT 2017