OpenVZ Forum


Home » General » Support » Force date shift in VM (How do I force a different date on VM compared to HN)
Force date shift in VM [message #50959] Fri, 13 December 2013 00:31 Go to next message
danaspinall is currently offline  danaspinall
Messages: 2
Registered: December 2013
Junior Member
From: *static.internode.on.net
Hi all.

I have a physical server running about 6 different RHES5 instances. As part of our application testing I need to be able to time shift 2 of the VMs to a date in the past, of over 31 days, to test some application logic.
I have found articles on how to fix NTP sync with the HN, but nothing specific about setting a completely different date override for specific VMs on the same server.
Does anyone know if it is possible? I don't mind the dirtiest of hacks as this is just for testing.

Any info much appreciated.

Dan.
Re: Force date shift in VM [message #50965 is a reply to message #50959] Sun, 15 December 2013 17:02 Go to previous messageGo to next message
grep is currently offline  grep
Messages: 34
Registered: November 2013
Member
From: *as5577.net
Hi,

openvz Containers get time from node, not possible to set other time than as node.

You can only edit the timezones to get some hours different.

Maybe you can create your own zoneinfo with different of xxx hours, but not sure if this would work.

But you could install something like kvm and test it there. it can run on the same server as openvz.
Re: Force date shift in VM [message #51043 is a reply to message #50965] Tue, 07 January 2014 05:01 Go to previous message
danaspinall is currently offline  danaspinall
Messages: 2
Registered: December 2013
Junior Member
From: *static.internode.on.net
Hi Grep.

Thanks for the tip. I have tried to create a new zoneinfo file and if I try anything outside the 24 hour period I get the following error:

[root@staging tmp]# zic -v openvz-tz
"openvz-tz", line 1: invalid UTC offset

It doesn't look as though zic will allow me to make a zoneinfo file many days out.

I have also tried to create a rule in a similar manner:

[root@staging tmp]# zic openvz-rule
"openvz-rule", line 1: invalid saved time

So doesn't look like that will work either.

If you have any other ideas I'd love to hear them. Think I'm going to have to look at other options.

Thanks again for the ideas though.

Dan.
Previous Topic: /dev/null permission denied
Next Topic: Backing up OpenVZ important files
Goto Forum:
  


Current Time: Tue Nov 20 17:44:46 GMT 2018