OpenVZ Forum


Home » General » Support » Installing OpenVZ on Azure (vzkernel conflicts with bfa-firmware) (Error when trying to install OpenVZ to Azure CentOS6.3)
Installing OpenVZ on Azure (vzkernel conflicts with bfa-firmware) [message #50404] Thu, 22 August 2013 10:05 Go to next message
ebiken is currently offline  ebiken
Messages: 2
Registered: September 2012
Junior Member
From: *ppp.asahi-net.or.jp
Hi,

I created CentOS6.3 VM on Azure, and trying to install OpenVZ but got below error.

Does anyone faced same error? How can I avoid this?

[ebiken@openvz01 ~]$ uname -a
Linux openvz01 2.6.32-279.14.1.el6.openlogic.x86_64 #1 SMP Wed Dec 12 18:33:43 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

[root@openvz01 ebiken]# wget -P /etc/yum.repos.d/ http: //download.openvz.org/openvz.repo
[root@openvz01 ebiken]# rpm --import http: //ftp.openvz.org/RPM-GPG-Key-OpenVZ

# Enabled [openvz-kernel-rhel6-testing] in /etc/yum.repos.d/openvz.repo

[root@openvz01 ebiken]# yum install vzkernel
Loaded plugins: security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package vzkernel.x86_64 0:2.6.32-042stab080.11 will be installed
--> Processing Dependency: kernel-firmware >= 2.6.32-358.14.1.el6 for package: vzkernel-2.6.32-042stab080.11.x86_64
--> Processing Conflict: vzkernel-2.6.32-042stab080.11.x86_64 conflicts bfa-firmware < 3.0.3.1
--> Finished Dependency Resolution
Error: Package: vzkernel-2.6.32-042stab080.11.x86_64 (openvz-kernel-rhel6-testing)
Requires: kernel-firmware >= 2.6.32-358.14.1.el6
Installed: kernel-firmware-2.6.32-279.14.1.el6.openlogic.x86_64 (@openlogic)
kernel-firmware = 2.6.32-279.14.1.el6.openlogic
Error: vzkernel conflicts with bfa-firmware
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Re: Installing OpenVZ on Azure (vzkernel conflicts with bfa-firmware) [message #50569 is a reply to message #50404] Thu, 12 September 2013 18:39 Go to previous messageGo to next message
Paparaciz
Messages: 302
Registered: August 2009
Senior Member
From: 78.60.233*
sorry for delayed reply, but maybe it would be helpfull.
as I understand it just have strict dependencies, so probably disabling vzkernel-firmware will solve a problem:
http://wiki.openvz.org/Vzkernel-firmware
Re: Installing OpenVZ on Azure (vzkernel conflicts with bfa-firmware) [message #52249 is a reply to message #50569] Wed, 04 November 2015 15:03 Go to previous messageGo to next message
tburazin is currently offline  tburazin
Messages: 6
Registered: June 2015
Junior Member
From: 213.147.110*
Edit:
I'm an idiot and the fix on wiki.openvz.org/Vzkernel-firmware works (didn't save the file)...
Please ignore this post.


I know this is an old thread but I'm having this issue and I don't have vzkernel-firmware enabled.

Any help welcome.

Edit: Some info
Running CentOS 6.7 on Azure


blog.codeanywhere.com/tag/tommy-burazin

[Updated on: Fri, 06 November 2015 17:17]

Report message to a moderator

Re: Installing OpenVZ on Azure (vzkernel conflicts with bfa-firmware) [message #52254 is a reply to message #50404] Sat, 07 November 2015 18:40 Go to previous message
Paparaciz
Messages: 302
Registered: August 2009
Senior Member
From: *static.zebra.lt
Error: vzkernel conflicts with bfa-firmware

so try to use --skip-broken option, or figure out if it is an option avoid bfa-firmware package and remove it
Previous Topic: Does OpenVZ work on Ubuntu 14.04 LTS?
Next Topic: Precreated templates cannot be downloaded
Goto Forum:
  


Current Time: Mon Dec 09 10:52:17 GMT 2019