OpenVZ Forum


Home » General » Support » 2 different networks on same VE
2 different networks on same VE [message #49030] Wed, 27 February 2013 17:50 Go to next message
TheGreatDoc is currently offline  TheGreatDoc
Messages: 3
Registered: February 2013
Location: EspaƱa
Junior Member
Is it possible to have a VE working with 2 differents subnet ip address?

I have a HN with 2 interfaces, one with an public ip and another with private ip.

I have several VEs running on it, some with private ips and some with public ips. All work well but, if I try to use one public and one private on same VE, the secondary IP (no matter what) will not work outside the HN.

Explanation.

If [IP_ADDRESS="84.232.xxx.xxx 172.20.20.252"] all will work ok with the public ip, but private will only ping to 172.20.20.253 (HN Private IP)

If I swich it, [IP_ADDRESS="172.20.20.252 84.232.xxx.xxx"], all will work ok with the private ip, but the public will only have comm with the HN.

Any tip on this? I tried setting NEIGHBOUR_DEVS=detect in vz.conf to all, but then all networking stop working.

Thanks in advance
Re: 2 different networks on same VE [message #50658 is a reply to message #49030] Fri, 04 October 2013 01:29 Go to previous message
qrpike is currently offline  qrpike
Messages: 1
Registered: October 2013
Location: Atlanta
Junior Member
Seems a lot of people ( including me ) are having this issue, and there is no one that has responded to any of the posts I have come across.

Previous Topic: How to show IP pool avail. IPs from command line?
Next Topic: Problem with quota
Goto Forum:
  


Current Time: Sat May 25 04:22:39 GMT 2024

Total time taken to generate the page: 0.01700 seconds