OpenVZ Forum


Home » International » Russian » Не ходит multicast трафик между CT
Не ходит multicast трафик между CT [message #48716] Thu, 08 November 2012 13:27 Go to next message
yuri_kurenkov is currently offline  yuri_kurenkov
Messages: 6
Registered: November 2012
Junior Member
From: *ttn.ru
Добрый день!

Дано: CentOS6.3, 2.6.32-042stab063.2, vzctl-4.1.
Задача: обеспечить хождение multicast между CT.

Согласно рекомендации в списке рассылки использую veth.
Создаю два контейнера, добавляю в них veth. Запустив контейнеры, захожу в них и настраиваю eth0 интерфейсы. Далее на CT0 включаю в бридж сетевой интерфейс CT0, vethCT1.0, vethCT2,0. на интерфейсе CT0 IP отсутствует и прописан на бридже. Все три интерфейса находятся в одной IP сети. Unicast трафик прекрасно ходимт между CT0, CT1 и CT2. Multicast идет только в направлении от CT1 и CT2 в CT0.

Как обеспечить хождение multicast между CT1 и CT2?
[РЕШЕНО] Re: Не ходит multicast трафик между CT [message #48729 is a reply to message #48716] Mon, 12 November 2012 09:30 Go to previous message
yuri_kurenkov is currently offline  yuri_kurenkov
Messages: 6
Registered: November 2012
Junior Member
From: *ttn.ru
Необходимо использовать veth в бридже с сетевым интерфейсром CT0 и не забыть прописать маршрут в /etc/sysconfig/network-scripts/route-eth0:

224.0.0.0/4 via 0.0.0.0 dev eth0
Previous Topic: independent communication through the bridge
Next Topic: Проблема со свободным местом в CT
Goto Forum:
  


Current Time: Wed Aug 21 07:56:02 GMT 2019