OpenVZ Forum


Home » International » Russian » Проблемы с пробросом сетевых карт intel pro 100 (При использовании --netdev_add сетевые карты интел не работают)
Проблемы с пробросом сетевых карт intel pro 100 [message #48431] Wed, 17 October 2012 20:23 Go to next message
urodliv is currently offline  urodliv
Messages: 3
Registered: October 2012
Junior Member
From: *19.122.13.pool.sknt.ru
Система работает под управлением debian`a 6.0.6:
Linux ovz 2.6.32-5-openvz-686 #1 SMP Sun Sep 23 11:40:07 UTC 2012 i686 GNU/Linux

Сетевые адаптеры:
00:0e.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 08) 
00:10.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78) 
00:12.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 64) 
00:13.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 08) 
00:14.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)

Из репозитория non-free были установлены пакеты:
ii  firmware-linux 0.28+squeeze1 Binary firmware for various drivers in the Linux kernel (meta-package) 
ii  firmware-linux-free 2.6.32-46 Binary firmware for various drivers in the Linux kernel 
ii  firmware-linux-nonfree 0.28+squeeze1 Binary firmware for various drivers in the Linux kernel 

После этого в логах никаких ошибок не появлялось.
Создаём контейнер с помощью шаблона debian-6.0-x86 (к слову сказать другие шаблоны тоже пробовал -- результат аналогичный). Далее с помощью параметра --netdev_add пробрасываем каждую сетевую карту в свой контейнер. Прописываем сетевые настройки для адаптера и пробуем его «поднять». Для любого адаптера, отличного от интела, сетевые настройки применяются, и всё начинает работать на «ура». А вот с интелом все плохо. При применении сетевых параметров в консоль ничего не пишется около минуты. Затем в логе появляется запись:
Oct 18 00:08:26 ovz kernel: [ 3428.789663] e100 0000:00:13.0: firmware: requesting e100/d101m_ucode.bin
Oct 18 00:09:26 ovz kernel: [ 3488.788163] e100: eth0: e100_request_firmware: Failed to load firmware "e100/d101m_ucode.bin": -2

Пробовал устанавливать вышеозначенные пакеты в контейнер -- не помогает.
Что-то мне подсказывает, что дело тут в кривом предоставлении каких-нибудь модулей хост-системой контейнеру, но моих знаний в этом вопросе мало. Что ещё можно попробовать?
Re: Проблемы с пробросом сетевых карт intel pro 100 [message #48445 is a reply to message #48431] Wed, 17 October 2012 22:27 Go to previous messageGo to next message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

From: 81.5.92*
Я тут вижу две проблемы

1 Ядро не может загрузить firmware для карточки. Чёрт его знает, почему -- может, версия firmware не та, может, файла /lib/firmware/e100/d101m_ucode.bin нет на хосте.

2 у вас ужасно старое ядро, которое мы давно не поддерживаем. Горячо советую установить последнее RHEL6-based. Делается это вот так:
http://wiki.openvz.org/Install_kernel_from_RPM_on_Debian_6.0


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Re: Проблемы с пробросом сетевых карт intel pro 100 [message #48500 is a reply to message #48445] Thu, 18 October 2012 20:07 Go to previous messageGo to next message
urodliv is currently offline  urodliv
Messages: 3
Registered: October 2012
Junior Member
From: *19.122.13.pool.sknt.ru
Насчёт наличия/отсутствия файлов прошивки:
user@ovz:~$ ls -l /lib/firmware/e100/
итого 12
-rw-r--r-- 1 root root 539 Июн 12 19:13 d101m_ucode.bin
-rw-r--r-- 1 root root 539 Июн 12 19:13 d101s_ucode.bin
-rw-r--r-- 1 root root 539 Июн 12 19:13 d102e_ucode.bin

и
lsmod | grep e100
e100                   22509  0 
mii                     2714  2 3c59x,e100

Кроме того, до установки пакетов из non-free репозитория вылетала аналогичное сообщение и в основной системе. Так что в хосте всё фунициклирует отлично. А вот проброс...
Re: Проблемы с пробросом сетевых карт intel pro 100 [message #48640 is a reply to message #48445] Fri, 26 October 2012 13:20 Go to previous message
urodliv is currently offline  urodliv
Messages: 3
Registered: October 2012
Junior Member
From: *19.122.13.pool.sknt.ru
kir wrote on Thu, 18 October 2012 02:27

Я тут вижу две проблемы

1 Ядро не может загрузить firmware для карточки. Чёрт его знает, почему -- может, версия firmware не та, может, файла /lib/firmware/e100/d101m_ucode.bin нет на хосте.

Поставил на хост-системе centos 6.3 - проблема пропала. Единственно что непонятно, это нарабочий шаблон centos.

Поторопился.
После перезагрузки всё вернулось на круги своя...

[Updated on: Fri, 26 October 2012 14:02]

Report message to a moderator

Previous Topic: Странный рост показаний счётчика dcachesize
Next Topic: С новым ядром 2.6.18-308.8.2.el5.028stab101.1 увеличилась нагрузка
Goto Forum:
  


Current Time: Wed Sep 26 15:32:49 GMT 2018