OpenVZ Forum


Home » Mailing lists » Users » yum update problem on 32-bit CentOS 6.3
yum update problem on 32-bit CentOS 6.3 [message #48063] Wed, 26 September 2012 17:55 Go to next message
Oskar Stolc is currently offline  Oskar Stolc
Messages: 2
Registered: September 2012
Junior Member
From: *parallels.com
Hi,


I would like to report a possible yum update problem. It looks like
ploop-lib does not like my kernel version, it finds it too high?

[root@centos6 ~]# cat /etc/issue
CentOS release 6.3 (Final)
Kernel \r on an \m
[root@centos6 ~]# uname -a
Linux centos6.microsoft.com 2.6.32-042stab061.2 #1 SMP Fri Aug 24 09:09:34
MSD 2012 i686 i686 i386 GNU/Linux
[root@centos6 ~]#
[root@centos6 ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: ftp.heanet.ie
* epel: ftp.heanet.ie
* extras: ftp.heanet.ie
* openvz-kernel-rhel6: mirror.ellogroup.com
* openvz-utils: mirror.ellogroup.com
* updates: centosq3.centos.org
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ploop.i386 0:1.4-1 will be updated
---> Package ploop.i386 0:1.5-1 will be an update
---> Package ploop-lib.i386 0:1.4-1 will be updated
---> Package ploop-lib.i386 0:1.5-1 will be an update
---> Package vzctl.i386 0:3.3-1 will be updated
---> Package vzctl.i386 0:4.0-1 will be an update
---> Package vzctl-core.i386 0:4.0-1 will be obsoleting
---> Package vzctl-lib.i386 0:3.3-1 will be obsoleted
--> Processing Conflict: ploop-lib-1.5-1.i386 conflicts vzkernel <
2.6.32-042stab061.1
--> Processing Conflict: ploop-lib-1.5-1.i386 conflicts vzkernel <
2.6.32-042stab061.1
--> Finished Dependency Resolution
Error: ploop-lib conflicts with vzkernel
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Thanks,
Oskar
Re: yum update problem on 32-bit CentOS 6.3 [message #48067 is a reply to message #48063] Wed, 26 September 2012 19:00 Go to previous messageGo to next message
Paparaciz
Messages: 302
Registered: August 2009
Senior Member
From: *parallels.com
remove all older vzkernels, leave only 2.6.32-042stab061.2
than you can update

On Wed, Sep 26, 2012 at 8:55 PM, Oskar Stolc <oskar.stolc@gmail.com> wrote:
> Hi,
>
>
> I would like to report a possible yum update problem. It looks like
> ploop-lib does not like my kernel version, it finds it too high?
>
> [root@centos6 ~]# cat /etc/issue
> CentOS release 6.3 (Final)
> Kernel \r on an \m
> [root@centos6 ~]# uname -a
> Linux centos6.microsoft.com 2.6.32-042stab061.2 #1 SMP Fri Aug 24 09:09:34
> MSD 2012 i686 i686 i386 GNU/Linux
> [root@centos6 ~]#
> [root@centos6 ~]# yum update
> Loaded plugins: fastestmirror, refresh-packagekit, security
> Loading mirror speeds from cached hostfile
> * base: ftp.heanet.ie
> * epel: ftp.heanet.ie
> * extras: ftp.heanet.ie
> * openvz-kernel-rhel6: mirror.ellogroup.com
> * openvz-utils: mirror.ellogroup.com
> * updates: centosq3.centos.org
> Setting up Update Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package ploop.i386 0:1.4-1 will be updated
> ---> Package ploop.i386 0:1.5-1 will be an update
> ---> Package ploop-lib.i386 0:1.4-1 will be updated
> ---> Package ploop-lib.i386 0:1.5-1 will be an update
> ---> Package vzctl.i386 0:3.3-1 will be updated
> ---> Package vzctl.i386 0:4.0-1 will be an update
> ---> Package vzctl-core.i386 0:4.0-1 will be obsoleting
> ---> Package vzctl-lib.i386 0:3.3-1 will be obsoleted
> --> Processing Conflict: ploop-lib-1.5-1.i386 conflicts vzkernel <
> 2.6.32-042stab061.1
> --> Processing Conflict: ploop-lib-1.5-1.i386 conflicts vzkernel <
> 2.6.32-042stab061.1
> --> Finished Dependency Resolution
> Error: ploop-lib conflicts with vzkernel
> You could try using --skip-broken to work around the problem
> You could try running: rpm -Va --nofiles --nodigest
>
> Thanks,
> Oskar
>
Re: yum update problem on 32-bit CentOS 6.3 [message #48068 is a reply to message #48067] Wed, 26 September 2012 19:12 Go to previous message
Oskar Stolc is currently offline  Oskar Stolc
Messages: 2
Registered: September 2012
Junior Member
From: *parallels.com
On 09/26/2012 08:00 PM, helpaz wrote:
> remove all older vzkernels, leave only 2.6.32-042stab061.2
> than you can update
That worked, thanks!
Previous Topic: Kernel crash 2.6.32.61.2
Next Topic: yum update problem on CentOS 5.8 server
Goto Forum:
  


Current Time: Fri Nov 24 05:40:40 GMT 2017