OpenVZ Forum


Home » Mailing lists » Users » yum update problem on CentOS 5.8 server
yum update problem on CentOS 5.8 server [message #48047] Wed, 26 September 2012 12:46 Go to next message
Holger Rabbach (ICT) is currently offline  Holger Rabbach (ICT)
Messages: 3
Registered: September 2012
Junior Member
From: *parallels.com
Hi,

I tried to run yum update on a CentOS 5.8 OpenVZ host server today and something strange happened. Yum tries to update vzctl-core to version 4.0-1, which seems to require an updated plop-lib package, but the updated plop-lib package from the yum repository requires a kernel >= 2.6.32 (CentOS 5 runs on 2.6.18). As a result, the entire update fails. It looks like there are the wrong package versions in the yum repository for RHEL/CentOS 5 - or is there something else going on?

Best regards,
Holger

PS: full output from yum follows:

[root@paul ~]# yum update
Loaded plugins: dellsysid, fastestmirror, security
Loading mirror speeds from cached hostfile
* base: mirror.netcologne.de
* epel: ftp.uni-koeln.de
* extras: mirror.netcologne.de
* openvz-kernel-rhel5: openvz.proserve.nl
* openvz-utils: openvz.proserve.nl
* updates: mirror.netcologne.de
base | 1.1 kB 00:00
cr | 1.9 kB 00:00
dell-omsa-indep | 1.9 kB 00:00
dell-omsa-specific | 1.9 kB 00:00
openvz-kernel-rhel5 | 951 B 00:00
openvz-utils | 951 B 00:00
updates | 1.9 kB 00:00
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package ploop.x86_64 0:1.5-1 set to be updated
---> Package ploop-lib.x86_64 0:1.5-1 set to be updated
---> Package vzctl.x86_64 0:4.0-1 set to be updated
--> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl
---> Package vzctl-core.x86_64 0:4.0-1 set to be updated
--> Processing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl-core
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Finished Dependency Resolution
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
ploop-lib-1.5-1.x86_64 from openvz-utils has depsolving problems
--> ploop-lib conflicts with ovzkernel
vzctl-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-4.0-1.x86_64 (openvz-utils)
Error: ploop-lib conflicts with ovzkernel
Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
[root@paul ~]#

--
Holger Rabbach
Assistant International IT Manager


________________________________
OM International Services (Carlisle) Ltd - Unit B Clifford Court, Cooper Way - Carlisle CA3 0JG - United Kingdom
Charity reg no: 1112655 - Company reg no: 5649412 (England and Wales)
Re: yum update problem on CentOS 5.8 server [message #48048 is a reply to message #48047] Wed, 26 September 2012 13:13 Go to previous messageGo to next message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

From: *parallels.com
On 09/26/2012 04:46 PM, Holger Rabbach (ICT) wrote:
>
> Hi,
>
> I tried to run yum update on a CentOS 5.8 OpenVZ host server today and
> something strange happened. Yum tries to update vzctl-core to version
> 4.0-1, which seems to require an updated plop-lib package, but the
> updated plop-lib package from the yum repository requires a kernel >=
> 2.6.32 (CentOS 5 runs on 2.6.18). As a result, the entire update
> fails. It looks like there are the wrong package versions in the yum
> repository for RHEL/CentOS 5 -- or is there something else going on?
>

There are two problems here:

1 ploop

Since you have RHEL5-based kernel that do not require ploop, you can
remove ploop when installing vzctl-4.0. I have made vzctl not requiring
ploop by dynamically loading it when it's available. Note that vzctl is
not requiring ploop anymore, it just conflicts with the old version of it.

2 libcgroup

Currently I don't have a solution rather than compiling libcgroup from
source. I will take a closer look in the coming days and find a fix.

In the meantime,
- please stay with vzctl-3.3 and
- maybe it's a good time for switching to RHEL6 kernel which has a lot
of nice features such as VSwap.

> Best regards,
>
> Holger
>
> PS: full output from yum follows:
>
> [root@paul ~]# yum update
>
> Loaded plugins: dellsysid, fastestmirror, security
>
> Loading mirror speeds from cached hostfile
>
> * base: mirror.netcologne.de
>
> * epel: ftp.uni-koeln.de
>
> * extras: mirror.netcologne.de
>
> * openvz-kernel-rhel5: openvz.proserve.nl
>
> * openvz-utils: openvz.proserve.nl
>
> * updates: mirror.netcologne.de
>
> base | 1.1 kB 00:00
>
> cr | 1.9 kB 00:00
>
> dell-omsa-indep | 1.9 kB 00:00
>
> dell-omsa-specific | 1.9 kB 00:00
>
> openvz-kernel-rhel5 | 951 B 00:00
>
> openvz-utils | 951 B 00:00
>
> updates | 1.9 kB 00:00
>
> Skipping security plugin, no data
>
> Setting up Update Process
>
> Resolving Dependencies
>
> Skipping security plugin, no data
>
> --> Running transaction check
>
> ---> Package ploop.x86_64 0:1.5-1 set to be updated
>
> ---> Package ploop-lib.x86_64 0:1.5-1 set to be updated
>
> ---> Package vzctl.x86_64 0:4.0-1 set to be updated
>
> --> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl
>
> ---> Package vzctl-core.x86_64 0:4.0-1 set to be updated
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl-core
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Finished Dependency Resolution
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is needed
> by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is needed
> by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is needed
> by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1()(64bit) is needed by package
> vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> ploop-lib-1.5-1.x86_64 from openvz-utils has depsolving problems
>
> --> ploop-lib conflicts with ovzkernel
>
> vzctl-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1()(64bit) is needed by package
> vzctl-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by
> package vzctl-4.0-1.x86_64 (openvz-utils)
>
> Error: ploop-lib conflicts with ovzkernel
>
> Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by
> package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> You could try using --skip-broken to work around the problem
>
> You could try running: package-cleanup --problems
>
> package-cleanup --dupes
>
> rpm -Va --nofiles --nodigest
>
> [root@paul ~]#
>


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
RE: yum update problem on CentOS 5.8 server [message #48050 is a reply to message #48048] Wed, 26 September 2012 13:32 Go to previous messageGo to next message
Holger Rabbach (ICT) is currently offline  Holger Rabbach (ICT)
Messages: 3
Registered: September 2012
Junior Member
From: *parallels.com
Thanks for the quick reply, I'll stay with the old version for now. The host server will move to CentOS 6 in the not too distant future anyway, it's just not something I can do right away.

Regards,
Holger

--
Holger Rabbach
Assistant International IT Manager

From: Kir Kolyshkin [mailto:kir@openvz.org]
Sent: Mittwoch, 26. September 2012 15:13
To: users@openvz.org
Cc: Holger Rabbach (ICT)
Subject: Re: [Users] yum update problem on CentOS 5.8 server

On 09/26/2012 04:46 PM, Holger Rabbach (ICT) wrote:
Hi,

I tried to run yum update on a CentOS 5.8 OpenVZ host server today and something strange happened. Yum tries to update vzctl-core to version 4.0-1, which seems to require an updated plop-lib package, but the updated plop-lib package from the yum repository requires a kernel >= 2.6.32 (CentOS 5 runs on 2.6.18). As a result, the entire update fails. It looks like there are the wrong package versions in the yum repository for RHEL/CentOS 5 - or is there something else going on?

There are two problems here:

1 ploop

Since you have RHEL5-based kernel that do not require ploop, you can remove ploop when installing vzctl-4.0. I have made vzctl not requiring ploop by dynamically loading it when it's available. Note that vzctl is not requiring ploop anymore, it just conflicts with the old version of it.

2 libcgroup

Currently I don't have a solution rather than compiling libcgroup from source. I will take a closer look in the coming days and find a fix.

In the meantime,
- please stay with vzctl-3.3 and
- maybe it's a good time for switching to RHEL6 kernel which has a lot of nice features such as VSwap.



Best regards,
Holger

PS: full output from yum follows:

[root@paul ~]# yum update
Loaded plugins: dellsysid, fastestmirror, security
Loading mirror speeds from cached hostfile
* base: mirror.netcologne.de
* epel: ftp.uni-koeln.de<ftp://ftp.uni-koeln.de>
* extras: mirror.netcologne.de
* openvz-kernel-rhel5: openvz.proserve.nl
* openvz-utils: openvz.proserve.nl
* updates: mirror.netcologne.de
base | 1.1 kB 00:00
cr | 1.9 kB 00:00
dell-omsa-indep | 1.9 kB 00:00
dell-omsa-specific | 1.9 kB 00:00
openvz-kernel-rhel5 | 951 B 00:00
openvz-utils | 951 B 00:00
updates | 1.9 kB 00:00
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package ploop.x86_64 0:1.5-1 set to be updated
---> Package ploop-lib.x86_64 0:1.5-1 set to be updated
---> Package vzctl.x86_64 0:4.0-1 set to be updated
--> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl
---> Package vzctl-core.x86_64 0:4.0-1 set to be updated
--> Processing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl-core
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Finished Dependency Resolution
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
ploop-lib-1.5-1.x86_64 from openvz-utils has depsolving problems
--> ploop-lib conflicts with ovzkernel
vzctl-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-4.0-1.x86_64 (openvz-utils)
Error: ploop-lib conflicts with ovzkernel
Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
[root@paul ~]#


________________________________
OM International Services (Carlisle) Ltd - Unit B Clifford Court, Cooper Way - Carlisle CA3 0JG - United Kingdom
Charity reg no: 1112655 - Company reg no: 5649412 (England and Wales)
Re: yum update problem on CentOS 5.8 server [message #48100 is a reply to message #48050] Thu, 27 September 2012 12:54 Go to previous messageGo to next message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

From: *parallels.com
On 09/26/2012 05:32 PM, Holger Rabbach (ICT) wrote:
>
> Thanks for the quick reply, I’ll stay with the old version for now.
> The host server will move to CentOS 6 in the not too distant future
> anyway, it’s just not something I can do right away.
>

So I just solved the libcgroup dependency issue by adding libcgroup into
the repository.

Now you can remove ploop packages and update vzctl. To do it in one
transaction, you can use yum-shell:

# yum shell
> update vzctl
> remove ploop\*
> run

> Regards,
>
> Holger
>
> --
>
> Holger Rabbach
>
> Assistant International IT Manager
>
> *From:*Kir Kolyshkin [mailto:kir@openvz.org]
> *Sent:* Mittwoch, 26. September 2012 15:13
> *To:* users@openvz.org
> *Cc:* Holger Rabbach (ICT)
> *Subject:* Re: [Users] yum update problem on CentOS 5.8 server
>
> On 09/26/2012 04:46 PM, Holger Rabbach (ICT) wrote:
>
> Hi,
>
> I tried to run yum update on a CentOS 5.8 OpenVZ host server today
> and something strange happened. Yum tries to update vzctl-core to
> version 4.0-1, which seems to require an updated plop-lib package,
> but the updated plop-lib package from the yum repository requires
> a kernel >= 2.6.32 (CentOS 5 runs on 2.6.18). As a result, the
> entire update fails. It looks like there are the wrong package
> versions in the yum repository for RHEL/CentOS 5 – or is there
> something else going on?
>
>
> There are two problems here:
>
> 1 ploop
>
> Since you have RHEL5-based kernel that do not require ploop, you can
> remove ploop when installing vzctl-4.0. I have made vzctl not
> requiring ploop by dynamically loading it when it's available. Note
> that vzctl is not requiring ploop anymore, it just conflicts with the
> old version of it.
>
> 2 libcgroup
>
> Currently I don't have a solution rather than compiling libcgroup from
> source. I will take a closer look in the coming days and find a fix.
>
> In the meantime,
> - please stay with vzctl-3.3 and
> - maybe it's a good time for switching to RHEL6 kernel which has a lot
> of nice features such as VSwap.
>
>
> Best regards,
>
> Holger
>
> PS: full output from yum follows:
>
> [root@paul ~]# yum update
>
> Loaded plugins: dellsysid, fastestmirror, security
>
> Loading mirror speeds from cached hostfile
>
> * base: mirror.netcologne.de
>
> * epel: ftp.uni-koeln.de <ftp://ftp.uni-koeln.de>
>
> * extras: mirror.netcologne.de
>
> * openvz-kernel-rhel5: openvz.proserve.nl
>
> * openvz-utils: openvz.proserve.nl
>
> * updates: mirror.netcologne.de
>
> base | 1.1 kB 00:00
>
> cr | 1.9 kB 00:00
>
> dell-omsa-indep | 1.9 kB 00:00
>
> dell-omsa-specific | 1.9 kB 00:00
>
> openvz-kernel-rhel5 | 951 B 00:00
>
> openvz-utils | 951 B 00:00
>
> updates | 1.9 kB 00:00
>
> Skipping security plugin, no data
>
> Setting up Update Process
>
> Resolving Dependencies
>
> Skipping security plugin, no data
>
> --> Running transaction check
>
> ---> Package ploop.x86_64 0:1.5-1 set to be updated
>
> ---> Package ploop-lib.x86_64 0:1.5-1 set to be updated
>
> ---> Package vzctl.x86_64 0:4.0-1 set to be updated
>
> --> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl
>
> ---> Package vzctl-core.x86_64 0:4.0-1 set to be updated
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl-core
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Finished Dependency Resolution
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is needed
> by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is needed
> by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is needed
> by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1()(64bit) is needed by package
> vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> ploop-lib-1.5-1.x86_64 from openvz-utils has depsolving problems
>
> --> ploop-lib conflicts with ovzkernel
>
> vzctl-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1()(64bit) is needed by package
> vzctl-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by
> package vzctl-4.0-1.x86_64 (openvz-utils)
>
> Error: ploop-lib conflicts with ovzkernel
>
> Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by
> package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> You could try using --skip-broken to work around the problem
>
> You could try running: package-cleanup --problems
>
> package-cleanup --dupes
>
> rpm -Va --nofiles --nodigest
>
> [root@paul ~]#
>
>
> ------------------------------------------------------------ ------------
> OM International Services (Carlisle) Ltd - Unit B Clifford Court,
> Cooper Way - Carlisle CA3 0JG - United Kingdom
> Charity reg no: 1112655 - Company reg no: 5649412 (England and Wales)
>
>


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
RE: yum update problem on CentOS 5.8 server [message #48101 is a reply to message #48100] Thu, 27 September 2012 13:21 Go to previous message
Holger Rabbach (ICT) is currently offline  Holger Rabbach (ICT)
Messages: 3
Registered: September 2012
Junior Member
From: *parallels.com
Thanks again - this worked very nicely.

--
Holger Rabbach
Assistant International IT Manager


-----Original Message-----
From: users-bounces@openvz.org [mailto:users-bounces@openvz.org] On Behalf Of Kir Kolyshkin
Sent: Donnerstag, 27. September 2012 14:54
To: users@openvz.org
Cc: Holger Rabbach (ICT)
Subject: Re: [Users] yum update problem on CentOS 5.8 server

On 09/26/2012 05:32 PM, Holger Rabbach (ICT) wrote:
>
> Thanks for the quick reply, I’ll stay with the old version for now.
> The host server will move to CentOS 6 in the not too distant future
> anyway, it’s just not something I can do right away.
>

So I just solved the libcgroup dependency issue by adding libcgroup into the repository.

Now you can remove ploop packages and update vzctl. To do it in one transaction, you can use yum-shell:

# yum shell
> update vzctl
> remove ploop\*
> run

> Regards,
>
> Holger
>
> --
>
> Holger Rabbach
>
> Assistant International IT Manager
>
> *From:*Kir Kolyshkin [mailto:kir@openvz.org]
> *Sent:* Mittwoch, 26. September 2012 15:13
> *To:* users@openvz.org
> *Cc:* Holger Rabbach (ICT)
> *Subject:* Re: [Users] yum update problem on CentOS 5.8 server
>
> On 09/26/2012 04:46 PM, Holger Rabbach (ICT) wrote:
>
> Hi,
>
> I tried to run yum update on a CentOS 5.8 OpenVZ host server today
> and something strange happened. Yum tries to update vzctl-core to
> version 4.0-1, which seems to require an updated plop-lib package,
> but the updated plop-lib package from the yum repository requires
> a kernel >= 2.6.32 (CentOS 5 runs on 2.6.18). As a result, the
> entire update fails. It looks like there are the wrong package
> versions in the yum repository for RHEL/CentOS 5 – or is there
> something else going on?
>
>
> There are two problems here:
>
> 1 ploop
>
> Since you have RHEL5-based kernel that do not require ploop, you can
> remove ploop when installing vzctl-4.0. I have made vzctl not
> requiring ploop by dynamically loading it when it's available. Note
> that vzctl is not requiring ploop anymore, it just conflicts with the
> old version of it.
>
> 2 libcgroup
>
> Currently I don't have a solution rather than compiling libcgroup from
> source. I will take a closer look in the coming days and find a fix.
>
> In the meantime,
> - please stay with vzctl-3.3 and
> - maybe it's a good time for switching to RHEL6 kernel which has a lot
> of nice features such as VSwap.
>
>
> Best regards,
>
> Holger
>
> PS: full output from yum follows:
>
> [root@paul ~]# yum update
>
> Loaded plugins: dellsysid, fastestmirror, security
>
> Loading mirror speeds from cached hostfile
>
> * base: mirror.netcologne.de
>
> * epel: ftp.uni-koeln.de <ftp://ftp.uni-koeln.de>
>
> * extras: mirror.netcologne.de
>
> * openvz-kernel-rhel5: openvz.proserve.nl
>
> * openvz-utils: openvz.proserve.nl
>
> * updates: mirror.netcologne.de
>
> base | 1.1 kB 00:00
>
> cr | 1.9 kB 00:00
>
> dell-omsa-indep | 1.9 kB 00:00
>
> dell-omsa-specific | 1.9 kB 00:00
>
> openvz-kernel-rhel5 | 951 B 00:00
>
> openvz-utils | 951 B 00:00
>
> updates | 1.9 kB 00:00
>
> Skipping security plugin, no data
>
> Setting up Update Process
>
> Resolving Dependencies
>
> Skipping security plugin, no data
>
> --> Running transaction check
>
> ---> Package ploop.x86_64 0:1.5-1 set to be updated
>
> ---> Package ploop-lib.x86_64 0:1.5-1 set to be updated
>
> ---> Package vzctl.x86_64 0:4.0-1 set to be updated
>
> --> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl
>
> ---> Package vzctl-core.x86_64 0:4.0-1 set to be updated
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) for
> package: vzctl-core
>
> --> Processing Dependency: libcgroup.so.1()(64bit) for package:
> --> vzctl-core
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Processing Conflict: ploop-lib conflicts vzkernel <
> 2.6.32-042stab061.1
>
> --> Finished Dependency Resolution
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is needed
> by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is needed
> by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is needed
> by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1()(64bit) is needed by package
> vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> ploop-lib-1.5-1.x86_64 from openvz-utils has depsolving problems
>
> --> ploop-lib conflicts with ovzkernel
>
> vzctl-4.0-1.x86_64 from openvz-utils has depsolving problems
>
> --> Missing Dependency: libcgroup.so.1()(64bit) is needed by package
> vzctl-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by
> package vzctl-4.0-1.x86_64 (openvz-utils)
>
> Error: ploop-lib conflicts with ovzkernel
>
> Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by
> package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is
> needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
>
> You could try using --skip-broken to work around the problem
>
> You could try running: package-cleanup --problems
>
> package-cleanup --dupes
>
> rpm -Va --nofiles --nodigest
>
> [root@paul ~]#
>
>
> ------------------------------------------------------------ ----------
> -- OM International Services (Carlisle) Ltd - Unit B Clifford Court,
> Cooper Way - Carlisle CA3 0JG - United Kingdom Charity reg no: 1112655
> - Company reg no: 5649412 (England and Wales)
>
>
OM International Services (Carlisle) Ltd - Unit B Clifford Court, Cooper Way - Carlisle CA3 0JG - United Kingdom
Charity reg no: 1112655 - Company reg no: 5649412 (England and Wales)
Previous Topic: yum update problem on 32-bit CentOS 6.3
Next Topic: porting openwrt to openvz
Goto Forum:
  


Current Time: Tue Nov 21 23:18:24 GMT 2017