OpenVZ Forum


Home » Mailing lists » Users » vzquota problem with ploop container ....
vzquota problem with ploop container .... [message #47751] Fri, 07 September 2012 06:22 Go to next message
Rene Dokbua is currently offline  Rene Dokbua
Messages: 24
Registered: May 2012
Junior Member
From: *parallels.com
So now I have created a ploop account, and when I start it I get this error:

# vzctl start 1517
Starting container ...
Adding delta dev=/dev/ploop0 img=/vz2/private/1517/root.hdd/root.hdd (rw)
Mounting /dev/ploop0p1 at /vz2/root/1517 fstype=ext4
data='balloon_ino=12,usrjquota=aquota.user,grpjquota=aquota. group,jqfmt=vfsv0,'
Container is mounted
Adding IP address(es): 209.105.227.151
Setting CPU limit: 50
Setting CPU units: 30000
Setting CPUs: 1
Old quota utils version detected: Quota utilities version 3.13.
Quota utils version should be > 3.16
Container start in progress...

So I checked for the version of Quota installed:

# rpm -qa | grep -i quota
vzquota-3.0.12-1.x86_64

Ok, so it's old .. but ....

# yum update vzquota
Setting up Update Process
No Packages marked for Update

What gives?
Re: vzquota problem with ploop container .... [message #47755 is a reply to message #47751] Fri, 07 September 2012 15:18 Go to previous messageGo to next message
dowdle is currently offline  dowdle
Messages: 261
Registered: December 2005
Location: Bozeman, Montana
Senior Member
From: *coe.montana.edu
Rene,

----- Original Message -----
> Old quota utils version detected: Quota utilities version 3.13.
> Quota utils version should be > 3.16
> Container start in progress...
>
> So I checked for the version of Quota installed:
>
> # rpm -qa | grep -i quota
> vzquota-3.0.12-1.x86_64
>
> Ok, so it's old .. but ....
>
> # yum update vzquota
> Setting up Update Process
> No Packages marked for Update
>
> What gives?

My guess is that they have a updated vzquota package in the works and the other tools have gotten a little ahead of it... but I'm not sure.

TYL,
--
Scott Dowdle
704 Church Street
Belgrade, MT 59714
(406)388-0827 [home]
(406)994-3931 [work]


--
TYL, Scott Dowdle
Belgrade, Montana, USA
Re: vzquota problem with ploop container .... [message #47756 is a reply to message #47751] Fri, 07 September 2012 15:53 Go to previous messageGo to next message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

From: *parallels.com
This is about native quota tools installed into container, not vzquota.

The message means you will not be able to use usual Unix per user and per
group quota inside this container due to old quota utils installed inside
On Sep 7, 2012 10:24 AM, "Rene C." <openvz@dokbua.com> wrote:

> So now I have created a ploop account, and when I start it I get this
> error:
>
> # vzctl start 1517
> Starting container ...
> Adding delta dev=/dev/ploop0 img=/vz2/private/1517/root.hdd/root.hdd (rw)
> Mounting /dev/ploop0p1 at /vz2/root/1517 fstype=ext4
>
> data='balloon_ino=12,usrjquota=aquota.user,grpjquota=aquota. group,jqfmt=vfsv0,'
> Container is mounted
> Adding IP address(es): 209.105.227.151
> Setting CPU limit: 50
> Setting CPU units: 30000
> Setting CPUs: 1
> Old quota utils version detected: Quota utilities version 3.13.
> Quota utils version should be > 3.16
> Container start in progress...
>
> So I checked for the version of Quota installed:
>
> # rpm -qa | grep -i quota
> vzquota-3.0.12-1.x86_64
>
> Ok, so it's old .. but ....
>
> # yum update vzquota
> Setting up Update Process
> No Packages marked for Update
>
> What gives?


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Re: vzquota problem with ploop container .... [message #47769 is a reply to message #47756] Sat, 08 September 2012 04:54 Go to previous messageGo to next message
Rene Dokbua is currently offline  Rene Dokbua
Messages: 24
Registered: May 2012
Junior Member
From: *parallels.com
Ah, ok. So checked the container, has the latest version of quota
for Centos 5.8 = 3.13. Is quota for Centos delayed or OVZ a little
ahead?

On Fri, Sep 7, 2012 at 10:53 PM, Kir Kolyshkin <kir@openvz.org> wrote:
> This is about native quota tools installed into container, not vzquota.
>
> The message means you will not be able to use usual Unix per user and per
> group quota inside this container due to old quota utils installed inside
>
> On Sep 7, 2012 10:24 AM, "Rene C." <openvz@dokbua.com> wrote:
>>
>> So now I have created a ploop account, and when I start it I get this
>> error:
>>
>> # vzctl start 1517
>> Starting container ...
>> Adding delta dev=/dev/ploop0 img=/vz2/private/1517/root.hdd/root.hdd (rw)
>> Mounting /dev/ploop0p1 at /vz2/root/1517 fstype=ext4
>>
>> data='balloon_ino=12,usrjquota=aquota.user,grpjquota=aquota. group,jqfmt=vfsv0,'
>> Container is mounted
>> Adding IP address(es): 209.105.227.151
>> Setting CPU limit: 50
>> Setting CPU units: 30000
>> Setting CPUs: 1
>> Old quota utils version detected: Quota utilities version 3.13.
>> Quota utils version should be > 3.16
>> Container start in progress...
>>
>> So I checked for the version of Quota installed:
>>
>> # rpm -qa | grep -i quota
>> vzquota-3.0.12-1.x86_64
>>
>> Ok, so it's old .. but ....
>>
>> # yum update vzquota
>> Setting up Update Process
>> No Packages marked for Update
>>
>> What gives?
Re: vzquota problem with ploop container .... [message #47772 is a reply to message #47769] Sat, 08 September 2012 09:04 Go to previous messageGo to next message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

From: *parallels.com
On 09/08/2012 08:54 AM, Rene C. wrote:
> Ah, ok. So checked the container, has the latest version of quota
> for Centos 5.8 = 3.13. Is quota for Centos delayed or OVZ a little
> ahead?

Yes, we are ahead, since we're using ext4 on top of ploop.

The problem is, quota utils < 3.17 doesn't support ext4 quotas. That
essentially means
you will not be able to use in-container per-user and per-group quota on
CentOS on
ploop (unless, of course, you manually upgrade quota utils to >= 3.17).

>
> On Fri, Sep 7, 2012 at 10:53 PM, Kir Kolyshkin <kir@openvz.org> wrote:
>> This is about native quota tools installed into container, not vzquota.
>>
>> The message means you will not be able to use usual Unix per user and per
>> group quota inside this container due to old quota utils installed inside
>>
>> On Sep 7, 2012 10:24 AM, "Rene C." <openvz@dokbua.com> wrote:
>>> So now I have created a ploop account, and when I start it I get this
>>> error:
>>>
>>> # vzctl start 1517
>>> Starting container ...
>>> Adding delta dev=/dev/ploop0 img=/vz2/private/1517/root.hdd/root.hdd (rw)
>>> Mounting /dev/ploop0p1 at /vz2/root/1517 fstype=ext4
>>>
>>> data='balloon_ino=12,usrjquota=aquota.user,grpjquota=aquota. group,jqfmt=vfsv0,'
>>> Container is mounted
>>> Adding IP address(es): 209.105.227.151
>>> Setting CPU limit: 50
>>> Setting CPU units: 30000
>>> Setting CPUs: 1
>>> Old quota utils version detected: Quota utilities version 3.13.
>>> Quota utils version should be > 3.16
>>> Container start in progress...
>>>
>>> So I checked for the version of Quota installed:
>>>
>>> # rpm -qa | grep -i quota
>>> vzquota-3.0.12-1.x86_64
>>>
>>> Ok, so it's old .. but ....
>>>
>>> # yum update vzquota
>>> Setting up Update Process
>>> No Packages marked for Update
>>>
>>> What gives?
>>>


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Re: vzquota problem with ploop container .... [message #47775 is a reply to message #47769] Sat, 08 September 2012 13:41 Go to previous message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

From: *parallels.com
On Sep 8, 2012 8:55 AM, "Rene C." <openvz@dokbua.com> wrote:
>
> Ah, ok. So checked the container, has the latest version of quota
> for Centos 5.8 = 3.13. Is quota for Centos delayed or OVZ a little
> ahead?

It basically means you can not use in-container per-user and per-group
quota inside CentOS 5 container on ploop. Unless you manually install newer
quota tools of course.

>
> On Fri, Sep 7, 2012 at 10:53 PM, Kir Kolyshkin <kir@openvz.org> wrote:
> > This is about native quota tools installed into container, not vzquota.
> >
> > The message means you will not be able to use usual Unix per user and
per
> > group quota inside this container due to old quota utils installed
inside
> >
> > On Sep 7, 2012 10:24 AM, "Rene C." <openvz@dokbua.com> wrote:
> >>
> >> So now I have created a ploop account, and when I start it I get this
> >> error:
> >>
> >> # vzctl start 1517
> >> Starting container ...
> >> Adding delta dev=/dev/ploop0 img=/vz2/private/1517/root.hdd/root.hdd
(rw)
> >> Mounting /dev/ploop0p1 at /vz2/root/1517 fstype=ext4
> >>
> >>
data='balloon_ino=12,usrjquota=aquota.user,grpjquota=aquota. group,jqfmt=vfsv0,'
> >> Container is mounted
> >> Adding IP address(es): 209.105.227.151
> >> Setting CPU limit: 50
> >> Setting CPU units: 30000
> >> Setting CPUs: 1
> >> Old quota utils version detected: Quota utilities version 3.13.
> >> Quota utils version should be > 3.16
> >> Container start in progress...
> >>
> >> So I checked for the version of Quota installed:
> >>
> >> # rpm -qa | grep -i quota
> >> vzquota-3.0.12-1.x86_64
> >>
> >> Ok, so it's old .. but ....
> >>
> >> # yum update vzquota
> >> Setting up Update Process
> >> No Packages marked for Update
> >>
> >> What gives?


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Previous Topic: broken URLs for fedora-17 precreated templates on wiki
Next Topic: linux-openvz-2.6.32.59.7-gcc46.patch useful for bug id=2012?
Goto Forum:
  


Current Time: Fri Nov 24 03:48:53 GMT 2017