OpenVZ Forum


Home » Mailing lists » Users » CT migration of ploop failed on nfs
CT migration of ploop failed on nfs [message #47042] Fri, 29 June 2012 14:57 Go to next message
Tommy is currently offline  Tommy
Messages: 9
Registered: November 2011
Junior Member
From: *parallels.com
hi all:
I'm trying the migration of ploop from node1 to node2
the directory /vz/private of node1 is a local dirctory on node1.
the directory /vz/private of node2 is a nfs which I mounted from node3


I started the CT with ploop on node1
I migrated the CT as: vzmigrate -v --online -r no 192.168.5.159 1113

and I got the message as follow:

Starting online migration of CT 1113 to 192.168.5.159
OpenVZ is running...
Loading /etc/vz/vz.conf and /etc/vz/conf/1113.conf files
Check if ploop is supported on destination node
Next unused minor: 0
Check IPs on destination node:
Preparing remote node
Copying config file
1113.conf 100% 1761 1.7KB/s 00:00
No changes in CT configuration, not saving
Creating remote container root dir
Creating remote container private dir
Syncing private
Live migrating container...
Copying top ploop delta with CT suspend
Sending /vz/private/1113/root.hdd/root.hdd
Setting up checkpoint...
suspend...
get context...
Checkpointing completed successfully
Dumping container
Setting up checkpoint...
join context..
dump...
Checkpointing completed successfully
Copying dumpfile
dump.1113 100% 3887KB 3.8MB/s 00:00
Undumping container
Restoring container ...
Starting container ...
Error in do_lock (lock.c:71): Error in flock(/vz/private/1113/root.hdd/DiskDescriptor.xml.lck): Input/output error
Error in do_lock (lock.c:71): Error in flock(/vz/private/1113/root.hdd/DiskDescriptor.xml.lck): Input/output error
Failed to mount image: Error in do_lock (lock.c:71): Error in flock(/vz/private/1113/root.hdd/DiskDescriptor.xml.lck): Input/output error [23]
Error: Failed to undump container
Resuming...

Dose anyone know the problem? is it fixable or some wrong with my configuration?
BTW : is it possible to put the private of CT on the nfs?

Thanks!

Tommy
Re: CT migration of ploop failed on nfs [message #47048 is a reply to message #47042] Sat, 30 June 2012 18:09 Go to previous message
Roman Haefeli is currently offline  Roman Haefeli
Messages: 9
Registered: May 2012
Junior Member
From: *parallels.com
On Fre, 2012-06-29 at 22:57 +0800, Tommy Tang wrote:

> Dose anyone know the problem? is it fixable or some wrong with my configuration?
> BTW : is it possible to put the private of CT on the nfs?

We once had a similar problem. However, our setup is a bit different:
containers running in a old-style CT directory on a NFS share. We faced
some problems with some file locks not being freed properly, which lead
to not being able to start some daemons such as mysqld.

IIRC, the error was similar to yours. Since our cluster infrastructure
makes sure, that a certain container runs only on one node and thus
locking across nodes is not necessary, we simply disabled nfs locking
with the 'nolock' mount option. This solved the issue for us.

Roman
Previous Topic: Filter container traffic
Next Topic: Ubuntu 12.04 issue
Goto Forum:
  


Current Time: Sat Jan 20 05:34:14 GMT 2018