OpenVZ Forum

Home » Mailing lists » Users » loop devices in CT still not allowed ?
loop devices in CT still not allowed ? [message #46790] Wed, 13 June 2012 15:08
Namikaze Minato is currently offline  Namikaze Minato
Messages: 1
Registered: June 2012
Junior Member
Hello everybody.
I'm sorry to dig something that was already corrected before, but I
got some errors I don't manage to take care of alone.

I'm running a SLES11.1 host and a SLES11.1 CT.

First (minor) problem is that services are not started when I start a
CT. I have to start them manually after each boot. (Runlevel retuns
"unknown" in the CTs)

Second (the error I wrote this mail for):
vzctl set --devices|--devnodes: do not allow to enable loop devices in CT
was a bug corrected in version 3.0.29 according to this page:
I've tried:
vzctl set 404 --devnodes loop0:rw
on version 3.1 without success (returning this:
Device loop0 is not allowed to be assigned to a CT
Bad parameter for --devnodes: loop0:rw
), and got exactly the same result with version 3.3
BLK_DEV_LOOP is compiled inside the openvz kernel (2.6.32 vanilla +
042stab049.6 patch), so it's not a problem of the loop module not
loading on startup.

Why is this loop device problem bothering me ? Because every time I
want to install a package that has a dependency which can be resolved
by an rpm from the ISO, the package manager can't mount the ISO to use
these rpms.

I hope you can help me a little on these cases, otherwise I'll have to
stick with these hacks on a prod server, which would not be great.
I'll answer all questions I can answer :)

Thank you very much !
Previous Topic: yum error trying to update vzctl
Next Topic: Re:: loop devices in CT still not allowed ?
Goto Forum:

Current Time: Tue Nov 29 13:49:17 GMT 2022

Total time taken to generate the page: 0.01083 seconds