OpenVZ Forum


Home » Mailing lists » Users » Inode Limits not setting correctly
Inode Limits not setting correctly [message #46554] Mon, 28 May 2012 20:05
Mark Johanson is currently offline  Mark Johanson
Messages: 10
Registered: May 2011
Junior Member
From: *parallels.com
I have been trying to get diskinode limits to set at specific levels.
Namely a 600k:700k with a 1 day grace period. If I manually run the
commands:

vzctl set 127 --diskinodes 600000:700000 --save
vzctl set 127 --quotatime 86400 --save

I get the desired results for a already running VPS. However newly
created VPS's are not keeping the settings and I am not sure what is
assigning the arbitrary numbers it gets. I edited the vz.conf file (as
well as the .sample file) to add the limits as:

> ## Disk quota parameters
> DISKSPACE="50G:50G"
> DISKINODES="600000:700000"
> QUOTATIME="86400"
> DISK_QUOTA=yes

When the VPS builds initially it has the limits set:

# Disk quota parameters (in form of softlimit:hardlimit)
DISKSPACE="50G:50G" (even tried switching this number to the full number instead)
DISKINODES="600000:700000"
QUOTATIME="86400"

However after it completes the build process and restarts itself it has some arbitrary number in for the DISKINODES that I am uncertain where its being pulled from:

# Disk quota parameters (in form of softlimit:hardlimit)
DISKSPACE="5242880:5242880"
DISKINODES="2621440:2621440"
QUOTATIME="86400"

Any suggestions on where to look to make the inode limit work as it should?
Previous Topic: Strange CT creation problem with ploop-1.2.1 and vzkernel-2.6.32-042stab054.5
Next Topic: Re:: Inode Limits not setting correctly
Goto Forum:
  


Current Time: Sat Nov 17 05:07:44 GMT 2018