OpenVZ Forum


Home » International » German » Routing bei 2 Netzwerkkarten
Routing bei 2 Netzwerkkarten [message #45694] Thu, 29 March 2012 11:12
Lebowski is currently offline  Lebowski
Messages: 4
Registered: March 2012
Junior Member

Hallo!

Ich unterhalte 2 Hardware-Server, jeweils identisch und jeweils mit 2 Netzwerkkarten.

Auf einem läuft ein Debian6.0 squeeze System mit OpenVZ (kernel 2.6.32-5-openvz-amd64)

Auf dem anderen das gleichen ohne (kernel 2.6.32-5-amd64)

Eine Netzwerkkarte soll jeweils den Draht nach außen darstellen und die andere patcht die beiden Maschinen einfach lokal zusammen. Hat den Sinn das Datenbankquerys schneller sind und keinen externen Traffic verbrauchen.

Bei der OpenVZ-Maschine laufen nun 3 Container die alle auch schick konfiguriert (ebenfalls Debian 6 squeeze) sind und nach draußen telefonieren können, mit eigener IP und alles soweit schick.

Das Problem steckt nun im Lokalen Link. Interfaces der HN:
jonni@web ~ $ cat /etc/network/interfaces 
### Hetzner Online AG - installimage
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto  eth0
iface eth0 inet static
  address   176.9.112.212
  broadcast 176.9.112.223
  netmask   255.255.255.224
  gateway   176.9.112.193

# default route to access subnet
up route add -net 176.9.112.192 netmask 255.255.255.224 gw 176.9.112.193 eth0

auto eth1
iface eth1 inet static
  address 192.168.0.1
  netmask 255.255.255.0


Und nun soll jede VE in der Lage sein mit dem darunter stehendem Rechner zu kommunizieren, der die IP 192.168.0.2 hat. Dazu habe ich den VEs ganz naiv eine lokale IP gegeben, also:
root@ve100 / # cat /etc/network/interfaces 
# This configuration file is auto-generated.
# WARNING: Do not edit this file, your changes will be lost.
# Please create/edit /etc/network/interfaces.head and /etc/network/interfaces.tail instead,
# their contents will be inserted at the beginning and at the end
# of this file, respectively.
#
# NOTE: it is NOT guaranteed that the contents of /etc/network/interfaces.tail
# will be at the very end of this file.

# Auto generated lo interface
auto lo
iface lo inet loopback

# Auto generated venet0 interface
auto venet0
iface venet0 inet static
	address 127.0.0.1
	netmask 255.255.255.255
	broadcast 0.0.0.0
	up route add -net 192.0.2.1 netmask 255.255.255.255 dev venet0
auto venet0:0
iface venet0:0 inet static
	address 176.9.112.214
	netmask 255.255.255.255
	broadcast 0.0.0.0
	gateway 192.0.2.1

auto venet0:1
iface venet0:1 inet static
	address 192.168.0.100
	netmask 255.255.255.255
	broadcast 0.0.0.0


Der Effekt: Alle Rechner können sich fröhlich anpingen, also 192.168.0.1 <-> 192.168.0.2 und auch die VEs sind ansprechbar von beiden Hardware-Nodes. Das einzige was NICHT geht ist aus der VE auf 192.168.0.2... der eigene Wirt und die VE-Nachbarn gehen jedoch...

Ich vermute irgendwas beim routing murkst... Jemand eine Idee?

lg

Jonni
Previous Topic: -bash: fork: Cannot allocate memory Wer hat Rat?
Next Topic: cannot allocate memory problem
Goto Forum:
  


Current Time: Fri Feb 03 15:50:39 GMT 2023

Total time taken to generate the page: 0.00850 seconds