OpenVZ Forum


Home » Mailing lists » Users » ploop sanity check
ploop sanity check [message #45548] Sat, 17 March 2012 00:21 Go to next message
jjs - mainphrame is currently offline  jjs - mainphrame
Messages: 33
Registered: January 2012
Member
From: *socal.res.rr.com
On a Centos 6 test machine, I installed kernel 2.6.32-042stab052.8,
ploop-1.0 & ploop-lib-1.0 and attempted to follow along with
http://wiki.openvz.org/Ploop/readme.

I've had no success in creating a ploop image:

root@mrmber ~]# ploop init -s 1g -f raw /ploop.image
Creating raw delta /ploop.image size=2097152 sectors
add snapshot {5fbaabe3-6958-40FF-92a7-860e329aab41}
Storing /DiskDescriptor.xml
Can't resolve : No such file or directory
[root@mrmber ~]#

I'd be curious if anyone has gotten farther, and am curious as to what I
might be lacking

Regards,

jjs
Re: ploop sanity check [message #45549 is a reply to message #45548] Sat, 17 March 2012 04:27 Go to previous messageGo to next message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

From: *parallels.com
On 03/17/2012 04:21 AM, jjs - mainphrame wrote:
> On a Centos 6 test machine, I installed kernel 2.6.32-042stab052.8,
> ploop-1.0 & ploop-lib-1.0 and attempted to follow along with
> http://wiki.openvz.org/Ploop/readme.
>
> I've had no success in creating a ploop image:
>
> root@mrmber ~]# ploop init -s 1g -f raw /ploop.image

(as a side node, I do not recommend using raw images, they can not be
shrunk and have some other limitations)

> Creating raw delta /ploop.image size=2097152 sectors
> add snapshot {5fbaabe3-6958-40FF-92a7-860e329aab41}
> Storing /DiskDescriptor.xml
> Can't resolve : No such file or directory

My congratulations, you have found a bug! :)

I have fixed it in git (http://git.openvz.org/?p=ploop;a=commit;h=2e06c26)

In the meanwhile please create an image in a subdirectory, not in root
directory, i.e. something like /tmp/ploop.img should work.

> [root@mrmber ~]#
>
> I'd be curious if anyone has gotten farther, and am curious as to what
> I might be lacking
>
> Regards,
>
> jjs


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Re: ploop sanity check [message #45551 is a reply to message #45549] Sat, 17 March 2012 05:58 Go to previous messageGo to next message
jjs - mainphrame is currently offline  jjs - mainphrame
Messages: 33
Registered: January 2012
Member
From: *socal.res.rr.com
Thank you Kir, good workaround, I can create the ploop device somewhere
other than / and will continue testing.

Joe

On Fri, Mar 16, 2012 at 9:27 PM, Kir Kolyshkin <kir@openvz.org> wrote:

> On 03/17/2012 04:21 AM, jjs - mainphrame wrote:
>
>> On a Centos 6 test machine, I installed kernel 2.6.32-042stab052.8,
>> ploop-1.0 & ploop-lib-1.0 and attempted to follow along with
>> http://wiki.openvz.org/Ploop/**readme<http://wiki.openvz.org/Ploop/readme>
>> .
>>
>> I've had no success in creating a ploop image:
>>
>> root@mrmber ~]# ploop init -s 1g -f raw /ploop.image
>>
>
> (as a side node, I do not recommend using raw images, they can not be
> shrunk and have some other limitations)
>
>
> Creating raw delta /ploop.image size=2097152 sectors
>> add snapshot {5fbaabe3-6958-40FF-92a7-**860e329aab41}
>> Storing /DiskDescriptor.xml
>> Can't resolve : No such file or directory
>>
>
> My congratulations, you have found a bug! :)
>
> I have fixed it in git (http://git.openvz.org/?p=**
> ploop;a=commit;h=2e06c26<http://git.openvz.org/?p=ploop;a=commit;h=2e06c26>
> )
>
> In the meanwhile please create an image in a subdirectory, not in root
> directory, i.e. something like /tmp/ploop.img should work.
>
>
> [root@mrmber ~]#
>>
>> I'd be curious if anyone has gotten farther, and am curious as to what I
>> might be lacking
>>
>> Regards,
>>
>> jjs
>>
>
>
Re: ploop sanity check [message #45553 is a reply to message #45551] Sat, 17 March 2012 07:34 Go to previous message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

From: *parallels.com
17.03.2012 10:02 пользователь "jjs - mainphrame" <jjs@mainphrame.com>
написал:
>
> Thank you Kir, good workaround, I can create the ploop device somewhere
other than / and will continue testing.

Good! I suggest you to compile ploop and vzctl from git and try to use it.
It (mostly) works for me already.

>
> Joe
>
>
> On Fri, Mar 16, 2012 at 9:27 PM, Kir Kolyshkin <kir@openvz.org> wrote:
>>
>> On 03/17/2012 04:21 AM, jjs - mainphrame wrote:
>>>
>>> On a Centos 6 test machine, I installed kernel 2.6.32-042stab052.8,
ploop-1.0 & ploop-lib-1.0 and attempted to follow along with
http://wiki.openvz.org/Ploop/readme.
>>>
>>> I've had no success in creating a ploop image:
>>>
>>> root@mrmber ~]# ploop init -s 1g -f raw /ploop.image
>>
>>
>> (as a side node, I do not recommend using raw images, they can not be
shrunk and have some other limitations)
>>
>>
>>> Creating raw delta /ploop.image size=2097152 sectors
>>> add snapshot {5fbaabe3-6958-40FF-92a7-860e329aab41}
>>> Storing /DiskDescriptor.xml
>>> Can't resolve : No such file or directory
>>
>>
>> My congratulations, you have found a bug! :)
>>
>> I have fixed it in git (http://git.openvz.org/?p=ploop;a=commit;h=2e06c26
)
>>
>> In the meanwhile please create an image in a subdirectory, not in root
directory, i.e. something like /tmp/ploop.img should work.
>>
>>
>>> [root@mrmber ~]#
>>>
>>> I'd be curious if anyone has gotten farther, and am curious as to what
I might be lacking
>>>
>>> Regards,
>>>
>>> jjs
>>
>>
>
>
17.03.2012 10:02 пользователь "jjs - mainphrame" <jjs@mainphrame.com>
написал:

> Thank you Kir, good workaround, I can create the ploop device somewhere
> other than / and will continue testing.
>
> Joe
>
> On Fri, Mar 16, 2012 at 9:27 PM, Kir Kolyshkin <kir@openvz.org> wrote:
>
>> On 03/17/2012 04:21 AM, jjs - mainphrame wrote:
>>
>>> On a Centos 6 test machine, I installed kernel 2.6.32-042stab052.8,
>>> ploop-1.0 & ploop-lib-1.0 and attempted to follow along with
>>> http://wiki.openvz.org/Ploop/**readme<http://wiki.openvz.org/Ploop/readme>
>>> .
>>>
>>> I've had no success in creating a ploop image:
>>>
>>> root@mrmber ~]# ploop init -s 1g -f raw /ploop.image
>>>
>>
>> (as a side node, I do not recommend using raw images, they can not be
>> shrunk and have some other limitations)
>>
>>
>> Creating raw delta /ploop.image size=2097152 sectors
>>> add snapshot {5fbaabe3-6958-40FF-92a7-**860e329aab41}
>>> Storing /DiskDescriptor.xml
>>> Can't resolve : No such file or directory
>>>
>>
>> My congratulations, you have found a bug! :)
>>
>> I have fixed it in git (http://git.openvz.org/?p=**
>> ploop;a=commit;h=2e06c26<http://git.openvz.org/?p=ploop;a=commit;h=2e06c26>
>> )
>>
>> In the meanwhile please create an image in a subdirectory, not in root
>> directory, i.e. something like /tmp/ploop.img should work.
>>
>>
>> [root@mrmber ~]#
>>>
>>> I'd be curious if anyone has gotten farther, and am curious as to what I
>>> might be lacking
>>>
>>> Regards,
>>>
>>> jjs
>>>
>>
>>
>


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Previous Topic: Outbound networking failure
Next Topic: CT freeze on chkpnt --suspend operation, need advice, nothing can't kill it
Goto Forum:
  


Current Time: Sun Dec 17 23:22:23 GMT 2017