OpenVZ Forum


Home » International » French » pas du tous de réseau dans une vps
pas du tous de réseau dans une vps [message #45029] Sun, 22 January 2012 16:47 Go to next message
mtcocktail is currently offline  mtcocktail
Messages: 2
Registered: January 2012
Junior Member
From: *itika.net
J'espere pouvoir trouver une ou deux pistes avec les membres du forum sur mon problème.

Un proxmox qui marche très bien, avec une dizaine de vps en mode openvz venet qui fonctionne aussi.

J'ai migré dessus une vielle VPS qui était une migration physique de fedora-core-2 vers une vps. Elle marchais très bien même au niveau réseau sur un autre serveur, je l'ai migré avec vzmigrate sur un nouveau serveur et là pas de réseau.

Tous marche je peux rentrer dans la vps. Mais a l'intérieure de la vps, j'arrive même pas à pinger l'adresse 127.0.0.1

Voici la sortie du ifconfig dans la vps :

lo        Lien encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:H####
                                                  UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:87 errors:0 dropped:0 overruns:0 frame:0
          TX packets:87 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          RX bytes:5577 (5.4 Kb)  TX bytes:5577 (5.4 Kb)

venet0    Lien encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet adr:127.0.0.1  P-t-P:127.0.0.1  Bcast:0.0.0.0  Masque:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:2003 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2882 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          RX bytes:674839 (659.0 Kb)  TX bytes:189066 (184.6 Kb)

venet0:0  Lien encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet adr:94.23.117.XXX  P-t-P:94.23.117.XXX  Bcast:94.23.117.XXX  Masque:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:2003 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2882 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          RX bytes:674839 (659.0 Kb)  TX bytes:189066 (184.6 Kb)


la route

# netstat -nr
Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic   MSS Fen###e irtt Iface
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 venet0
0.0.0.0         0.0.0.0         0.0.0.0         U         0 0          0 venet0


Et je précise pas de problème sur toutes les autre vps sur le serveur. Sad
Re: pas du tous de réseau dans une vps [message #45039 is a reply to message #45029] Mon, 23 January 2012 12:47 Go to previous messageGo to next message
nyquist is currently offline  nyquist
Messages: 27
Registered: June 2010
Location: 44 - France
Junior Member
From: *fbx.proxad.net
Il me semble avoir eu le même problème a la migration d'une machine physique vers un vps.

J'ai pas trouvé tout de suite la cause donc je redonnait une ip manuellement a mon vps avec vzctl --ipdel && vzctl --ipadd.

Pour la résolution de la cause, je ne sais plus si c'est a cause d'un script dans /etc/network/if-up.d ou de la configuration de /etc/network/interfaces.

Bon c'était une debian migré sur un vps debian mais ca peut te donné des pistes

Regarde aussi du coté de /etc/init.d/ des fois qu'un script mal pensé y soit.
Re: pas du tous de réseau dans une vps [message #45040 is a reply to message #45029] Mon, 23 January 2012 16:41 Go to previous message
mtcocktail is currently offline  mtcocktail
Messages: 2
Registered: January 2012
Junior Member
From: *itika.net
Humm sans plus de succès le vzctl --del puis le --add.

L'ip est bien présente dans la vps, tous semble bien configuré mais ce qui me surprend c'est que dans la VPS je n'arrive même pas a pinger 127.0.0.1

Previous Topic: Openvz & OpenSwan
Next Topic: Config réseau
Goto Forum:
  


Current Time: Sun Apr 23 17:43:17 GMT 2017