OpenVZ Forum


Home » Mailing lists » Users » /usr/sbin/vzctl: undefined symbol: get_set_opt..failed
/usr/sbin/vzctl: undefined symbol: get_set_opt..failed [message #44778] Tue, 03 January 2012 13:50 Go to next message
Benjamin Henrion is currently offline  Benjamin Henrion
Messages: 51
Registered: February 2011
Member
From: *parallels.com
Hi,

I am hiting a bug with vzctl, when I do a "vzctl -a", it hangs, and a
similar behaviour when I restart /etc/init.d/vz:

============================================================ ==================
root@molotov /etc/vz/dists [42]# /etc/init.d/vz restart
Bringing down interface venet0: ..done
Stopping OpenVZ: ..done
Starting OpenVZ: ..done
Bringing up interface venet0: ..done
- Warning: IP forwarding is not enabled
vzctl set 0 --cpuunits 1000 failed: /usr/sbin/vzctl: symbol lookup
error: /usr/sbin/vzctl: undefined symbol: get_set_opt..failed
^[[A
============================================================ ==================

I reinstalled the openvz kernel, vzctl and vzdump, no change of behaviour.

Any idea what this might be?

Maybe a libc6 problem?

Best,

--
Benjamin Henrion <bhenrion at ffii.org>
FFII Brussels - +32-484-566109 - +32-2-4148403
"In July 2005, after several failed attempts to legalise software
patents in Europe, the patent establishment changed its strategy.
Instead of explicitly seeking to sanction the patentability of
software, they are now seeking to create a central European patent
court, which would establish and enforce patentability rules in their
favor, without any possibility of correction by competing courts or
democratically elected legislators."
Re: /usr/sbin/vzctl: undefined symbol: get_set_opt..failed [message #44779 is a reply to message #44778] Tue, 03 January 2012 14:08 Go to previous messageGo to next message
Benjamin Henrion is currently offline  Benjamin Henrion
Messages: 51
Registered: February 2011
Member
From: *parallels.com
On Tue, Jan 3, 2012 at 2:50 PM, Benjamin Henrion <bh@udev.org> wrote:
> Hi,
>
> I am hiting a bug with vzctl, when I do a "vzctl -a", it hangs, and a
> similar behaviour when I restart /etc/init.d/vz:
>
> ============================================================ ==================
> root@molotov /etc/vz/dists [42]# /etc/init.d/vz restart
> Bringing down interface venet0: ..done
> Stopping OpenVZ: ..done
> Starting OpenVZ: ..done
> Bringing up interface venet0: ..done
> - Warning: IP forwarding is not enabled
> vzctl set 0 --cpuunits 1000 failed: /usr/sbin/vzctl: symbol lookup
> error: /usr/sbin/vzctl: undefined symbol: get_set_opt..failed
> ^[[A
> ============================================================ ==================
>
> I reinstalled the openvz kernel, vzctl and vzdump, no change of behaviour.
>
> Any idea what this might be?
>
> Maybe a libc6 problem?

I recompiled a vzctl binary from the git master trunk, moved it to
/usr/sbin, and it works now.

--
Benjamin Henrion <bhenrion at ffii.org>
FFII Brussels - +32-484-566109 - +32-2-4148403
"In July 2005, after several failed attempts to legalise software
patents in Europe, the patent establishment changed its strategy.
Instead of explicitly seeking to sanction the patentability of
software, they are now seeking to create a central European patent
court, which would establish and enforce patentability rules in their
favor, without any possibility of correction by competing courts or
democratically elected legislators."
Re: /usr/sbin/vzctl: undefined symbol: get_set_opt..failed [message #44780 is a reply to message #44778] Tue, 03 January 2012 16:27 Go to previous message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

From: *parallels.com
Your vzctl and vzctl-lib are out of sync.
On Jan 3, 2012 5:53 PM, "Benjamin Henrion" <bh@udev.org> wrote:

> Hi,
>
> I am hiting a bug with vzctl, when I do a "vzctl -a", it hangs, and a
> similar behaviour when I restart /etc/init.d/vz:
>
>
> ============================================================ ==================
> root@molotov /etc/vz/dists [42]# /etc/init.d/vz restart
> Bringing down interface venet0: ..done
> Stopping OpenVZ: ..done
> Starting OpenVZ: ..done
> Bringing up interface venet0: ..done
> - Warning: IP forwarding is not enabled
> vzctl set 0 --cpuunits 1000 failed: /usr/sbin/vzctl: symbol lookup
> error: /usr/sbin/vzctl: undefined symbol: get_set_opt..failed
> ^[[A
>
> ============================================================ ==================
>
> I reinstalled the openvz kernel, vzctl and vzdump, no change of behaviour.
>
> Any idea what this might be?
>
> Maybe a libc6 problem?
>
> Best,
>
> --
> Benjamin Henrion <bhenrion at ffii.org>
> FFII Brussels - +32-484-566109 - +32-2-4148403
> "In July 2005, after several failed attempts to legalise software
> patents in Europe, the patent establishment changed its strategy.
> Instead of explicitly seeking to sanction the patentability of
> software, they are now seeking to create a central European patent
> court, which would establish and enforce patentability rules in their
> favor, without any possibility of correction by competing courts or
> democratically elected legislators."


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Previous Topic: virt-manager and openvz
Next Topic: Openvz at FOSDEM
Goto Forum:
  


Current Time: Sun Dec 17 23:19:58 GMT 2017