OpenVZ Forum


Home » International » German » Nach bash update vzctl enter Problem
icon5.gif  Nach bash update vzctl enter Problem [message #44537] Tue, 13 December 2011 15:40 Go to next message
IronMaidenFan is currently offline  IronMaidenFan
Messages: 2
Registered: October 2007
Junior Member
From: *netcologne.de
Hi,

ich habe einen Container in dem normal Debian Wheezy läuft. Bisher kein Problem. Kürzlich gab es jedoch ein Bash Update auf Version 4.2-1 von 4.1-3. Seit dem komme ich nicht mehr den Container mit vzctl enter 9001. Ein Neustart des CTS brachte auch keine Besserung. Der Container läuft bei einem Neustart problemlos. Das Hostsystem ist übrigens ein standard Debian Squeeze mit Kernel 2.6.32-5-openvz-amd64.

Um genau zu sein: Ich drücke Enter um den Befehl auszuführen und der Cursor springt in die nächste Zeile. Dann passiert nix mehr. Ich kann den Befehl problemlos mit Strg-C beenden.

Mit 'ps auxf' sieht das ganze so aus:
1000     22971  0.0  0.0  21028  3580 pts/0    Ss   16:15   0:00  |       \_ -bash
root     25139  0.0  0.0  37160  1344 pts/0    S    16:22   0:00  |           \_ su -
root     25152  0.0  0.0  19540  2080 pts/0    S    16:22   0:00  |               \_ -su
root     28556  0.0  0.0  18624   956 pts/0    S+   16:31   0:00  |                   \_ vzctl enter 9001
root     28557  0.0  0.0  18624   624 ?        Ss   16:31   0:00  |                       \_ vzctl: pts/0    
root     28558  0.0  0.0  17780  1928 /vz/root/9001/dev/pts/0 Ss+ 16:31   0:00  |     \_ -bash


Mit einem strace sind die letzten Zeilen dies hier:
[pid 28981] rt_sigaction(SIGRT_30, {SIG_DFL, [], SA_RESTORER, 0x7f739d5921e0}, NULL, 8) = 0
[pid 28981] rt_sigaction(SIGRT_31, {SIG_DFL, [], SA_RESTORER, 0x7f739d5921e0}, NULL, 8) = 0
[pid 28981] rt_sigaction(SIGRT_32, {SIG_DFL, [], SA_RESTORER, 0x7f739d5921e0}, NULL, 8) = 0
[pid 28981] rt_sigaction(65, {SIG_DFL, [], SA_RESTORER, 0x7f739d5921e0}, NULL, 8) = -1 EINVAL (Invalid argument)
[pid 28981] ioctl(4, 0x400c2e05, 0x7fff4dec2090) = 9001
[pid 28981] setgroups(0, [])            = 0
[pid 28981] stat("/sbin/init", {st_mode=S_IFREG|0755, st_size=37000, ...}) = 0
[pid 28981] open("/sbin/init", O_RDONLY) = 5
[pid 28981] read(5, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\2\0>\0", 20) = 20
[pid 28981] close(5)                    = 0
[pid 28981] close(4)                    = 0
[pid 28981] open("/dev/ptmx", O_RDWR)   = 4
[pid 28981] statfs("/dev/pts", {f_type="DEVPTS_SUPER_MAGIC", f_bsize=4096, f_blocks=0, f_bfree=0, f_bavail=0, f_files=0, f_ffree=0, f_fsid={0, 0}, f_namelen=255, f_frsize=4096}) = 0
[pid 28981] ioctl(4, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
[pid 28981] ioctl(4, TIOCGPTN, [0])     = 0
[pid 28981] stat("/dev/pts/0", {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 0), ...}) = 0
[pid 28981] stat("/dev/pts/0", {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 0), ...}) = 0
[pid 28981] getuid()                    = 0
[pid 28981] open("/etc/group", O_RDONLY|O_CLOEXEC) = 5
[pid 28981] lseek(5, 0, SEEK_CUR)       = 0
[pid 28981] fstat(5, {st_mode=S_IFREG|0644, st_size=525, ...}) = 0
[pid 28981] mmap(NULL, 525, PROT_READ, MAP_SHARED, 5, 0) = 0x7f739e10a000
[pid 28981] lseek(5, 525, SEEK_SET)     = 525
[pid 28981] munmap(0x7f739e10a000, 525) = 0
[pid 28981] close(5)                    = 0
[pid 28981] ioctl(4, TIOCSPTLCK, [0])   = 0
[pid 28981] ioctl(4, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
[pid 28981] ioctl(4, TIOCGPTN, [0])     = 0
[pid 28981] stat("/dev/pts/0", {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 0), ...}) = 0
[pid 28981] open("/dev/pts/0", O_RDWR|O_NOCTTY) = 5
[pid 28981] ioctl(5, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
[pid 28981] ioctl(5, SNDCTL_TMR_CONTINUE or TCSETSF, {B38400 opost isig icanon echo ...}) = 0
[pid 28981] ioctl(5, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
[pid 28981] ioctl(5, TIOCSWINSZ, {ws_row=62, ws_col=237, ws_xpixel=0, ws_ypixel=0}) = 0
[pid 28981] ioctl(5, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
[pid 28981] readlink("/proc/self/fd/5", "/dev/pts/0", 4095) = 10
[pid 28981] ioctl(5, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
[pid 28981] readlink("/proc/self/fd/5", "/dev/pts/0", 4095) = 10
[pid 28981] rt_sigaction(SIGCHLD, {0x402ce0, [], SA_RESTORER|SA_NOCLDSTOP, 0x7f739d5921e0}, NULL, 8) = 0
[pid 28981] clone(Process 1052 attached
child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f739e1049d0) = 1052
Process 28982 attached (waiting for parent)
[pid 28981] close(5)                    = 0
[pid 28981] close(9)                    = 0
[pid 28981] fcntl(3, F_GETFL)           = 0 (flags O_RDONLY)
[pid 28981] fcntl(3, F_SETFL, O_RDONLY|O_NONBLOCK) = 0
[pid 28981] fcntl(4, F_GETFL)           = 0x8002 (flags O_RDWR|O_LARGEFILE)
[pid 28981] fcntl(4, F_SETFL, O_RDWR|O_NONBLOCK|O_LARGEFILE) = 0
[pid 28981] select(1024, [3 4 10], NULL, NULL, NULL


Hat jmd. ähnliche Erfahrung kürzlich gehabt?
Oder kann mir jmd. Tipps geben, wie ich der Sache weiter auf den Grund gehen kann?

Gruß
Alexander
Re: Nach bash update vzctl enter Problem [message #44793 is a reply to message #44537] Wed, 04 January 2012 14:55 Go to previous messageGo to next message
shion is currently offline  shion
Messages: 5
Registered: August 2009
Junior Member
From: 85.183.32*
Ich habe genau das gleiche Problem. Leider...

Host-System:
debian squeeze
2.6.32-5-openvz-amd64

Container:
debian wheezy
bash 4.2-1 (ob das Problem von dieser Version ausgelöst wurde, kann ich leider nicht sagen)

Mein strace sieht ebenfalls gleich aus (mal abgesehen von ein paar Speicheradressen).
Ein Neustart des Containers hat nichts gebracht, ein Neustart des kompletten Host-Systems ebenso wenig.
Bei allen anderen Containern die mit debian squeeze laufen treten keine Probleme auf.

Hast du bereits eine Lösung oder wenigstens einen Lösungsansatz gefunden?
Re: Nach bash update vzctl enter Problem [message #44794 is a reply to message #44537] Wed, 04 January 2012 15:31 Go to previous messageGo to next message
shion is currently offline  shion
Messages: 5
Registered: August 2009
Junior Member
From: 85.183.32*
Hier die lösung des Rätsels:
Laut dem Eintrag (http://bugzilla.openvz.org/show_bug.cgi?id=1812) im OpenVZ Bugtracker wurde der Bug bereits gefixed. Leider ist dieser Bugfix nicht unter Squeeze verfügbar sondern erst in Wheezy.

[Updated on: Mon, 09 January 2012 16:15] by Moderator

Report message to a moderator

Re: Nach bash update vzctl enter Problem [message #47872 is a reply to message #44794] Mon, 17 September 2012 16:22 Go to previous messageGo to next message
jogy is currently offline  jogy
Messages: 2
Registered: September 2012
Junior Member
From: *pool.mediaWays.net
Hallo!
Also liegt es an der Version von vzctl? Ich habe mal unter squeeze versucht ein Update von vzctl durchzuführen. Ein "./configure" lief noch durch aber kein "make"

Ich bekomme die folgende Fehlermeldung:
xml.c:5:27: error: libxml/parser.h: Datei oder Verzeichnis nicht gefunden
xml.c:6:25: error: libxml/tree.h: Datei oder Verzeichnis nicht gefunden
xml.c:7:30: error: libxml/xmlwriter.h: Datei oder Verzeichnis nicht gefunden
xml.c:49: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'find_child_node'
xml.c:63: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'seek'
xml.c:89: error: expected ')' before '*' token
xml.c:102: error: expected declaration specifiers or '...' before 'xmlNode'
xml.c: In function 'add_child_nodes':
xml.c:104: error: 'xmlNode' undeclared (first use in this function)
xml.c:104: error: (Each undeclared identifier is reported only once
xml.c:104: error: for each function it appears in.)
xml.c:104: error: 'node' undeclared (first use in this function)
xml.c:105: error: 'xmlChar' undeclared (first use in this function)
xml.c:105: error: 'guid' undeclared (first use in this function)
xml.c:106: error: 'val' undeclared (first use in this function)
xml.c:113: error: 'cur_node' undeclared (first use in this function)
xml.c:113: warning: implicit declaration of function 'seek'
xml.c:119: error: 'XML_ELEMENT_NODE' undeclared (first use in this function)
xml.c:121: warning: implicit declaration of function 'xmlGetProp'
xml.c:121: error: 'BAD_CAST' undeclared (first use in this function)
xml.c:121: error: expected ')' before string constant
xml.c:127: error: expected ')' before string constant
xml.c:135: warning: implicit declaration of function 'get_element_txt'
xml.c: At top level:
xml.c:159: error: expected declaration specifiers or '...' before 'xmlNode'
xml.c: In function 'parse_xml':
xml.c:161: error: 'xmlNode' undeclared (first use in this function)
xml.c:161: error: 'cur_node' undeclared (first use in this function)
xml.c:162: error: 'xmlChar' undeclared (first use in this function)
xml.c:162: error: 'guid' undeclared (first use in this function)
xml.c:168: error: 'root_node' undeclared (first use in this function)
xml.c:175: error: expected expression before ')' token
xml.c:177: error: 'BAD_CAST' undeclared (first use in this function)
xml.c:177: error: expected ')' before string constant
xml.c:183: error: too many arguments to function 'add_child_nodes'
xml.c: At top level:
xml.c:224: error: expected ')' before 'writer'
xml.c:262: error: expected ')' before 'writer'
xml.c: In function 'vzctl_store_snapshot_tree':
xml.c:282: error: 'xmlTextWriterPtr' undeclared (first use in this function)
xml.c:282: error: expected ';' before 'writer'
xml.c:283: error: 'xmlDocPtr' undeclared (first use in this function)
xml.c:283: error: expected ';' before 'doc'
xml.c:291: error: 'doc' undeclared (first use in this function)
xml.c:291: warning: implicit declaration of function 'xmlNewDoc'
xml.c:291: error: 'BAD_CAST' undeclared (first use in this function)
xml.c:291: error: expected ')' before 'XML_DEFAULT_VERSION'
xml.c:295: error: 'writer' undeclared (first use in this function)
xml.c:295: warning: implicit declaration of function 'xmlNewTextWriterTree'
xml.c:304: warning: implicit declaration of function 'xmlTextWriterStartDocument'
xml.c:309: warning: implicit declaration of function 'xmlTextWriterStartElement'
xml.c:309: error: expected ')' before string constant
xml.c:316: warning: implicit declaration of function 'xmlTextWriterEndElement'
xml.c:324: error: expected ')' before string constant
xml.c:329: warning: implicit declaration of function 'xmlTextWriterWriteAttribute'
xml.c:329: error: expected ')' before string constant
xml.c:334: warning: implicit declaration of function 'xmlTextWriterWriteElement'
xml.c:334: error: expected ')' before string constant
xml.c:335: error: expected ')' before string constant
xml.c:336: error: expected ')' before string constant
xml.c:337: error: expected ')' before string constant
xml.c:338: error: expected ')' before string constant
xml.c:352: warning: implicit declaration of function 'write_SavedStateItem'
xml.c:359: warning: implicit declaration of function 'write_close_tag'
xml.c:372: warning: implicit declaration of function 'xmlFreeTextWriter'
xml.c:375: warning: implicit declaration of function 'xmlSaveFormatFile'
xml.c:394: warning: implicit declaration of function 'xmlFreeDoc'
xml.c: In function 'vzctl_read_snapshot_tree':
xml.c:402: error: 'xmlDoc' undeclared (first use in this function)
xml.c:402: error: 'doc' undeclared (first use in this function)
xml.c:403: error: 'xmlNode' undeclared (first use in this function)
xml.c:403: error: 'root_element' undeclared (first use in this function)
xml.c:405: error: 'LIBXML_TEST_VERSION' undeclared (first use in this function)
xml.c:407: error: expected ';' before 'doc'
xml.c:411: warning: implicit declaration of function 'xmlDocGetRootElement'
xml.c:413: error: too many arguments to function 'parse_xml'
xml.c:416: warning: implicit declaration of function 'xmlCleanupParser'
make[2]: *** [xml.lo] Fehler 1
make[2]: Leaving directory `/home/jogy/Downloads/openvz/vzctl-3.3/src/lib'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/home/jogy/Downloads/openvz/vzctl-3.3/src'
make: *** [all-recursive] Fehler 1


Re: Nach bash update vzctl enter Problem [message #47934 is a reply to message #44537] Wed, 19 September 2012 14:25 Go to previous messageGo to next message
shion is currently offline  shion
Messages: 5
Registered: August 2009
Junior Member
From: 85.183.32*
Quote:
Also liegt es an der Version von vzctl?
Genau. Ich habe mein Host-System vor einigen Monaten auf Wheezy geupgradet, da es fatal war nicht mehr an die Container ranzukommen.

Bei deinem make Problem kann ich dir leider nicht weiterhelfen.
Re: Nach bash update vzctl enter Problem [message #47936 is a reply to message #47934] Wed, 19 September 2012 14:32 Go to previous message
jogy is currently offline  jogy
Messages: 2
Registered: September 2012
Junior Member
From: *pool.mediaWays.net
Ein Update auf Wheezy wäre gar nicht nötig gewesen. Man kann sich die aktuellen Binarys herunterladen und installieren:
vzctl-3.3-1.x86_64.tar.gz 
vzctl-lib-3.3-1.x86_64.tar.gz


hier -> wiki.openvz.org/Download/vzctl/3.3

Jetzt klappt ein Login auf einen Wheezy-Container von Squeeze aus.

Gruß
Jogy
Previous Topic: WICHTIGE: Probleme bei setzten von CPU- und RAM-Werte
Next Topic: Umzug
Goto Forum:
  


Current Time: Sun Dec 16 00:48:37 GMT 2018