OpenVZ Forum


Home » International » French » Openvz & OpenSwan
Openvz & OpenSwan [message #43672] Wed, 05 October 2011 13:57 Go to next message
artete is currently offline  artete
Messages: 1
Registered: October 2011
Junior Member
From: 217.108.22*
Bonjour,

Voilà mon problème, je possède un serveur dédié sous OpenVZ/Proxmox, ça fonctionne très bien.
Par contre j'ai un problème dans la configuration du VPN.
Je vous explique brièvement, je possède des machines virtuelles bridgé avec des interfaces venet.

J'ai installé openswan sur la machine hôte.
La configuration à l'air bonne.

En faisant un tcpdump sur la machine virtuelle j'ai par exemple :
15:48:06.576741 IP 192.168.1.104.18454 > test.ftp: S 3858949105:3858949105(0) win 8192 <mss 1460,nop,wscale 8,nop,nop,sackOK>
15:48:09.576719 IP 192.168.1.104.18454 > test.ftp: S 3858949105:3858949105(0) win 8192 <mss 1460,nop,wscale 8,nop,nop,sackOK>
15:48:15.577123 IP 192.168.1.104.18454 > test.ftp: S 3858949105:3858949105(0) win 8192 <mss 1460,nop,nop,sackOK>

On voit bien que l'IP 192.168.1.104 accède à ma machine virtuelle, mais celle-ci ne répond pas.
Savez-vous d'où cela peut venir ?

De plus mes VE sont configuré en venet, je ne sais pas si ça a une incidence sur le fonctionnement général.

Merci pour toute aide éventuelle.

Cordialement
Re: Openvz & OpenSwan [message #44874 is a reply to message #43672] Tue, 10 January 2012 12:52 Go to previous message
nyquist is currently offline  nyquist
Messages: 27
Registered: June 2010
Location: 44 - France
Junior Member
From: *fbx.proxad.net
Il manque peut être une route à tes VMs pour savoir par ou passer pour répondre au réseau 192.168.1/24

essaye de mettre ceci sur une VM :
ip route add 192.168.1/24 via IP_LOCAL_DU_NOEUD_PHYSIQUE


Previous Topic: OpenVZ venet accès internet impossible
Next Topic: pas du tous de réseau dans une vps
Goto Forum:
  


Current Time: Tue Jun 27 10:30:52 GMT 2017