OpenVZ Forum


Home » Mailing lists » Users » chkpt/vzmigrate with SSL connections
chkpt/vzmigrate with SSL connections [message #43609] Fri, 30 September 2011 22:22 Go to next message
Dariush Pietrzak is currently offline  Dariush Pietrzak
Messages: 40
Registered: November 2007
Member
From: *parallels.com
Hi
I recently tried migrating live postgresql slave, and it failed, right
after migration such messages appeared in logfile:


011-10-01 00:04:39 CEST LOG: invalid record length at 0/2B008258
2011-10-01 00:04:52 CEST FATAL: no free slots in PMChildFlags array
2011-10-01 00:04:52 CEST LOG: process 10745 releasing ProcSignal slot 2056, but it contains 0
2011-10-01 00:04:54 CEST LOG: process 10743 releasing ProcSignal slot 2055, but it contains 0
2011-10-01 00:05:31 CEST FATAL: could not receive data from WAL stream: SSL connection has been closed unexpectedly

2011-10-01 00:05:31 CEST LOG: process 10746 releasing ProcSignal slot 2058, but it contains 0

since it's just hot-standby and there was no reports running on it, it was safe to restart, so:

2011-10-01 00:05:39 CEST LOG: database system was interrupted while in recovery at log time 2011-10-01 00:03:43 CEST
2011-10-01 00:05:39 CEST HINT: If this has occurred more than once some data might be corrupted and you might need to choose an earlier recovery target.
2011-10-01 00:05:39 CEST LOG: incomplete startup packet
2011-10-01 00:05:39 CEST LOG: entering standby mode
2011-10-01 00:05:39 CEST LOG: consistent recovery state reached at 0/2B008258
afterwards it started working fine.

Kernel is RHEL6 from 17 sep, machines between which guest was being migrated
are identical, I'm not sure if the problem was in SSL contexts becoming
corrupted, or was it somehow related to postgresql inner workings...
I do believe I have successfully transfered running postgresqls before, this
was my first attempt of moving PG with running replication, so I assume the
problem might be related to SSL.
Anyone else encountered something like this?

(I do know that dhcp3 servers require restart after online migration, this is first
time I see applications reporting data corruption in such case)

best regards, Eyck
--
Key fingerprint = 40D0 9FFB 9939 7320 8294 05E0 BCC7 02C4 75CC 50D9
Total Existance Failure
Re: chkpt/vzmigrate with SSL connections [message #43611 is a reply to message #43609] Sat, 01 October 2011 01:53 Go to previous message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

From: *parallels.com
Please file a bug to bugzilla.openvz.org
On Oct 1, 2011 2:24 AM, "Dariush Pietrzak" <ml-openvz-eyck@kuszelas.eu>
wrote:
> Hi
> I recently tried migrating live postgresql slave, and it failed, right
> after migration such messages appeared in logfile:
>
>
> 011-10-01 00:04:39 CEST LOG: invalid record length at 0/2B008258
> 2011-10-01 00:04:52 CEST FATAL: no free slots in PMChildFlags array
> 2011-10-01 00:04:52 CEST LOG: process 10745 releasing ProcSignal slot
2056, but it contains 0
> 2011-10-01 00:04:54 CEST LOG: process 10743 releasing ProcSignal slot
2055, but it contains 0
> 2011-10-01 00:05:31 CEST FATAL: could not receive data from WAL stream:
SSL connection has been closed unexpectedly
>
> 2011-10-01 00:05:31 CEST LOG: process 10746 releasing ProcSignal slot
2058, but it contains 0
>
> since it's just hot-standby and there was no reports running on it, it was
safe to restart, so:
>
> 2011-10-01 00:05:39 CEST LOG: database system was interrupted while in
recovery at log time 2011-10-01 00:03:43 CEST
> 2011-10-01 00:05:39 CEST HINT: If this has occurred more than once some
data might be corrupted and you might need to choose an earlier recovery
target.
> 2011-10-01 00:05:39 CEST LOG: incomplete startup packet
> 2011-10-01 00:05:39 CEST LOG: entering standby mode
> 2011-10-01 00:05:39 CEST LOG: consistent recovery state reached at
0/2B008258
> afterwards it started working fine.
>
> Kernel is RHEL6 from 17 sep, machines between which guest was being
migrated
> are identical, I'm not sure if the problem was in SSL contexts becoming
> corrupted, or was it somehow related to postgresql inner workings...
> I do believe I have successfully transfered running postgresqls before,
this
> was my first attempt of moving PG with running replication, so I assume
the
> problem might be related to SSL.
> Anyone else encountered something like this?
>
> (I do know that dhcp3 servers require restart after online migration, this
is first
> time I see applications reporting data corruption in such case)
>
> best regards, Eyck
> --
> Key fingerprint = 40D0 9FFB 9939 7320 8294 05E0 BCC7 02C4 75CC 50D9
> Total Existance Failure


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Previous Topic: /var/lock/subsys directory missing on openvz debian squeeze
Next Topic: Ubuntu 10.04 template issue
Goto Forum:
  


Current Time: Sun Oct 22 20:56:24 GMT 2017