OpenVZ Forum


Home » Mailing lists » Users » Ubuntu 10.04 template issue
Ubuntu 10.04 template issue [message #43585] Thu, 29 September 2011 05:17 Go to next message
Mark Johanson is currently offline  Mark Johanson
Messages: 10
Registered: May 2011
Junior Member
From: *parallels.com
Having a weird issue with Ubuntu 10.04 templates that started this week.
A newly created template (or existing templates) work just fine until
the following is done:

apt-get upgrade

After doing a upgrade (which consists of 13 updates) nothing in the
template outside of init will start up. I'm wondering if anyone else has
had a issue with 10.04 recently, or has seen this issue before.

Upon VPS creation everything is started fine and you can ping out of the
VPS:



# ping yahoo.com
PING yahoo.com (209.191.122.70) 56(84) bytes of data.
--- yahoo.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1000ms
rtt min/avg/max/mdev = 31.342/31.384/31.426/0.042 ms




So its time to do a update:

# apt-get update && apt-get upgrade
Hit http://archive.ubuntu.com lucid Release.gpg
Get:1 http://archive.ubuntu.com lucid-security Release.gpg [198B]
....
Fetched 418kB in 2s (207kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
mountall
The following packages will be upgraded:
apt apt-utils libdbus-1-3 libgssapi-krb5-2 libk5crypto3 libkrb5-3
libkrb5support0 libpam-modules libpam-runtime libpam0g libpng12-0
logrotate
perl-base
13 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 4623kB of archives.
After this operation, 20.5kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com/ubuntu/ lucid-security/main perl-base
5.10.1-8ubuntu2.1 [1003kB]
Get:2 http://archive.ubuntu.com/ubuntu/ lucid-security/main
libpam-modules 1.1.1-2ubuntu5.3 [371kB]
Get:3 http://archive.ubuntu.com/ubuntu/ lucid-security/main apt
0.7.25.3ubuntu9.7 [1811kB]
Get:4 http://archive.ubuntu.com/ubuntu/ lucid-security/main
libpam-runtime 1.1.1-2ubuntu5.3 [115kB]
Get:5 http://archive.ubuntu.com/ubuntu/ lucid-security/main libpam0g
1.1.1-2ubuntu5.3 [123kB]
Get:6 http://archive.ubuntu.com/ubuntu/ lucid-security/main apt-utils
0.7.25.3ubuntu9.7 [238kB]
Get:7 http://archive.ubuntu.com/ubuntu/ lucid-security/main libk5crypto3
1.8.1+dfsg-2ubuntu0.9 [96.9kB]
Get:8 http://archive.ubuntu.com/ubuntu/ lucid-security/main
libgssapi-krb5-2 1.8.1+dfsg-2ubuntu0.9 [121kB]
Get:9 http://archive.ubuntu.com/ubuntu/ lucid-security/main libkrb5-3
1.8.1+dfsg-2ubuntu0.9 [351kB]
Get:10 http://archive.ubuntu.com/ubuntu/ lucid-security/main
libkrb5support0 1.8.1+dfsg-2ubuntu0.9 [42.9kB]
Get:11 http://archive.ubuntu.com/ubuntu/ lucid-security/main logrotate
3.7.8-4ubuntu2.2 [44.1kB]
Get:12 http://archive.ubuntu.com/ubuntu/ lucid-security/main libdbus-1-3
1.2.16-2ubuntu4.3 [128kB]
Get:13 http://archive.ubuntu.com/ubuntu/ lucid-security/main libpng12-0
1.2.42-1ubuntu2.2 [177kB]
Fetched 4623kB in 8s (564kB/s)
debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog
based frontend cannot be used.
at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 75, <> line 13.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (@INC
contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7, <> line 13.)
debconf: falling back to frontend: Teletype
Preconfiguring packages ...
(Reading database ... 11401 files and directories currently installed.)
Preparing to replace perl-base 5.10.1-8ubuntu2
(using .../perl-base_5.10.1-8ubuntu2.1_i386.deb) ...
Unpacking replacement perl-base ...
Setting up perl-base (5.10.1-8ubuntu2.1) ...
(Reading database ... 11401 files and directories currently installed.)
Preparing to replace libpam-modules 1.1.1-2ubuntu5
(using .../libpam-modules_1.1.1-2ubuntu5.3_i386.deb) ...
debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog
based frontend cannot be used.
at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 75.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (@INC
contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype
Unpacking replacement libpam-modules ...
Setting up libpam-modules (1.1.1-2ubuntu5.3) ...

(Reading database ... 11401 files and directories currently installed.)
Preparing to replace apt 0.7.25.3ubuntu7
(using .../apt_0.7.25.3ubuntu9.7_i386.deb) ...
Unpacking replacement apt ...
Setting up apt (0.7.25.3ubuntu9.7) ...
Installing new version of config file /etc/cron.daily/apt ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
(Reading database ... 11401 files and directories currently installed.)
Preparing to replace libpam-runtime 1.1.1-2ubuntu5
(using .../libpam-runtime_1.1.1-2ubuntu5.3_all.deb) ...
Unpacking replacement libpam-runtime ...
Setting up libpam-runtime (1.1.1-2ubuntu5.3) ...
debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog
based frontend cannot be used.
at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 75.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (@INC
contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype

(Reading database ... 11401 files and directories currently installed.)
Preparing to replace libpam0g 1.1.1-2ubuntu5
(using .../libpam0g_1.1.1-2ubuntu5.3_i386.deb) ...
Unpacking replacement libpam0g ...
Setting up libpam0g (1.1.1-2ubuntu5.3) ...
debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog
based frontend cannot be used.
at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 75.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (@INC
contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
(Reading database ... 11401 files and directories currently installed.)
Preparing to replace apt-utils 0.7.25.3ubuntu7
(using .../apt-utils_0.7.25.3ubuntu9.7_i386.deb) ...
Unpacking replacement apt-utils ...
Preparing to replace libk5crypto3 1.8.1+dfsg-2ubuntu0.8
(using .../libk5crypto3_1.8.1+dfsg-2ubuntu0.9_i386.deb) ...
Unpacking replacement libk5crypto3 ...
Preparing to replace libgssapi-krb5-2 1.8.1+dfsg-2ubuntu0.8
(using .../libgssapi-krb5-2_1.8.1+dfsg-2ubuntu0.9_i386.deb) ...
Unpacking replacement libgssapi-krb5-2 ...
Preparing to replace libkrb5-3 1.8.1+dfsg-2ubuntu0.8
(using .../libkrb5-3_1.8.1+dfsg-2ubuntu0.9_i386.deb) ...
Unpacking replacement libkrb5-3 ...
Preparing to replace libkrb5support0 1.8.1+dfsg-2ubuntu0.8
(using .../libkrb5support0_1.8.1+dfsg-2ubuntu0.9_i386.deb) ...
Unpacking replacement libkrb5support0 ...
Preparing to replace logrotate 3.7.8-4ubuntu2
(using .../logrotate_3.7.8-4ubuntu2.2_i386.deb) ...
Unpacking replacement logrotate ...
Preparing to replace libdbus-1-3 1.2.16-2ubuntu4.1
(using .../libdbus-1-3_1.2.16-2ubuntu4.3_i386.deb) ...
Unpacking replacement libdbus-1-3 ...
Preparing to replace libpng12-0 1.2.42-1ubuntu2.1
(using .../libpng12-0_1.2.42-1ubuntu2.2_i386.deb) ...
Unpacking replacement libpng12-0 ...
Setting up apt-utils (0.7.25.3ubuntu9.7) ...

Setting up libkrb5support0 (1.8.1+dfsg-2ubuntu0.9) ...

Setting up libk5crypto3 (1.8.1+dfsg-2ubuntu0.9) ...

Setting up libkrb5-3 (1.8.1+dfsg-2ubuntu0.9) ...

Setting up libgssapi-krb5-2 (1.8.1+dfsg-2ubuntu0.9) ...

Setting up logrotate (3.7.8-4ubuntu2.2) ...
Setting up libdbus-1-3 (1.2.16-2ubuntu4.3) ...

Setting up libpng12-0 (1.2.42-1ubuntu2.2) ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place





Updates complete and you can still ping out.

# ping yahoo.com
PING yahoo.com (98.137.149.56) 56(84) bytes of data.
64 bytes from ir1.fp.vip.sp2.yahoo.com (98.137.149.56): icmp_seq=1
ttl=52 time=61.4 ms

--- yahoo.com ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms




Reboot the VPS and everything is dead:

# reboot
# got signal 15
exited from CT 700

# vzlist -a
CTID NPROC STATUS IP_ADDR HOSTNAME
700 1 running x.x.x.x server.example.com

# vzctl enter 700
entered into CT 700
# ping yahoo.com
ping: unknown host yahoo.com

After logging in the only processes running are:
1 root 18 0 2256 1092 924 S 0 0.1 0:00.36 init
1080 root 15 0 11228 344 216 S 0 0.0 0:00.00 vzctl
1081 root 15 0 2984 1652 1320 S 0 0.2 0:00.00 bash




I have gone through a number of Ubuntu bug reports trying the various
solutions they have listed with no changes. After updates 10.04 is dead
in the water. Starting up process (for example networking) do not help.
One recommendation is to add --debug and --verbose to the boot process,
but I have not been able to figure out how to pass those kinds of
arguments to the start up process to make Ubuntu actually log something.

Is anyone else having issues with 10.04 recently, or seen anyt
...

Re: Ubuntu 10.04 template issue [message #43586 is a reply to message #43585] Thu, 29 September 2011 07:19 Go to previous messageGo to next message
MailingListe is currently offline  MailingListe
Messages: 29
Registered: May 2008
Junior Member
From: *parallels.com
Zitat von Mark Johanson <mjohanson@a2hosting.com>:

>
> Having a weird issue with Ubuntu 10.04 templates that started this week.
> A newly created template (or existing templates) work just fine until
> the following is done:
>
> apt-get upgrade
>
> After doing a upgrade (which consists of 13 updates) nothing in the
> template outside of init will start up. I'm wondering if anyone else has
> had a issue with 10.04 recently, or has seen this issue before.
>
> Upon VPS creation everything is started fine and you can ping out of the
> VPS:

We had the same problem recently. After upgrade the network in the
Container does not start anymore. Stop the VPS and alter the following
file inside the VPS

/etc/init/networking.conf

Change

start on (local-filesystems and stopped udevtrigger)

to something like this

start on (local-filesystems)

The reason is there is no udev inside the VPS.

Regards

Andreas
  • Attachment: smime.p7s
    (Size: 5.90KB, Downloaded 117 times)
Re: Ubuntu 10.04 template issue [message #43595 is a reply to message #43585] Thu, 29 September 2011 16:54 Go to previous messageGo to next message
Mark Johanson is currently offline  Mark Johanson
Messages: 10
Registered: May 2011
Junior Member
From: *parallels.com
On Thu, 2011-09-29 at 12:00 -0400, users-request@openvz.org wrote:

> /etc/init/networking.conf
>
> Change
>
> start on (local-filesystems and stopped udevtrigger)
>
> to something like this
>
> start on (local-filesystems)
>

Thanks for the information on what to change, unfortunately that appears
to already be set that way:

start on local-filesystems

task

pre-start exec mkdir -p /var/run/network

exec ifup -a

I'll keep digging to see if udev is loading up somewhere else causing a
issue, but any other suggestions on what to look at would be greatly
appreciated.
Re: Ubuntu 10.04 template issue [message #43626 is a reply to message #43595] Mon, 03 October 2011 10:48 Go to previous message
MailingListe is currently offline  MailingListe
Messages: 29
Registered: May 2008
Junior Member
From: *parallels.com
Zitat von Mark Johanson <mjohanson@a2hosting.com>:

>
> On Thu, 2011-09-29 at 12:00 -0400, users-request@openvz.org wrote:
>
>> /etc/init/networking.conf
>>
>> Change
>>
>> start on (local-filesystems and stopped udevtrigger)
>>
>> to something like this
>>
>> start on (local-filesystems)
>>
>
> Thanks for the information on what to change, unfortunately that appears
> to already be set that way:
>
> start on local-filesystems
>
> task
>
> pre-start exec mkdir -p /var/run/network
>
> exec ifup -a
>
> I'll keep digging to see if udev is loading up somewhere else causing a
> issue, but any other suggestions on what to look at would be greatly
> appreciated.

Try to debug what is going on inside the VE by issuing "vzctl exec
<VE-ID> ifconfig" and maybe looking at the VE logfiles. Another glitch
for SSH is using OOM settings in the startupscript /etc/init/ssh.conf
BTW.

Good luck

Andreas
  • Attachment: smime.p7s
    (Size: 5.90KB, Downloaded 107 times)
Previous Topic: chkpt/vzmigrate with SSL connections
Next Topic: Kernel 028stab094.3 not in current
Goto Forum:
  


Current Time: Sun Oct 22 20:57:37 GMT 2017