OpenVZ Forum


Home » General » Support » pcompact deprecated warning from cron
pcompact deprecated warning from cron [message #53785] Thu, 07 April 2022 13:35 Go to next message
wsap is currently offline  wsap
Messages: 55
Registered: March 2018
Location: Halifax, NS
Member
With the upgrade to OpenVZ 7.0.18 the standard nightly cron run of pcompact results in email notifications like this:

Subject: Cron <root@node> /usr/sbin/pcompact -t 2h -q >/dev/null
Message:
WARNING: You are using a deprecated CLI component that won't be installed by default in the next major release. Please use virsh instead
WARNING: You are using a deprecated CLI component that won't be installed by default in the next major release. Please use virsh instead
WARNING: You are using a deprecated CLI component that won't be installed by default in the next major release. Please use virsh instead
WARNING: You are using a deprecated CLI component that won't be installed by default in the next major release. Please use virsh instead

I appreciate that these warnings are handy for those running the command manually, however it doesn't make much sense for a cron run that OpenVZ itself originally set up and uses to send warnings about its own utilities on each cron run like this.

The help docs for pcompact indicate that the -q switch, which is applied, is used to "disable printing of non-error messages to the standard output (console)."

This warning is not an error, and so it should be silenced by the -q switch, no?


[Updated on: Thu, 07 April 2022 13:37]

Report message to a moderator

Re: pcompact deprecated warning from cron [message #53788 is a reply to message #53785] Sun, 10 April 2022 15:34 Go to previous messageGo to next message
vaverin is currently offline  vaverin
Messages: 708
Registered: September 2005
Senior Member
These messages are not an error,
but I'm agree it's very annoying.

Unfortunately I cannot answer your question so I've re-addressed it to developers via devel@openvz.org mailing list.

Thank you,
Vasily Avrein
Re: pcompact deprecated warning from cron [message #53789 is a reply to message #53788] Sun, 10 April 2022 20:50 Go to previous message
vaverin is currently offline  vaverin
Messages: 708
Registered: September 2005
Senior Member
According to developers,
this issue was already reported as
https://jira.sw.ru/browse/PSBM-137949

I hope it will be fixed in next product updates.

Thank you,
Vasily Averin
Previous Topic: /usr/sbin/httpd: page allocation failure?
Next Topic: How To Migrating OpenVZ 6 CT into OpenVZ 7
Goto Forum:
  


Current Time: Mon Sep 26 06:32:04 GMT 2022

Total time taken to generate the page: 0.00671 seconds