OpenVZ Forum


Home » General » Support » emergecy issue " IP lost " (ip lost after reboot container)
emergecy issue " IP lost " [message #53233] Thu, 19 July 2018 01:49
simonq is currently offline  simonq
Messages: 1
Registered: July 2018
Junior Member
From: 124.239.139*
i have a ubuntu 16 container on my host

i restart it sometimes

then i found it didn't have an ip address, the ip lost.
i input 'ifconfig ' in container, just shows 'lo interface ', no ' venet0' and venet0:0 output.
i opened 'etc/network/interfaces' the config is still there


root@localhost:/# ifconfig
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@localhost:/#




interfaces:
auto lo
iface lo inet loopback

# Auto generated venet0 interfaces
auto venet0
iface venet0 inet static
        address 127.0.0.1
        netmask 255.255.255.255
        broadcast 0.0.0.0
        up route add default dev venet0

iface venet0 inet6 static
        address ::2
        netmask 128
        up ip -6 r a default dev venet0
auto venet0:0
iface venet0:0 inet static
        address 192.168.7.13
        netmask 255.255.255.0

Previous Topic: OVZ7 Hyper-converged Storage Solution
Next Topic: Bug reports should go to bugs.openvz.org
Goto Forum:
  


Current Time: Thu Jul 19 05:59:25 GMT 2018