OpenVZ Forum


Home » General » Support » Teamed adapter support? (prlsrvctl doesn't seem to work with teaming.)
Teamed adapter support? [message #52842] Wed, 17 May 2017 16:24 Go to next message
azilber is currently offline  azilber
Messages: 11
Registered: May 2015
Location: Malaysia
Junior Member
From: *time.net.my
Hi All,

I have a server with 4 physical interfaces. Two are teamed on the private network (team0), and two on the public facing network (team1). team0 is bridged to br0 and team1 is bridged to br1. So far so good.

prlsrvctl net list shows eth2 attached to br0 (instead of team0). The interface is called 'Bridged'. I removed it, and tried to add an interface called 'Private' on interface team0 with bridge br0.

I do:

# prlsrvctl net add Private
# prlsrvctl net add Private -t bridged --ifname team0 -d "This is now the private bridged virtual network"
Failed to add Virtual Network Private: Could not find a bridge for network adapter "eth2". Please make sure the bridge is created.

It looks like prlsrvctl isn't aware of teaming. Is there another way to get this working?
Re: Teamed adapter support? [message #52894 is a reply to message #52842] Mon, 17 July 2017 09:45 Go to previous messageGo to next message
VinzC is currently offline  VinzC
Messages: 14
Registered: December 2008
Junior Member
From: *dyn.cybernet.be
I'm not used to OpenVZ 7 but I've had to achieve something similar with an older version. Just create a bridge that has the teamed interface as its member.

Vince C.
Re: Teamed adapter support? [message #52895 is a reply to message #52894] Mon, 17 July 2017 16:02 Go to previous message
azilber is currently offline  azilber
Messages: 11
Registered: May 2015
Location: Malaysia
Junior Member
From: *time.net.my
It's an OVZ7 bug, prlsrvctl doesn't support teaming, so it's not aware of that interface.

OVZ-6902
Previous Topic: Can I really not run VM's on an AMD Opteron 1214?
Next Topic: "Thin pool volumes cannot be reduced in size yet."
Goto Forum:
  


Current Time: Sat Nov 25 00:08:06 GMT 2017