OpenVZ Forum


Home » General » Support » RHEL 7.1 VPS - initscripts upgrade causes networking failures (RHEL 7.1 CentOS initscripts)
RHEL 7.1 VPS - initscripts upgrade causes networking failures [message #51927] Mon, 16 March 2015 23:56 Go to next message
jochum is currently offline  jochum
Messages: 21
Registered: December 2006
Location: Naperville, IL, USA
Junior Member
From: *lucent.com
Hi All:

In upgrading my RHEL container from 7.0 to 7.1 container today, I found that upgrading initscripts (from initscripts-9.49.17-1.el7_0.1.x86_64 to initscripts-9.49.24-1.el7.x86_64) causes networking to fail after a reboot. Before the reboot:

**********************************************************
[root@lss-vps141 ~]# ifconfig -a
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 4 bytes 304 (304.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 4 bytes 304 (304.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

venet0: flags=211<UP,BROADCAST,POINTOPOINT,RUNNING,NOARP> mtu 1500
inet 127.0.0.1 netmask 255.255.255.255 broadcast 0.0.0.0 destination 127.0.0.1
unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 0 (UNSPEC)
RX packets 306 bytes 453581 (442.9 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 152 bytes 8093 (7.9 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

venet0:0: flags=211<UP,BROADCAST,POINTOPOINT,RUNNING,NOARP> mtu 1500
inet 135.1.58.141 netmask 255.255.255.255 broadcast 135.1.58.141 destination 135.1.58.141
unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 0 (UNSPEC)

[root@lss-vps141 ~]# systemctl status -l network.service
network.service - LSB: Bring up/down networking
Loaded: loaded (/etc/rc.d/init.d/network)
Active: active (exited) since Mon 2015-03-16 19:49:58 EDT; 1min 29s ago
Process: 1031 ExecStop=/etc/rc.d/init.d/network stop (code=exited, status=0/SUCCESS)
Process: 1185 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=0/SUCCESS)

Mar 16 19:49:58 lss-vps141 systemd[1]: Starting LSB: Bring up/down networking...
Mar 16 19:49:58 lss-vps141 network[1185]: Bringing up loopback interface: [ OK ]
Mar 16 19:49:58 lss-vps141 network[1185]: Bringing up interface venet0: arping: Device venet0 not available.
Mar 16 19:49:58 lss-vps141 network[1185]: [ OK ]
Mar 16 19:49:58 lss-vps141 systemd[1]: Started LSB: Bring up/down networking.

**********************************************************

After the upgrade and reboot, the same command no longer shows the venet0:0 entry, and error messages in the systemctl status output:

**********************************************************

[root@lss-vps141 ~]# ifconfig -a
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 4 bytes 304 (304.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 4 bytes 304 (304.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

venet0: flags=211<UP,BROADCAST,POINTOPOINT,RUNNING,NOARP> mtu 1500
inet 127.0.0.1 netmask 255.255.255.255 broadcast 0.0.0.0 destination 127.0.0.1
unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 0 (UNSPEC)
RX packets 612 bytes 907174 (885.9 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 300 bytes 16279 (15.8 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

[root@lss-vps141 ~]# systemctl status -l network.service
network.service - LSB: Bring up/down networking
Loaded: loaded (/etc/rc.d/init.d/network)
Active: active (exited) since Mon 2015-03-16 19:52:42 EDT; 9s ago
Process: 1484 ExecStop=/etc/rc.d/init.d/network stop (code=exited, status=0/SUCCESS)
Process: 1639 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=0/SUCCESS)

Mar 16 19:52:42 lss-vps141 network[1639]: Bringing up loopback interface: [ OK ]
Mar 16 19:52:42 lss-vps141 network[1639]: Bringing up interface venet0: arping: Device venet0 not available.
Mar 16 19:52:42 lss-vps141 network[1639]: Determining if ip address 135.1.58.141 is already in use for device venet0...
Mar 16 19:52:42 lss-vps141 network[1639]: arping: Device venet0 not available.
Mar 16 19:52:42 lss-vps141 network[1639]: ERROR : [/etc/sysconfig/network-scripts/ifup-aliases] Error, some other host already uses address 135.1.58.141.
Mar 16 19:52:42 lss-vps141 network[1639]: [ OK ]
Mar 16 19:52:42 lss-vps141 systemd[1]: Started LSB: Bring up/down networking.
[root@lss-vps141 ~]#

**********************************************************

Does anyone know how to fix (or get around) this?

thanks,

Paul
Re: RHEL 7.1 VPS - initscripts upgrade causes networking failures [message #51930 is a reply to message #51927] Tue, 17 March 2015 17:54 Go to previous messageGo to next message
Paparaciz
Messages: 302
Registered: August 2009
Senior Member
From: *static.zebra.lt
I suggest to submit bug report
Re: RHEL 7.1 VPS - initscripts upgrade causes networking failures [message #51960 is a reply to message #51927] Wed, 01 April 2015 01:22 Go to previous messageGo to next message
hermit is currently offline  hermit
Messages: 3
Registered: April 2015
Junior Member
From: *mullvad.net
Seeing exactly the same with Centos7, did a standard install from image, worked fine, updated using YUM, not installed anything new, networking no longer starts, get exactly the same as you did with Debian.

Have you found a fix for it yet?
Re: RHEL 7.1 VPS - initscripts upgrade causes networking failures [message #51961 is a reply to message #51960] Wed, 01 April 2015 08:43 Go to previous messageGo to next message
Claudiu is currently offline  Claudiu
Messages: 1
Registered: April 2015
Junior Member
From: *b.astral.ro
Same with Fedora 21.

One possible fix is to modify /etc/vz/dists/scripts/redhat-add_ip.sh by adding ARPCHECK="no" in function create_config()

function create_config()
{
local ip=$1
local netmask=$2
local ifnum=$3
local file=${IFCFG_DIR}/bak/${VENET_DEV_CFG}:${ifnum}

echo "DEVICE=${VENET_DEV}:${ifnum}
ONBOOT=yes
IPADDR=${ip}
NETMASK=${netmask}"
ARPCHECK=\"no\" > $file ||
error "Can't write to file $file" ${VZ_FS_NO_DISK_SPACE}
}
Re: RHEL 7.1 VPS - initscripts upgrade causes networking failures [message #51962 is a reply to message #51960] Wed, 01 April 2015 11:32 Go to previous messageGo to next message
jochum is currently offline  jochum
Messages: 21
Registered: December 2006
Location: Naperville, IL, USA
Junior Member
From: *lucent.com
Hi Hermit:

Yes, using the "OpenVZ Maintenance Partnership", Kirill was able to point me to a "yet unreleased version of vctl" which has a fix.

If you want it, just copy the following file:
http://git.openvz.org/?p=vzctl ;a=blob;f=etc/dists/scripts/redhat-add_ip.sh;h=d6a52b8960885 d980fcc95201a44881c8efa5f3f;hb=HEAD

over the existing version in /etc/vz/dist/scripts.

This script is then run when vzctl starts, as well as for vzctl set --ipadd.

Hope this helps,

Paul
Re: RHEL 7.1 VPS - initscripts upgrade causes networking failures [message #51964 is a reply to message #51962] Wed, 01 April 2015 23:42 Go to previous messageGo to next message
hermit is currently offline  hermit
Messages: 3
Registered: April 2015
Junior Member
From: *mullvad.net
Thanks for the info.

I'm just an end vps user, so I have passed this on to the providers, hopefully they will do the appropriate. In the meantime, I have added

ip addr add xx.yy.zz.ip dev venet0


to my startup script on my vps.

Re: RHEL 7.1 VPS - initscripts upgrade causes networking failures [message #51965 is a reply to message #51962] Thu, 02 April 2015 13:28 Go to previous messageGo to next message
steveh1966 is currently offline  steveh1966
Messages: 2
Registered: April 2015
Junior Member
From: *theabsoluteorganics.com
Link to download script file does not work.
Re: RHEL 7.1 VPS - initscripts upgrade causes networking failures [message #51966 is a reply to message #51962] Thu, 02 April 2015 13:34 Go to previous messageGo to next message
steveh1966 is currently offline  steveh1966
Messages: 2
Registered: April 2015
Junior Member
From: *theabsoluteorganics.com
Ok works remove the TWO spaces!!
Re: RHEL 7.1 VPS - initscripts upgrade causes networking failures - Working fix [message #51967 is a reply to message #51964] Fri, 03 April 2015 02:31 Go to previous message
hermit is currently offline  hermit
Messages: 3
Registered: April 2015
Junior Member
From: *mullvad.net
Hi

I have resolved the issue on my vps using a patch at at the redhat bugzilla, Bug 1207975 which fixes a bug in the ifup-aliases file in the etc/sysconfig/network-scripts directory of the vps. Sorry, but it wont let me post links, but I am sure you can easily find it.

For anyone else with this problem, please give it a try.
Previous Topic: Systemd
Next Topic: cpuunits on the latest ovz kernel with vswap
Goto Forum:
  


Current Time: Sat Apr 04 11:34:11 GMT 2020