OpenVZ Forum


Home » General » Support » VPS remains offline.
VPS remains offline. [message #51431] Fri, 30 May 2014 17:23 Go to next message
Matresa is currently offline  Matresa
Messages: 1
Registered: May 2014
Junior Member
Hi there. So I recently installed Solusvm on my server and was creating a VPS. Everything seemed fine, but the VPS never actually goes online.

I've looked, and looked, and looked, but can't seem to find what's wrong. Hopefully I can get some help from you. Below is all the info I can possibly think you might need.

Server is running CentOS 6. Had fresh installed everything so thought all the files were meant to be right already.

/boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/md2
#          initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title OpenVZ (2.6.32-042stab088.4)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-042stab088.4 ro root=UUID=0d347cc9-64cf-4e95-aa6d-8db7cbc69a27 rd_NO_LUKS rd_MD_UUID=1dba08ec:25578355:509c0419:c92859eb LANG=en_US.UTF-8 rd_MD_UUID=32cbbc92:39d44be2:c3ead50e:d6f469de SYSFONT=latarcyrheb-sun16 crashkernel=auto  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_LVM rd_NO_DM rhgb quiet
        initrd /initramfs-2.6.32-042stab088.4.img
title CentOS (2.6.32-431.17.1.el6.x86_64)
        root (hd0,0)
@


uname -r and -a
[root@server5 ~]# uname -r
2.6.32-042stab088.4
[root@server5 ~]# uname -a
Linux server5 2.6.32-042stab088.4 #1 SMP Thu Apr 3 17:41:05 MSK 2014 x86_64 x86_64 x86_64 GNU/Linux
[root@server5 ~]#


vi /var/log/vzctl.log
[root@server5 ~]# vi /var/log/vzctl.log
2014-05-30T00:39:27-0400 vzeventd : Started
2014-05-30T00:39:28-0400 vzctl : Setting CPU units: 1000
2014-05-30T00:39:28-0400 vzctl : WARNING: Settings were not saved to config and will be lost after CT restart (use --save flag)
2014-05-30T03:06:45-0400 vzctl : CT 105 : Can't load ploop library: libploop.so: cannot open shared object file: No such file or directory
2014-05-30T03:06:45-0400 vzctl : CT 105 : Please install ploop packages!
2014-05-30T03:06:45-0400 vzctl : CT 105 : Creation of container private area failed
2014-05-30T03:06:45-0400 vzctl : CT 105 : Container config file does not exist
2014-05-30T03:06:45-0400 vzctl : CT 105 : Warning: distribution not specified in CT config, using defaults from /etc/vz/dists/default
2014-05-30T03:06:45-0400 vzctl : CT 105 : Starting container...
2014-05-30T03:06:45-0400 vzctl : CT 105 : Error: required UB parameter kmemsize not set
2014-05-30T03:06:45-0400 vzctl : CT 105 : Error: required UB parameter lockedpages not set
2014-05-30T03:06:45-0400 vzctl : CT 105 : Error: required UB parameter privvmpages not set
2014-05-30T03:06:45-0400 vzctl : CT 105 : Error: required UB parameter shmpages not set
2014-05-30T03:06:45-0400 vzctl : CT 105 : Error: required UB parameter numproc not set


I looked around as to how to set up those parameters but I just have no clue what to change. Please help! Thanks in advance.

[Updated on: Sun, 08 June 2014 16:12]

Report message to a moderator

Re: VPS remains offline. [message #51433 is a reply to message #51431] Sun, 01 June 2014 10:09 Go to previous message
Paparaciz
Messages: 302
Registered: August 2009
Senior Member
I don't know how much solusvm supports ploop.
can you tell which vzctl version you are using?

main problem I think is:
2014-05-30T03:06:45-0400 vzctl : CT 105 : Can't load ploop library: libploop.so: cannot open shared object file: No such file or directory
2014-05-30T03:06:45-0400 vzctl : CT 105 : Please install ploop packages!

did you installed ploop packages?

if solusvm doesn't have ploop support, and you have recent version of vzctl than you might change default VE_LAYOUT in:
/etc/vz/vz.conf

to:
## Filesystem layout for new CTs: either simfs (default) or ploop
VE_LAYOUT=simfs
Previous Topic: venet0 and ipv6 (fully specified issue)
Next Topic: Problem migrating Debian 3.1 physical server to OpenVZ container
Goto Forum:
  


Current Time: Tue Jan 31 00:07:19 GMT 2023

Total time taken to generate the page: 0.00955 seconds