OpenVZ Forum


Home » General » Support » cpu limit not working
cpu limit not working [message #51139] Sun, 23 February 2014 07:01
sahostking is currently offline  sahostking
Messages: 3
Registered: February 2014
Location: Cape Town, South Africa
Junior Member

We have some engineers doing testing and they could increase load to such an extent that it affected other VPS's

07:34:45 up 3 days, 11 min, 4 users, load average: 1463.08, 1474.73, 2174.58

We use OpenVZ with SolusVM and have set CPU limit from the recommend 400 to 200 with cpu cores of 4.

Also IO priority is set to 6.

Anything we can do to prevent this from occurring. We want to ask them to redo their tests but would like to figure out why this is occurring.

Is the only way to stop it just to suspend a VM when it occurs does limiting not "Limit" the VM from using a certain amount?

Let me put it this way. Cloudlinux on shared hosting limits websites to using no more than 25%.

But for some reason with OpenVZ which supposedly works the same but when setting it I still get 1 VPS that can take down or slow down all other VPS's even when dropping it allowance.

For eg we have over 4 VPS's on the server right now.

They have :

CPU Units = 1000
Cores = 4
CPU % = 400

Now lets say all 4 run cpanel with 100 websites each and everything is running smoothly. We then place a app that does cpu stress testing on VM1. The load runs into the 1000s withing minutes as per above and then we notice some sluggishness on other VMS.

vzcpucheck -v gives me this:

VEID CPUUNITS
-------------------------
0 1000
102 1000
103 1000
104 1000
Current CPU utilization: 4000
Power of the node: 1277120


Just can't figure out how to limit that properly. It's like previous procs are not closing fast enough maybe?


Previous Topic: usb passthrough
Next Topic: Duplicate folder or what it is? /vz/root and /home/vps
Goto Forum:
  


Current Time: Sat May 18 03:47:54 GMT 2024

Total time taken to generate the page: 0.01462 seconds