OpenVZ Forum


Home » General » Support » CentOS OpenVZ & IP routing (CentOS OpenVZ & IP routing)
CentOS OpenVZ & IP routing [message #49012] Tue, 19 February 2013 23:01 Go to next message
JonyFX is currently offline  JonyFX
Messages: 1
Registered: February 2013
Location: Russia
Junior Member
I recently got a dedicated server from Hetzner, however, they do not yeild any support, besides hardware support but I have a kinda major issue.

My problem (in short) is basically that IPs doesn't route to the correct container (VPS). I've been told by Hetzner themselfs that I should follow this guide: Cant post links... I did do so, however the Routed "Broute" didn't work, nothing changed, as far as I can tell. So I tried the Bridged mode. After doing as it said I did "service network restart" & it got stuck at Eth0, after like 20-30 seconds it said: "Connection error", as I assumed it broke. I then went into rescue mode to edit the config again & I found out that after removing: "BRIDGE=br0" from the eth0 file it went back to normal.

Here's my eth0 file:

DEVICE=eth0 
BOOTPROTO=static 
ONBOOT=yes 
HWADDR=40:61:86:be:ce:c2 
IPADDR=xx.46.48.74 
NETMASK=255.255.255.255 
SCOPE="peer xx.46.48.65" 
IPV6INIT=yes 
IPV6ADDR=2a01:4f8:110:1385::2/64 
IPV6_DEFAULTGW=fe80::1 
IPV6_DEFAULTDEV=eth0


Not sure if IPv6 is relevant here, so I just added it, in case.

By using the IP (secondary one), I could connect to the server just fine, but it wouldn't redirect to the container.

Searching Google & this forum as well, I found this: Cant use links.... _in_the_same_range Yet bad luck, didn't work. Didn't change anything besides I had to restart the server after a while because it just shut down, basically. (I used the script as suggested)

Any ideas?
Re: CentOS OpenVZ & IP routing [message #49022 is a reply to message #49012] Sat, 23 February 2013 21:14 Go to previous messageGo to next message
Ales is currently offline  Ales
Messages: 330
Registered: May 2009
Senior Member
Well, unless you somehow tell us which guide you've followed, nobody can help you. We simply don't know what you did.

Try and post all the steps you did to set up your VM, exact commands if possible...
Re: CentOS OpenVZ & IP routing [message #49050 is a reply to message #49012] Tue, 05 March 2013 09:03 Go to previous message
erik is currently offline  erik
Messages: 1
Registered: March 2013
Junior Member
Are you trying to use external ip's on the container, or do you want to redirect ports from host to internal network.

If external ip's, is it in the same network as the host ip? Or is i routed to you host ip?


Previous Topic: fork: Cannot allocate memory
Next Topic: Two subnets on one HN, one of them statically routed to the other
Goto Forum:
  


Current Time: Tue Apr 16 19:26:50 GMT 2024

Total time taken to generate the page: 0.01402 seconds