OpenVZ Forum


Home » General » Support » Yum fails to install package in OpenVZ container. (Yum install failures inside container)
Yum fails to install package in OpenVZ container. [message #48270] Wed, 10 October 2012 15:25
vicraj123 is currently offline  vicraj123
Messages: 1
Registered: October 2012
Junior Member
I have OpenVz installed on Fedora 15. In my host OS I am able to install packages such as iperf.

However, when I'm inside a container (logged in a root on the container), I get the following error message:

yum -v install iperf
Config time 0.168
Yum Version: 3.2.29
Setting up Package Sacks
pkgsack time: 0.099
rpmdb time: 0.000
Setting up Install Process
Checking for virtual provide or file-provide for iperf
No package iperf available. Error: Nothing to do


The host OS and the container have the same set of repositories listed in /etc/yum.repos.d. Also there are no excludes in yum.conf, either on the host or the guest container.

What is really perplexing to me is I have this working on a different install of Fedora 15 with OpenVZ that I did a few months ago. I can't figure out what's different about this install.

In case it matters, all of this is running inside a VirtualBox VM i.e. I have a VirtualBox VM running Fedora 15 with OpenVZ installed on it.

Any help with this will be greatly appreciated---I'm at my wits end trying to figure this out. Thanks!
Previous Topic: Multiple hosts: networking and venet
Next Topic: Live migration issues
Goto Forum:
  


Current Time: Sun Nov 27 19:55:26 GMT 2022

Total time taken to generate the page: 0.00975 seconds