OpenVZ Forum

Home » General » Support » tail/multitail not working - vztop works (strange terminal problems)
tail/multitail not working - vztop works [message #47299] Fri, 27 July 2012 10:50
faris is currently offline  faris
Messages: 2
Registered: July 2012
Location: UK
Junior Member
Hi guys,

I hope you'll allow me some slack - I'm actually running Virtuozzo rather than OpenVZ, but given the nature of the problems I'm having I'm guessing that it won't make much difference in this case.

I've just commissioned some new Centos 6.3 hardware nodes and the result has been a lot of crying. I've had horrible problems with Containers that were happy using SLM parameters on my old machines but go nuts on my new machines running 2.6.32-042stab057.1. For example with 2Gb assigned via SLM, a Container would use 1.6Gb and be very happy. The same container migrated to the new machine, set to use vSwap (--ram 2G --swap 1G) runs out of memory - ftp, email, httpd etc stop working correctly with various memory allocation errors.

While trying to investigate this, I encountered the problem that this post is really about --- I can't seem to use "tail -f" or multitail via an ssh session (PuTTY) on the HN.

With tail -f, the content of whatever log I want to look at is shown at the moment that I run the command, but never updates. There's no scrolling at all.

With multitail the same thing happens - I get various windows on the screen showing the contents of the logs at the moment I run the command, but no update to the contents of the logs.

If I enter into a Container via the HN (vzctl enter CTID) I can run tail or multitail inside them with no problem. They work correctly. The issue only happens when running these commands on the HN itself.

Both the Containers and the HN are running Centos 6.3 x86_64. As I say, kernel is 2.6.32-042stab057.1. vzctl-4.7.0-76.x86_64 if it makes any difference?

Initially I thought it was some sort of terminal issue, but vztop works fine, which would seem to it ncurses? doing its thing and terminal redraws are possible.

Has anyone encountered anything like this before? I don't know where to begin looking for what might be causing the problem.


Previous Topic: Access to hard disk serial number
Next Topic: OpenVZ RHEL6 is much more stable now
Goto Forum:

Current Time: Tue Dec 05 04:23:13 GMT 2023

Total time taken to generate the page: 0.02018 seconds