OpenVZ Forum


Home » International » German » vzctl problem
vzctl problem [message #36599] Fri, 03 July 2009 19:45 Go to next message
Anonymous Coward From: *dip.t-dialin.net
Hi,

Ich gehe atm nach diesem guide hier:

http://wiki.openvz.org/Installation_on_Debian

ich nutze debian 5!

nun wollte ich folgendes machen: apt-get install vzctl-ostmpl-debian

kommt aber dass das packet nicht gefunden wird Oo

Quote:


apt-get install vzctl-ostmpl-debian
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
E: Konnte Paket vzctl-ostmpl-debian nicht finden



hoffe auf baldige hilfe, mfg aless
Re: vzctl problem [message #36600 is a reply to message #36599] Sat, 04 July 2009 04:42 Go to previous messageGo to next message
notbuu is currently offline  notbuu
Messages: 34
Registered: June 2009
Member
From: *adsl.highway.telekom.at
Hallo Aless!

Boernie oder ich werden uns das mal anschauen. Kommen aber wahrscheinlich erst am Abend oder nach dem Wochenende dazu.

LG Mario

[Updated on: Sat, 04 July 2009 05:14]

Report message to a moderator

Re: vzctl problem [message #36602 is a reply to message #36599] Sat, 04 July 2009 09:14 Go to previous messageGo to next message
Anonymous Coward From: *dip.t-dialin.net
Hi

Vielen Dank für eure Hilfe.
Ich hab den Verdacht, dass es vielleicht daran liegen könnte, dass bei Debian 4 die Packete anders gehießen haben. Ich werd auch noch ein wenig "rumeqperimentieren".
Schönes Wochenende euch,

MfG Aless
Re: vzctl problem [message #36606 is a reply to message #36602] Sat, 04 July 2009 16:34 Go to previous messageGo to next message
Anonymous Coward From: *dip.t-dialin.net
okay, problem gefunden. Ich hab debian lenny (5) und bin nach nem etch (4) guide gegangen. Hab das ganze nun neu versucht scheint auch alles zu klappen. Aber wenn ich probier im openvz kernel zu starten kommt folgende fehlermeldung:

This kernel requires the following features not present on the CPU:
pae
Unable to boot - please use a kernel appropriate for your CPU

Was soll ich tun? Ist mein alter Laptop schrott? xD

hier mal der Link zu meinem englishen thread, da ist alles ausführlicher erklärt:

http://forum.openvz.org/index.php?t=tree&goto=36605& #msg_36605

MfG Aless
Re: vzctl problem [message #36607 is a reply to message #36599] Sat, 04 July 2009 16:34 Go to previous messageGo to next message
notbuu is currently offline  notbuu
Messages: 34
Registered: June 2009
Member
From: *adsl.highway.telekom.at
Hi,

wir helfen gerne!

Ups... du warst schneller....

Also, ich hab mal auf einem unserer Debian 5 Server nachgeschaut. Die Pakete sind wirklich nicht im standard Repository vorhanden.

Die wiki-Seite welche du verlink hast, listet auch das Repository von Thorsten Schifferdecker aka. curx (hier im deutschen Forum der Moderator).

Ein Blick in sein Repository ( http://download.openvz.org/debian-systs/pool/openvz/v/vzctl- ostemplate/) hat gezeigt, dass Template Packages vorhanden sind. Das Datum ist halt schon vom Jänner, sollte aber kein großes Problem sein (wenn überhaupt).

Fazit: Wenn du diese Templates verwenden möchtest, einfach das Repository vom wiki eintragen, dann kannst du das Template installieren. Vorsicht, ich hab mir die Pakete jetzt nicht angeschaut, ob sie zur Verzeichnisstruktur von Lenny passen (/var/lib/vz)! Vielleicht mache ich das später...

Alternativ: Wir machen unsere Templates selber, legen diese in ein Repository und können sie dann auch mit apt installieren. (wir haben aber auch mehr VPSen wo sich das auszahlt)

LG Mario

[Updated on: Sat, 04 July 2009 16:48]

Report message to a moderator

Re: vzctl problem [message #36608 is a reply to message #36607] Sat, 04 July 2009 16:39 Go to previous messageGo to next message
Anonymous Coward From: *dip.t-dialin.net
hey Smile

danke für die hilfe, soweit bin ich mittlerweile auch schon :S
habe ungefähr 10 sekunden bevor du gepostet hast das hier geschrieben:

http://forum.openvz.org/index.php?t=tree&th=7681&mid =36606&&rev=&reveal=

ich denke dass ich das mit meinem alten laptop nicht hinbekomme oder? (Zumindest nicht mit deb. Lenny)

MfG Aless
Re: vzctl problem [message #36610 is a reply to message #36599] Sat, 04 July 2009 16:56 Go to previous messageGo to next message
notbuu is currently offline  notbuu
Messages: 34
Registered: June 2009
Member
From: *adsl.highway.telekom.at
Hehe Laughing

Habe mir deinen Post angeschaut und nehme einfach mal an, dass du schon direkt nach der Kernel installation versucht hast zu booten.

Wieviel GB oder MB Ram hat dein altes Notebook?
Was hast du für eine CPU in deinem Notebook?

i686 steht für Compiler Optimierungen für Prozessoren der 6ten Gerneration. Sollte der Laptop _wirklich_ alt sein, dann könnte es Probleme geben.

Also, was in jedem Fall gehen sollte ist ein Vanilla Kernel mit dem Stable OpenVZ Patch.

Ich glaube es gibt im wiki eine Anleitung dazu, ansonsten kann ich bei mir einmal nachkramen. Ich habe in der Firma für Etch mal eine Doku geschrieben, da es dort noch keine fertigen Kernel gab.

LG Mario
Re: vzctl problem [message #36613 is a reply to message #36599] Sat, 04 July 2009 18:37 Go to previous messageGo to next message
Anonymous Coward From: *adsl.alicedsl.de
Hi,

ich habe gebootet, nachdem ich die schritte vorgenommen habe, die ich im englishen beriech gepostet hab.

mein alter laptop hat 512mb ram, intel celeron 1,5ghz

es handelt sich dabei um dieses modell: http://www.loveno.be/product/8079

nur den ram habe ich daran verbessert, von 256mb auf 512^^

mfg aless
Re: vzctl problem [message #36621 is a reply to message #36613] Sun, 05 July 2009 14:13 Go to previous messageGo to next message
Anonymous Coward From: *dip.t-dialin.net
achja was ich mich frage, warum der debian 686 kernel bei mir läuft, wenn ich uname -r eingeb gibt er das hier aus:
2.6.26-2-686

daher sollte es ja eigentlich laufen oder? Oo
Re: vzctl problem [message #36622 is a reply to message #36599] Sun, 05 July 2009 14:29 Go to previous messageGo to next message
notbuu is currently offline  notbuu
Messages: 34
Registered: June 2009
Member
From: *adsl.highway.telekom.at
Hi!

stimmt, sollte eigentlich laufen, und von der 3GB Grenze, (PAE) bist du meilenweit entfernt.

Kontrolliere bitte einmal in deiner /boot/grub/menu.lst ob dort beim OpenVZ Kernel zusätzliche Parameter beim Starten mit angegeben werden, welche beim "normale" 686 Kernel boot fehlen.

Ich glaube allerdings, dass das nichts bringen wird. Habe hier eine Post gefunden: http://www.linuxquestions.org/questions/linux-laptop-and-net book-25/kernel-panic-cannot-execute-a-pae-enabled-kernel-on- a-pae-less-cpu-548990/

Gleiches Problem, Lösung: Kernel ohne PAE Option neu kompilieren.

LG Mario
Re: vzctl problem [message #36625 is a reply to message #36599] Sun, 05 July 2009 15:28 Go to previous messageGo to next message
Anonymous Coward From: *dip.t-dialin.net
Hi,

ich seh da keine neuen parameter.

OpenVZ Kernel:
Quote:


title Debian GNU/Linux, kernel 2.6.26-2-openvz-686
root (hd0,0)
kernel /boot/vmlinuz-2.6.26-2-openvz-686 root=/dev/hda1 ro quiet
initrd /boot/initrd.img-2.6.26-2-openvz-686



"Normaler" Kernel:

Quote:


title Debian GNU/Linux, kernel 2.6.26-2-686
root (hd0,0)
kernel /boot/vmlinuz-2.6.26-2-686 root=/dev/hda1 ro quiet
initrd /boot/initrd.img-2.6.26-2-686





Achja, ich habe mir heute die Zeit genommen und das ganze auf meinem neuen Laptop (Samsung r710) mit VMware installiert. Läuft zwar ein wenig lahm (wegen vmware) aber funktionieren tut bei dem System alles.
Da ich das ganze sowieso nur installiert habe, um zu sehen ob ich das per remote alles hinbekomme hat es nun seinen Zweck erfüllt. Ich denke ich bin bereit das ganze dann auf meinem neuen Root zu installieren, wenn ich ihn mit bestelle^^ (mein jetziger läuft leider noch bis zum 29 juli, wenn der weg ist hol ich mir den neuen.)

Ich hätte mir einiges an Zeit sparen können, wenn ichs gleich per VMware auf meinem neuen system versucht hätte aber ist ja nun egal^^

Ich bedanke mich Herzlichst bei dir, für deine Hilfe & deine Geduld^^ Sollte ich mit meinem Root Probleme haben werde ich mich hier nocheinmal melden.

So Long~

MfG Aless
Re: vzctl problem [message #36626 is a reply to message #36599] Sun, 05 July 2009 16:19 Go to previous message
notbuu is currently offline  notbuu
Messages: 34
Registered: June 2009
Member
From: *adsl.highway.telekom.at
Hi,

freut mich, dass es soweit geklappt hat! Bei Fragen, immer rein hier damit! Wir helfen gerne, wenn wir können = community!

Have a lot of fun!

Mario
Previous Topic: openVPN bridging Multi-Singlepoint
Next Topic: Bitte um schnelle Hilfe: Problem mit Quota Einstellungen für Container
Goto Forum:
  


Current Time: Thu Oct 29 13:11:46 GMT 2020