OpenVZ Forum


Home » General » Support » stdin: is not a tty.
stdin: is not a tty. [message #32977] Sat, 13 September 2008 05:00 Go to next message
Otto is currently offline  Otto
Messages: 3
Registered: March 2007
Junior Member
Hello community,

When I do SCP on CentOS (centos 5.1 x86_64 template) with OpenVZ, and I get this. It is happening to all my nodes:

stdin: is not a tty
10meg.zip 10% 1060KB 206.6KB/s 00:44 E

DEV is indeed there. I tried remaking dev, but didn't solve it. If I do vzctl enter, it shows but I can still enter:

[root@cl1 ~]# vzctl enter 110
entered into VE 110
mesg: error: tty device is not owned by group `tty'

So, I looked at the VE's /dev/ to see the ttyx's to see if they are indeed owned by group tty, and surprisingly, it is.

root@lax1 [/]# ls -lh /dev/ | grep ttyx
crw-rw-rw- 1 root tty 3, 128 Sep 2 06:08 ttyx0
crw-rw-rw- 1 root tty 3, 129 Sep 2 06:08 ttyx1
crw-rw-rw- 1 root tty 3, 130 Sep 2 06:08 ttyx2
crw-rw-rw- 1 root tty 3, 131 Sep 2 06:08 ttyx3
crw-rw-rw- 1 root tty 3, 132 Sep 2 06:08 ttyx4
crw-rw-rw- 1 root tty 3, 133 Sep 2 06:08 ttyx5
crw-rw-rw- 1 root tty 3, 134 Sep 2 06:08 ttyx6
crw-rw-rw- 1 root tty 3, 135 Sep 2 06:08 ttyx7
crw-rw-rw- 1 root tty 3, 136 Sep 2 06:08 ttyx8
crw-rw-rw- 1 root tty 3, 137 Sep 2 06:08 ttyx9
crw-rw-rw- 1 root tty 3, 138 Sep 2 06:08 ttyxa
crw-rw-rw- 1 root tty 3, 139 Sep 2 06:08 ttyxb
crw-rw-rw- 1 root tty 3, 140 Sep 2 06:08 ttyxc
crw-rw-rw- 1 root tty 3, 141 Sep 2 06:08 ttyxd
crw-rw-rw- 1 root tty 3, 142 Sep 2 06:08 ttyxe
crw-rw-rw- 1 root tty 3, 143 Sep 2 06:08 ttyxf

Please help as I am clueless at this point. I asked others and they are also facing the same problem.

Linux xxxxxx.xxxx.com 2.6.18-92.1.1.el5.028stab057.2 #1 SMP Mon Jul 21 17:08:31 MSD 2008 x86_64 x86_64 x86_64 GNU/Linux
Re: stdin: is not a tty. [message #33000 is a reply to message #32977] Tue, 16 September 2008 19:00 Go to previous messageGo to next message
xemul is currently offline  xemul
Messages: 248
Registered: November 2005
Senior Member
Plz, explain the same thing in our Bugzilla - this will helps you and us to track this problem better.

http://static.openvz.org/userbars/openvz-developer.png
Re: stdin: is not a tty. [message #33062 is a reply to message #32977] Sat, 20 September 2008 23:58 Go to previous message
Otto is currently offline  Otto
Messages: 3
Registered: March 2007
Junior Member
Thanks, I've already submitted it on Bugzilla.
Previous Topic: Creation of VE private area failed
Next Topic: Get WebVZ 2.0 on Gentoo to Administrate OpenVZ
Goto Forum:
  


Current Time: Sun Nov 27 19:29:19 GMT 2022

Total time taken to generate the page: 0.00889 seconds