OpenVZ Forum


Home » General » Support » Memory limits in active VE - refreshing info in VE system?
Memory limits in active VE - refreshing info in VE system? [message #32998] Tue, 16 September 2008 15:11 Go to next message
januszzz is currently offline  januszzz
Messages: 50
Registered: January 2007
Location: Opole, Poland
Member
Hi,
I'm setting memory limits in active VE. Everything works OK, settings appears immediately in /proc/user_beancounters.

But the question is if I should also see extended/decreased parameters when I run 'free' command? I do see old parameters until I reboot the VE.

Is it a way to refresh this in free and/or cat /proc/meminfo output?
Re: Memory limits in active VE - refreshing info in VE system? [message #32999 is a reply to message #32998] Tue, 16 September 2008 18:57 Go to previous messageGo to next message
xemul is currently offline  xemul
Messages: 248
Registered: November 2005
Senior Member
The things you see in /proc/meminfo depends on the --meminfo <mode> you used for your ve.

Can you provide some more detail on the problems you have - ve config file, free outputs, vzctl set commands you type, etc.


http://static.openvz.org/userbars/openvz-developer.png
Re: Memory limits in active VE - refreshing info in VE system? [message #33001 is a reply to message #32999] Tue, 16 September 2008 19:28 Go to previous messageGo to next message
januszzz is currently offline  januszzz
Messages: 50
Registered: January 2007
Location: Opole, Poland
Member
--meminfo you say... so RTFM just helped... Cool

It appears that if I change privvmpages/kmemsize values of /proc/meminfo are not in line with real memory setting until the VE reboot, this is my issue.

I've changed --meminfo to pages:value which is appripriate for real memory assigned to VE. After reboot of the VE this setting will revert, but free will show correct (privvmpages) information.

Do I get it right, should it be like that?

Configs are usual, I just didn't know the meminfo option... strange, I've read the manual three years ago Wink
Re: Memory limits in active VE - refreshing info in VE system? [message #35951 is a reply to message #33001] Wed, 06 May 2009 04:11 Go to previous message
bbhenry is currently offline  bbhenry
Messages: 17
Registered: February 2009
Junior Member
I have the same issue. And this is happening to my installation on a Ubuntu 8.04 64 bit Hardware Node.

My other CentOS based Hardware Node don't have this issue. What ever memory I assigned to the VE, the "free" command inside VE will reflect right away my changes.

So I am wondering if this is a bug of the Ubuntu 8.04 OpenVZ kernel?
Previous Topic: OpenVZ on Ubuntu 9.04 (Jaunty) Host
Next Topic: updated from centos 5.2 to 5.3, yum error now on VEs
Goto Forum:
  


Current Time: Sun Nov 27 18:36:37 GMT 2022

Total time taken to generate the page: 0.00934 seconds