OpenVZ Forum


Home » General » Support » Quota file is gone!
Quota file is gone! [message #16448] Thu, 06 September 2007 20:10 Go to next message
silentninja is currently offline  silentninja
Messages: 37
Registered: September 2007
Member
Today i noticed that on one of our VPS servers, the aquota.user and aquota.group files are gone... i mean, they're symlinks to /proc/vz/vzaquota/*/aquota... but... there's nothing in vzaquota.

On the conf file I've set the quotaugid option and the fstab looks fine to me:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/sda5       /               ext3    defaults,usrquota 1 1
/dev/sda1       /boot           ext3    defaults,usrquota 1 2
/dev/sda3       /tmp            ext3    defaults,noexec,usrquota 1 0
none            /dev/pts        devpts  gid=5,mode=620 0 0
none            /proc           proc    defaults 0 0
none            /dev/shm        tmpfs   defaults 0 0
/dev/sda2       swap            swap    defaults 0 0

/dev/sdb1       /vz/private/101         ext3    defaults,usrquota 0 0
/dev/sdb2       /vz/private/102         ext3    defaults,usrquota 0 0
/dev/sdb3       /vz/private/103         ext3    defaults,usrquota 0 0
/dev/sdb5       /vz/private/105         ext3    defaults,usrquota 0 0
/dev/sdb6       /vz/private/106         ext3    defaults,usrquota 0 0
/dev/sdb7       /vz/private/107         ext3    defaults,usrquota 0 0
/dev/sdb8       /vz/private/108         ext3    defaults,usrquota 0 0
/dev/sdb9       /vz/private/109         ext3    defaults,usrquota 0 0
/dev/sdb10      /vz/private/110         ext3    defaults,usrquota 0 0
/dev/sdc        /backup         ext3    defaults        1 2

/dev/hda                /media/cdrom            auto    pamconsole,exec,noauto,managed 0 0



sda is the OS disk, sdb is where I store my vps servers and sdc is a backup disk. Do you have any idea why the proc vzaquota file is not there anymore? Is there any fix to rebuild it?

I've tried a quotacheck on each vps, but it creates the aquota file and not the aquota symlink... as a part time solution works... until i restart that vps and boom, it gets overwritten.

I've googled searching for this, but I've only found how to fix the broken symlink, but not the other way around that i need.
Re: Quota file is gone! [message #16458 is a reply to message #16448] Fri, 07 September 2007 04:44 Go to previous messageGo to next message
Vasily Tarasov is currently offline  Vasily Tarasov
Messages: 1345
Registered: January 2006
Senior Member
Hi,

Can you tell us please full OpenVZ kernel version you're using?

Thank you,
Vasily
Re: Quota file is gone! [message #16472 is a reply to message #16448] Fri, 07 September 2007 19:14 Go to previous messageGo to next message
silentninja is currently offline  silentninja
Messages: 37
Registered: September 2007
Member
I'm using a OpenVZ Kernel: 2.6.9-023stab016.2-smp
The servers are running on a x64 intel pentium processor.
problem.... [message #16473 is a reply to message #16472] Fri, 07 September 2007 20:12 Go to previous messageGo to next message
jromero is currently offline  jromero
Messages: 1
Registered: September 2007
Junior Member
hello i just installed scientific linux on my laptop and it runs ok, but then it dies , the monitor shuts down , and the keyboard does not work at all , i would be very thankfull if someone could help me , thanks in advance..
Re: problem.... [message #16476 is a reply to message #16473] Fri, 07 September 2007 21:49 Go to previous messageGo to next message
silentninja is currently offline  silentninja
Messages: 37
Registered: September 2007
Member
jromero wrote on Fri, 07 September 2007 17:12

hello i just installed scientific linux on my laptop and it runs ok, but then it dies , the monitor shuts down , and the keyboard does not work at all , i would be very thankfull if someone could help me , thanks in advance..


There's no relationship between your question and mine... post a new topic please.
Re: problem.... [message #16478 is a reply to message #16476] Sat, 08 September 2007 04:48 Go to previous messageGo to next message
mastersherin is currently offline  mastersherin
Messages: 35
Registered: January 2007
Location: India
Member

Hello,

I think you have mistaken. When you check the private area from main server, it will show the links as broken,because it is actually linking to the ve's proc and not to the main server proc.
root@me(~)$ ls -al /vz/private/101/
total 92
lrwxrwxrwx 1 root root 39 Sep 8 09:36 aquota.group -> /proc/vz/vzaquota/0000000f/aquota.group
lrwxrwxrwx 1 root root 38 Sep 8 09:36 aquota.user -> /proc/vz/vzaquota/0000000f/aquota.user
drwxr-xr-x 2 root root 4096 May 26 15:47 bin
drwxr-xr-x 2 root root 4096 Feb 22 2005 boot
drwxr-xr-x 4 root root 16384 Sep 8 09:36 dev
drwxr-xr-x 42 root root 4096 Sep 8 09:36 etc


Now start the node 101 and do the followiing

root@me(~)$ vzctl enter 101
entered into VE 101
root@neverdelete//#ls -al
total 92
drwxr-xr-x 22 root root 4096 Sep 8 08:06 .
drwxr-xr-x 22 root root 4096 Sep 8 08:06 ..
-rw-r--r-- 1 root root 0 Sep 8 08:06 .autofsck
lrwxrwxrwx 1 root root 39 Sep 8 08:06 aquota.group -> /proc/vz/vzaquota/0000000f/aquota.group -
lrwxrwxrwx 1 root root 38 Sep 8 08:06 aquota.user -> /proc/vz/vzaquota/0000000f/aquota.user

The link "aquota.group -> /proc/vz/vzaquota/0000000f/aquota.group" is linking to /vz/root/101/proc/vz/vzaquota/0000000f/
See it below,

root@me(~)$ ls -al /vz/root/101/proc/vz/vzaquota/0000000f/
total 263192
-r-------- 1 root root 134754304 Sep 8 09:57 aquota.group
-r-------- 1 root root 134754304 Sep 8 09:57 aquota.user

root@me(~)$
Please refer the attachment index.php?t=getfile&id=401&private=0
  • Attachment: quota.png
    (Size: 75.14KB, Downloaded 2956 times)


Sherinmon A,

Re: problem.... [message #16482 is a reply to message #16478] Sat, 08 September 2007 14:59 Go to previous messageGo to next message
silentninja is currently offline  silentninja
Messages: 37
Registered: September 2007
Member
No I'm not, there's nothing in the /proc/vz/vzaquota INSIDE any vps of the server, there's just nothing there where it should be...

root@vps1 [/]# vzctl enter 103
entered into VPS 103
-bash-3.00# ls -l /
total 160
lrwxrwxrwx 1 root root 39 Sep 4 14:46 aquota.group -> /proc/vz/vzaquota/00000017/aquota.group
lrwxrwxrwx 1 root root 38 Sep 4 14:46 aquota.user -> /proc/vz/vzaquota/00000017/aquota.user
drwx--x--x 3 root root 4096 Oct 1 2006 files



-bash-3.00# cd /proc/vz/vzaquota/
-bash-3.00# ls -la
total 0
dr-x------ 2 root root 0 Sep 8 11:56 .
dr-xr-xr-x 3 root root 0 Sep 8 11:56 ..

Re: problem.... [message #16487 is a reply to message #16482] Sun, 09 September 2007 05:51 Go to previous messageGo to next message
mastersherin is currently offline  mastersherin
Messages: 35
Registered: January 2007
Location: India
Member

hello,

Make sure the second level quota is enable in that vps

# grep -i quotaugidlimit /etc/vz/conf/114.conf
If not please set the quotaugidlimit as follows,then restart the vps.

#vzctl set 114 --quotaugidlimit 500 --save



Sherinmon A,

Re: problem.... [message #16488 is a reply to message #16487] Sun, 09 September 2007 06:19 Go to previous messageGo to next message
silentninja is currently offline  silentninja
Messages: 37
Registered: September 2007
Member
mastersherin wrote on Sun, 09 September 2007 02:51

hello, Make sure the second level quota is enable in that vps




root@vps1 [~]# grep -i quotaugidlimit /etc/vz/conf/103.conf
QUOTAUGIDLIMIT="1000"

It it enabled, but isn't working, that's really why i don't understand it.. because i've other webservers that works totally fine

Isn't there any way to "auto recreate aquota files"?
Like the quotacheck on linux, but for vz

[Updated on: Sun, 09 September 2007 06:20]

Report message to a moderator

Re: problem.... [message #16489 is a reply to message #16488] Sun, 09 September 2007 06:25 Go to previous messageGo to next message
mastersherin is currently offline  mastersherin
Messages: 35
Registered: January 2007
Location: India
Member

Hello,
Can you check the quota module "vzdquota" is loaded or not.

# lsmod |grep -i vzdquota

Also which kernel you using ,rpm or compiled kernel


Sherinmon A,

Re: problem.... [message #16490 is a reply to message #16489] Sun, 09 September 2007 06:41 Go to previous messageGo to next message
silentninja is currently offline  silentninja
Messages: 37
Registered: September 2007
Member
mastersherin wrote on Sun, 09 September 2007 03:25

# lsmod |grep -i vzdquota
Also which kernel you using ,rpm or compiled kernel


root@vps1 [~]# lsmod |grep -i vzdquota
vzdquota 38496 6 [permanent]
vzdev 3584 4 vznetdev,vzethdev,vzdquota,vzmon

Outside the vps, it's installed, i didn't tested inside one of the vps's at the webserver. The kernel i've named previously, it's vzkernel: Linux 2.6.9-023stab016.2-smp
I'm on a x86_64 GNU/Linux (CentOS 5), the odd thing is that I've other 3 webservers installed the exact same way.. that DO work. There must be something we're not seeing in here.
Re: problem.... [message #22631 is a reply to message #16490] Wed, 31 October 2007 20:24 Go to previous messageGo to next message
silentninja is currently offline  silentninja
Messages: 37
Registered: September 2007
Member
Hello, I've tried as far as I can think everything.. I've updated the kernel up to the latest version, vzaquota is installed and updated.. so, that's out of the bounds.

I've also tried to create the folder itself so the quotacheck creates the aquota files correctly, but the server doesn't allowed me to write under the proc folder, so, if I do a quotacheck and fixquotas, the thing solves, but if I restart the vps or the server itself, the aquota files are deleted and new broken links instead of them.. I may be able to do a +i to the aquota files, but hey, if i do that i wont get any quotas working neither.

This is my fstab:

/dev/sda5       /                       ext3    defaults                1 1
/dev/sda1       /boot                   ext3    defaults                1 2
/dev/sda3       /tmp                    ext3    defaults,noexec,usrquota 1 0
none            /dev/pts                devpts  gid=5,mode=620          0 0
none            /proc                   proc    defaults                0 0
none            /dev/shm                tmpfs   defaults                0 0
/dev/sda2       swap                    swap    defaults                0 0


/dev/sdb1       /vz/private/101         ext3    defaults                1 2
/dev/sdb2       /vz/private/102         ext3    defaults                1 2
/dev/sdb3       /vz/private/103         ext3    defaults,usrquota       1 2
/dev/sdb5       /vz/private/105         ext3    defaults                1 2
/dev/sdb6       /vz/private/106         ext3    defaults                1 2
/dev/sdb7       /vz/private/107         ext3    defaults                1 2
/dev/sdb8       /vz/private/108         ext3    defaults                1 2
/dev/sdb9       /vz/private/109         ext3    defaults                1 2
/dev/sdb10      /vz/private/110         ext3    defaults                1 2

/dev/sdc        /backup                 ext3    defaults                1 2

/dev/hda        /media/cdrom            auto    pamconsole,exec,noauto,managed 0 0


My mtab looks like this..
/dev/sda5 / ext3 rw 0 0
none /proc proc rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
usbfs /proc/bus/usb usbfs rw 0 0
/dev/sda1 /boot ext3 rw 0 0
/dev/sda3 /tmp ext3 rw,noexec,usrquota 0 0
none /dev/shm tmpfs rw 0 0
/dev/sdb1 /vz/private/101 ext3 rw 0 0
/dev/sdb2 /vz/private/102 ext3 rw 0 0
/dev/sdb3 /vz/private/103 ext3 rw,usrquota 0 0
/dev/sdb5 /vz/private/105 ext3 rw 0 0
/dev/sdb6 /vz/private/106 ext3 rw 0 0
/dev/sdb7 /vz/private/107 ext3 rw 0 0
/dev/sdb8 /vz/private/108 ext3 rw 0 0
/dev/sdb10 /vz/private/110 ext3 rw 0 0
/dev/sdc /backup ext3 rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
/dev/sdb9 /vz/private/109 ext3 rw 0 0


I've this rpms installed on the main server:
root@vps1 [/]# rpm -qa | grep vz
vzctl-lib-3.0.11-1
vzrpm43-python-4.3.3-7_nonptl.6
vzpkg-2.7.0-18
vzquota-3.0.8-1
vzrpm43-4.3.3-7_nonptl.6
vzrpm44-4.4.1-22.5
vzyum-2.4.0-11
vztmpl-centos-4-2.0-2
vzctl-3.0.11-1
vzrpm44-python-4.4.1-22.5
ovzkernel-smp-2.6.9-023stab044.11


The server is a 64 bits machine, here's the uname and linux distro:
root@vps1 [/]# uname -a
Linux vps1.nuthost.com 2.6.9-023stab044.11-smp #1 SMP Sun Sep 30 13:46:07 MSD 2007 x86_64 x86_64 x86_64 GNU/Linux

root@vps1 [/]# cat /proc/version
Linux version 2.6.9-023stab044.11-smp (root@rhel4-64) (gcc version 3.4.5 20051201 (Red Hat 3.4.5-2)) #1 SMP Sun Sep 30 13:46:07 MSD 2007


I'm really lost.. my clients are worried about their users having unlimited quotas and I've no idea of where this comes from.. the wierdest thing is that i've another webserver hired at ev1 with the exact same configuration and.. that one works.. but this one doesn't :@
Re: problem.... [message #22665 is a reply to message #22631] Thu, 01 November 2007 08:14 Go to previous messageGo to next message
mastersherin is currently offline  mastersherin
Messages: 35
Registered: January 2007
Location: India
Member

what template you using ?
Re: problem.... [message #22694 is a reply to message #22665] Thu, 01 November 2007 15:37 Go to previous messageGo to next message
silentninja is currently offline  silentninja
Messages: 37
Registered: September 2007
Member
mastersherin wrote on Thu, 01 November 2007 05:14

what template you using ?

The template is from a Centos4 with cPanel and the server runs as RedHat Linux.
Re: problem.... [message #23731 is a reply to message #22694] Fri, 23 November 2007 14:17 Go to previous messageGo to next message
silentninja is currently offline  silentninja
Messages: 37
Registered: September 2007
Member
Hi, I'm still having this issue.. I've bypassed the quotas issue by deleting the links, creating the quota files with "quotacheck -a", and fixing the cpanel with "/scripts/fixquotas".. but still each time the server or vz service reboots, this rollback, deletes the quota files and remakes the broken links.. so I've to wait another half an hour for each vps to be fixed.

Do you know any way to recreate the quotas keeping the link file, or avoiding the aquota files for being deleted and pointed nowhere?
Re: Quota file is gone! [message #28579 is a reply to message #16448] Mon, 24 March 2008 16:18 Go to previous messageGo to next message
rickb is currently offline  rickb
Messages: 368
Registered: October 2006
Senior Member
Hi, I have this same problem on 2.6.18 el5 openvz branch. I have moved the VE to another node which has many VEs not experiencing the problem, but the problem remains.

to be clear, the problem is that /proc/vz/vzaquota is empty inside the VE

2nd level quotas enabled
quotaugid set in ve.conf



-------------
Common Terms I post with: http://wiki.openvz.org/Category:Definitions

UBC. Learn it, love it, live it: http://wiki.openvz.org/Proc/user_beancounters
Re: Quota file is gone! [message #28582 is a reply to message #28579] Mon, 24 March 2008 17:33 Go to previous message
silentninja is currently offline  silentninja
Messages: 37
Registered: September 2007
Member
I've replied here with the solution, but my post is gone.. oh well, here goes again.

Check that on /etc/vz/vz.conf there's the "QUOTA" option in ON.. it's that simple. After that, go inside the server and (if you have cpanel) execute /scripts/fixquotas.

If you haven't you may have to do..
vzctl stop ID
vzquota off ID
vzquota on ID
vzctl start ID

I don't remember if the ID on the vzquota should be in the middle, but you'll know if it fails.
Previous Topic: On boot adjustment for /etc/hosts
Next Topic: iptables --update
Goto Forum:
  


Current Time: Sat Feb 04 08:59:03 GMT 2023

Total time taken to generate the page: 0.00863 seconds