OpenVZ Forum


Home » General » Support » trying to install image magick via yum i get error Error: hal conflicts with kernel < 2.6.17
trying to install image magick via yum i get error Error: hal conflicts with kernel < 2.6.17 [message #27549] Tue, 19 February 2008 11:43 Go to next message
slonghurst is currently offline  slonghurst
Messages: 40
Registered: September 2006
Location: UK
Member
when i check on the virtual node what kernal is used,

uname -r
2.6.18-8.1.15.el5.028stab049.1

it brings back the kernel of the host node which is greater than 2.6.17

Any help greatly appreciated
Re: trying to install image magick via yum i get error Error: hal conflicts with kernel < 2.6.17 [message #27584 is a reply to message #27549] Wed, 20 February 2008 06:33 Go to previous messageGo to next message
maratrus is currently offline  maratrus
Messages: 1495
Registered: August 2007
Location: Moscow
Senior Member
Hi,

I suppose that it is some dummy package inside VPS which provides kernel capability. Try to
rpm -q --whatprovides kernel
inside VPS. And try to remove that package.
Re: trying to install image magick via yum i get error Error: hal conflicts with kernel < 2.6.17 [message #27794 is a reply to message #27584] Wed, 27 February 2008 14:16 Go to previous messageGo to next message
slonghurst is currently offline  slonghurst
Messages: 40
Registered: September 2006
Location: UK
Member
hi

sorry for the delay, have only just got back to being able to look at this. When execute that command i get this

# rpm -q --whatprovides kernel
dummy-fedora-core-4-1.0-4.swsoft

i then try

rpm -e dummy-fedora-core-4-1.0-4.swsoft

to which i get these errors.

error: Failed dependencies:
ethtool >= 1.8-2 is needed by (installed) initscripts-8.54.1-1.i386
mingetty is needed by (installed) initscripts-8.54.1-1.i386
module-init-tools is needed by (installed) initscripts-8.54.1-1.i386

I installed the fedora template from the community created section so i guesss it is a problem with this. On the plus side i downloaded the source imagemagick and forced the install and we can now use the functions we wanted. Would be nice to know how to get round this in future though
Re: trying to install image magick via yum i get error Error: hal conflicts with kernel < 2.6.17 [message #27848 is a reply to message #27549] Fri, 29 February 2008 08:49 Go to previous messageGo to next message
xemul is currently offline  xemul
Messages: 248
Registered: November 2005
Senior Member
Try to tune your VE's uname -r with /proc/sys/kernel/virt_osrelease file. Maybe the installer just checks this one.

http://static.openvz.org/userbars/openvz-developer.png
Re: trying to install image magick via yum i get error Error: hal conflicts with kernel < 2.6.17 [message #27856 is a reply to message #27794] Fri, 29 February 2008 12:27 Go to previous messageGo to next message
maratrus is currently offline  maratrus
Messages: 1495
Registered: August 2007
Location: Moscow
Senior Member
Hi,

Before give you any piece of advice I'll try to explain my point of view.
The issue is in the following:
We have a dummy package which provides some kinds of capabilities. To observe them please use rpm command:
rpm -q --provides PACK_NAME
(in your case PACK_NAME=dummy-fedora-core-4-1.0-4.swsoft). As you can see this package is a fake package (it might provide capability but mightn't contain the corresponding utility). I only know two reasons why it was made:
a) Some packages need the capability for example
Quote:

 module-init-tools is needed by (installed) initscripts-8.54.1-1.i386

but actually we cannot load modules from inside VE. And we have to provide this or may be some else capability.
b) We don't want to increase VE's weight so we don't add some unnecessary utilities.

In your case you could look at
rpm -q --provides PACK_NAME
output and install inside VE appropriate packages, for example in your case, kernel,module-init-tools, ethtool, mingetty etc (the common Fedora-4 packages) and then remove dummy package from inside the VE.

I suppose that everything should work and you'll be able to install appropriate software.
Re: trying to install image magick via yum i get error Error: hal conflicts with kernel < 2.6.17 [message #38679 is a reply to message #27856] Fri, 15 January 2010 03:18 Go to previous message
dedicados is currently offline  dedicados
Messages: 46
Registered: February 2009
Location: Mexico
Member

when i try to upgrade my centos, i get error like that

Convert: bla bla bla is needed by package samba

i do

#yum remove samba

and now i can upgrade my OS
Previous Topic: A Big problem with my vps
Next Topic: PAE support inside VE
Goto Forum:
  


Current Time: Sun Nov 27 17:54:16 GMT 2022

Total time taken to generate the page: 0.00940 seconds