OpenVZ Forum


Home » General » Support » TUN device in VE
TUN device in VE [message #27326] Thu, 14 February 2008 19:20 Go to next message
yoolee is currently offline  yoolee
Messages: 23
Registered: November 2007
Junior Member
Hi, all

I am doing a large-scale openvpn performance test, of course on an OpenVZ-based environment. What I want to do is create 1,000 VEs with one openvpn client in each of them. These openvpn clients will connect to a remote openvpn server.

At first I try to run vpn client on hardware node, and move the tun device to a VE by using vzctl set 101 --netdev_add tun0 (I have modified openvpn a little bit). But that command failed as: "Bad parameter ...". Why I did so is to put tun device in VE and the corresponding openvpn process in HN, so it can access to the remote vpn server. And I don't want to use NAT because it will incur additional overhead.

I'am using the kernel 2.6.18-fza-028stab051.1-686-bigmem, on a Debian 4.0 host.

Thanks for your help in advance.

-Yue
Re: TUN device in VE [message #27329 is a reply to message #27326] Thu, 14 February 2008 22:25 Go to previous messageGo to next message
yoolee is currently offline  yoolee
Messages: 23
Registered: November 2007
Junior Member
I have looked into the vzctl code, there is a prohibition of moving tun,tap,lo and venet devices during parse. Can I just simply allow tun device on my host?

Re: TUN device in VE [message #27334 is a reply to message #27326] Fri, 15 February 2008 08:11 Go to previous message
xemul is currently offline  xemul
Messages: 248
Registered: November 2005
Senior Member
You can create tun devices right inside the VE.

http://static.openvz.org/userbars/openvz-developer.png
Previous Topic: Help with failed LockPages UBC
Next Topic: NFS server on VE
Goto Forum:
  


Current Time: Fri Apr 19 14:37:10 GMT 2024

Total time taken to generate the page: 0.01849 seconds