OpenVZ Forum


Home » General » Support » Help with failed LockPages UBC
Help with failed LockPages UBC [message #27289] Thu, 14 February 2008 03:50 Go to next message
joelee is currently offline  joelee
Messages: 63
Registered: April 2006
Member
Hi All,

I've been running this VPS for over 3months with no problems. Suddenly, I noticed my application would not start. I checked the UBC and noticed the "LOCKPAGES" resource registered failcnt...

I tried to increment this parameter with no success. I have not installed anything additional to this VPS. The application running on this VPS is an email/postfix App.

Note: Have not added any other VPS on the system either..

       uid  resource           held    maxheld    barrier      limit    failcnt
      105:  kmemsize         373088     411281 2147483647 2147483647          0
            lockedpages           0          0         32         32          0
            privvmpages         984        997 2147483647 2147483647          0
            shmpages              1          2       8192       8192          0
            dummy                 0          0          0          0          0
            numproc               8          9       1000       1000          0
            physpages           641        641          0 2147483647          0
            vmguarpages           0          0     384000 2147483647          0
            oomguarpages        641        641 2147483647 2147483647          0
            numtcpsock            0          0        200        200          0
            numflock              0          1        100        110          0
            numpty                0          0         16         16          0
            numsiginfo            0          1        256        256          0
            tcpsndbuf             0          0     319488 2147483647          0
            tcprcvbuf             0          0     319488 2147483647          0
            othersockbuf       4464       4464     319488 2147483647          0
            dgramrcvbuf           0          0     132096     132096          0
            numothersock          2          3        250        250          0
            dcachesize            0          0    1048576    4992000          0
            numfile             127        143      13000      13000          0
            dummy                 0          0          0          0          0
            dummy                 0          0          0          0          0
            dummy                 0          0          0          0          0
            numiptent            10         10        128        128          0


Upon booting the VPS the lockpages resource is clean... As soon as I try to ssh into the VPS it fails the ssh connection. And, upon checking the UBC again - I get the failcnt - see below.


      uid  resource           held    maxheld    barrier      limit    failcnt
      105:  kmemsize         698314     923366 2147483647 2147483647          0
            lockedpages          32         32         32         32         22
            privvmpages        3358      54372 2147483647 2147483647          0
            shmpages              6          6       8192       8192          0
            dummy                 0          0          0          0          0
            numproc              14         23       1000       1000          0
            physpages          2240       5770          0 2147483647          0
            vmguarpages           0          0     384000 2147483647          0
            oomguarpages       2240       5770 2147483647 2147483647          0
            numtcpsock            1          2        200        200          0
            numflock              1          3        100        110          0
            numpty                0          0         16         16          0
            numsiginfo            0          2        256        256          0
            tcpsndbuf             0          0     319488 2147483647          0
            tcprcvbuf             0          0     319488 2147483647          0
            othersockbuf      13392      15624     319488 2147483647          0
            dgramrcvbuf           0       8376     132096     132096          0
            numothersock          8         11        250        250          0
            dcachesize            0          0    1048576    4992000          0
            numfile             323        480      13000      13000          0
            dummy                 0          0          0          0          0
            dummy                 0          0          0          0          0
            dummy                 0          0          0          0          0
            numiptent            10         10        128        128          0


Would appreciate any HELP/Suggestions... Can't start the application.

Joe
Re: Help with failed LockPages UBC [message #27293 is a reply to message #27289] Thu, 14 February 2008 07:48 Go to previous messageGo to next message
xemul is currently offline  xemul
Messages: 248
Registered: November 2005
Senior Member
As the quick and easy test you may set llockedpages to some very high value (like 2147483647 Wink) and check the maxheld after the application successful start.

Besides, you may start this app under strace like this
strace -fF -o log -e mlock,mlockall <app>

and check how many memory this application is trying to lock


http://static.openvz.org/userbars/openvz-developer.png
Re: Help with failed LockPages UBC [message #27324 is a reply to message #27293] Thu, 14 February 2008 17:37 Go to previous message
joelee is currently offline  joelee
Messages: 63
Registered: April 2006
Member
xemul, thanks for the reply... I will try your suggestions. However, I have this question. Since, my UBC settings for the lockpages were initial set with the default of 32:32 and the app worked fine for a long time with that setting - I am wondering how it worked with that low setting before. Also, before I posted the error, I increased that setting at 64:64... up to 512:512... and same problem.

I guess I trying to understand if the lockpages value is typically that high? The other nagging question is when I did a vzcfgvalidate against that VPS no error was reported by it. I've had no success in the past where vzcfgvalidate worked - I don't know how useful is this command tool.

Anyway thanks for the tips... I will try them and report findings!

Joe
Previous Topic: Kernel build help
Next Topic: TUN device in VE
Goto Forum:
  


Current Time: Fri Apr 19 15:29:05 GMT 2024

Total time taken to generate the page: 0.01776 seconds